Jump to content

Open this page in "FileMaker Go"?


This topic is 1425 days old. Please don't post here. Open a new topic instead.

Recommended Posts

I made a FileMaker Go 13 solution and made a custom icon for it on the home screen using the iPhone Config Utility. The app and the link all work just fine. But since the icon is basically an URL, it goes through Safari. When clicked, Safari sees the file extension and opens the file in FileMaker Go. But it does this only once automatically, after one click the link is set as browser history. So the next time you click the app icon, Safari asks to 'Open this page in "FileMaker Go"?' with 'Cancel' and 'Open' as clickable options. Very annoying. If you clear Safari's browser history in 'Settings', it opens again in a single run. But right thereafter you get the message again in Safari. Not really user friendly, as the user needs to click 'Open' to continue the app.

I've been looking into scripts that clear the browser history, but there aren't any that I know off. Also, turning on private browsing does not make a difference.

Any suggestions highly appreciated.

Link to comment
Share on other sites

Did not try it yet, iPod is at my customer who's using the app... But I compared the profiles, and the only thing different is this:

 

iPhone Configuration Utility:

<key>URL</key>
<string>fmp://%7E/apptag.fmp12</string>
 
 

FileMaker App Maker:

<key>URL</key>
<string>javascript:window.location='FMP://%7E/tagapp.fmp12'</string>
 
So indeed, maybe the "javascript:window.location" prevents Safari from asking the above...
Will test for sure, but I think this does the trick.
Link to comment
Share on other sites

The app maker works very well. Just make sure you are using the IOS 7 version, assuming you have IOS 7 on your device. Also, if you have both FM12 and FM13 on your device you will have yo remove the FM12 for the app to work with a FM13 solution.

Link to comment
Share on other sites

  • 5 months later...
  • Newbies

The problem with using the app maker is that you can't embed a username & password into the fmp:// url scheme.

 

For example, the fmp:// url scheme allows you to type something like this:

 

fmp://username:[email protected]_Address/DatabaseName.fmp12

 

However, if you use the app maker, it encodes that "@" symbol as a %40, so you are forced to use the iPhone Configuration Utility.

Link to comment
Share on other sites

  • 1 month later...

Hi,

 

You could try using the attached version of App Maker, to create the profile, which I modified so it works with iOS 8... Just go to the 'Settings' tab and make sure you select 'iOS 8' from the 'Supported iOS version' popup menu.

 

Hope this helps...

 

[edit: oops, forgot attachment, should be here now]

App Maker 1.0.4sky.fmp12.zip

Link to comment
Share on other sites

  • 2 months later...
  • 2 years later...

This topic is 1425 days old. Please don't post here. Open a new topic instead.

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

  • Similar Content

    • By juli51
      Hi all,
       
      Is there any way to launch a kiosk mode video from FM Go?
       
      I have a customer who has iPads in his shop for the public to search product information ( it's a very simple catalog). When the iPad is idle he wants a promotional video to start automatically and close when someone touches the screen again.
       
      Thanks in advance...
    • By Goetch
      I am pretty sure this is a known bug in FMGo 13, however, I was wondering if anyone might have a work around.  
       
      I am having an issue with list view in a simple FMGo 13 program.  Basically after about 20 or so records the input field of a new record disappears.  Scrolling the screen will almost always bring it back.
       
      The program is pretty simple, 3 tables, 2 input fields scan and qty.  I made the program to help take our physical inventory.  The user is only interacting with the "scan" table.  The two fields are scan and quantity.  Basically I download the program into an iPhone and pair a socket scanner with it.  I have a script trigger that runs on object save on the scan field.  The barcode and based on a preference either a new record is created or the user enters in the quantity.  Everything works great until about 20 or so records are scanned, then the user can no longer see the input field on the bottom of the screen.  Scrolling up usually fixes this.  The program seems to work flawlessly if the layout is set to form view, however, obviously the user does not see the last few scans in this view.  
       
      Like I said I have read that there are bugs in list view.
       
      Can anyone suggest a work around?  
    • By Rote
      Hi,
       
      I have Filemaker 12 server and when using FileMaker GO 13 on an iPhone I am able to connect remotely when on cellular but when I switch to wifi (still entering remotely) it does not "see" the server. (Host is not available)
       
      I have tried this on two separate wifi locations with the same problem. I even tried it on the WIFI network that the server is on with no luck.
       
      Also replicated the same problem using wifi on an iPad. I don't have cellular o the iPad so I couldn't determine if it would see the server
       
      Is it a magical port I am missing that needs to be opened?
       
      Any help would be appreciated.  I am stumped.
       
      Thanks
    • By milanm
      Hi,
      On iOS, i am trying to open the .pdf file stored inside the container field.
       
      The variable $path is created using "Get ( TemporaryPath)"... and than i use "Export Field Contents" with option to open file automatically.
       
      This works great on FM Client device and opens the PDF file stored inside the container field as expected.
       
      On iOS device with FileMaker Go 13 it gives a 404 Error - "File could not be found". Why?
    • By charlie649
      I have a solution on the iPad using FMGo13 and the user likes to let the iPad sleep without logging out.  When the iPad wakes up I have experienced weird problems from, records not saving, data entry not allowed, not being able to connect to host even though the network and the host show they are available. 
       
      If you restart the iPad the problem is solved and everything works perfectly, only seems to happen after the iPad sleeps
       
      Just wondering if anyone else has experienced this and what the solution was
×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.