Jump to content

Filemaker Uninstalls Windows Services when removed.


RobinW
 Share

This topic is 2576 days old. Please don't post here. Open a new topic instead.

Recommended Posts

  • Newbies

Hi All, I'm a small business computer support guy and have been called into an SBS 2011 essentials server that's cactus. They've tried to upgrade from Filemaker 11 server, which has been running fine for several years I'm told, to Filemaker 12 server. After the change the server services failed, IIS no longer works, remote desktop gateway is gone and the active directory database is corrupted.

 

I restored the machine's C: drive to a date before the change and that restored functionality and filemaker 11 server. I've found if you uninstall filemaker 11 it also uninstalls several services in IIS and remote desktop gateway at least and I'm guessing this corrupts the registry.

 

I knocked up an SBS 2011 VMachine and installed Filemaker Server 12 on it. But if I uninstall it from there I see the same result. Lots of Windows services are removed. So even if I get server 12 going it will kill the box when uninstalled.

 

I believe SBS isn't supported and before I try the same thing on a 2008 R2 virtual running IIS, I'm sure I'll get the same result, does anyone know a way to stop this. I'm tempted to just come in in safe mode and delete the pig off the C: drive, but I'm sure that'll cause other issues. 

Link to comment
Share on other sites

What you are seeing is not normal.  An FMS uninstall does not remove those services.  It does make modifications to the IIS default website as it removes the connection to the FMS Web Publishing Engine (WPE).

 

You are right that SBS is not supported and that could very well be the issue.  I've done hundreds of FMS installs on Windows 2003 / 2008 / 2012 and have never seen this issue so you will not get the same result there.

 

You are removing FMS (after closing the databases and stopping the FMS service) from the "add/remove" control panel?

Link to comment
Share on other sites

  • Newbies

Yes, I tried stopping the service before uninstall and it looked ok, but the services vanished after a reboot. Been at this thing since Friday Arvo, it's now early Sunday :sad:

 

I've reimaged the server, moved filemaker server 11 to another directory in safe mode and manually removed most of it from the registry. Looks good so far. The guy with the server 12 keys is in bed !!!

 

The IIS services like ASP and half dozen others are uninstalled, I can go to server manager and reinstall them to make it go but remote desktop gateway and the corrupt directory database is a real problem to fix.

 

As I said, it did the same thing on a clean installed unconfigured VMachine of SBS 2011 essentials with a filemaker server 12 uninstall. Same services vanished. Somethings not right. I put server 12 on the clean VMachine to see if the install was causing the issue. It's definitely uninstalling that's at fault. 

Link to comment
Share on other sites

  • Newbies

Yes Add/Remove, I'd only use a removal; tool if something won't uninstall.

 

[edit]

Just to tie this off. Removing filemaker 11 in safe mode was no good. Filemaker 12 installed just fine and was running but then said the serial was invalid when accessing the admin console, there must be FM11 licence remnants in the registry. 

 

I imaged the server back to a stable date and filemaker was moved to another machine.

Link to comment
Share on other sites

This topic is 2576 days old. Please don't post here. Open a new topic instead.

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

  • Similar Content

    • By Rich
      Greets, and a happy, holiday season to all.
      This is one of those "Well, I could swear it _used_ to work..." FMP (PC) problems: I want a script to create a custom-named folder on the desktop (PC) [for exporting data purposes] so I used the following (see attached) Send Event command: 
      "cmd /c md " & Quote ( Right ( Get ( DesktopPath ) ; Length ( Get ( DesktopPath ) ) -1 ) & "Job Chop-Chop! Backup" )
      ...in earlier versions of FMP--and if memory serves--it used to work. (See https://fmrift.wordpress.com/2010/02/03/creating-a-folder-from-filemaker-windows/ ). However, when I try to run the script in FMP v17.x the script fails with the following error message in the Script Debugger, "[3] Command is unavailable (for example, wrong operating system or mode)".
      So, I'm trying to figure out why the command's failing--could it possibly be it's because I'm using FMP (PC) in VMWare's Fusion PC emulator (v10.1.4, running in OS Mojave) instead of on a "real" PC? Any ideas for a tweak/fix?
      Cheers,
      Rich

    • By jrich4411
      Good evening people.  As the title states, I am a complete newbie to FileMaker Pro.  I've done some fairly extensive work with Excel, but this is my first experience with databases.
      For now, I'm looking for advice and suggestions.  I promise I will have plenty of "how do I... " questions later, but for now I need to pick a direction to go in with my new project.  I've spent a bunch of hours viewing Intro to FileMaker tutorials on YouTube and I've experimented with creating a couple test databases.  If this is not the correct forum for this question, please let me know.
      So, my wife and daughter are heavily involved with riding horses.  I've been drafted into being on the Board of Directors for our state Quarter Horse Association (Quarter Horse is a breed like Thoroughbred or Clydesdale).   The first thing I discovered is that they have NO association membership database of any sort.   What they do have is simply a file folder of applications for members, one folder for each year.  Me being an I.T. geek by trade, I know there is a better way.  I've at least entered the info into a spreadsheet (my specialty) so we have the info electronically to be able to reference current membership status during our shows.
      I wish to create a database for the membership, which I've done so far.  It has basic info - name, address, etc.  I have an ID field that automatically increments with each record - seems to be a strong recommendation in the tutorials I watched.  I have a field that combines the first & last name fields which I plan on using for looking up membership info, sending renewals, etc later.  I also have a membership year field and here comes my first question.  When I renew a member for the new year, I want to keep the previous year's record in the database - should I ever want to print a report for 2016 membership in 2019 for instance, I can.  So I figure I need a static member ID field that is separate from the record ID field I already have that can be linked to another database which will hold that member's horse information.   Is it possible to have a field that will increment serially when I add a new member but will copy from the previous year's info when I renew a member for a new year?  
      I'm looking for any and all suggestions - links to videos that might help - suggestions for a better way of accomplishing my goal, anything at all.   I'm not a programmer so I don't have that background FYI.
      Thanks!
       
      Jon
    • By GeoSteven
      I am running a server side script that attempts to update records in a MySQL table that is set up as an external data source. It runs without issue for hours to weeks at a time then gets hung on error 512 (Record was already modified by another user). The problem is that I can't figure out how to capture and handle this error. I've tried adding "If get(lasterror)=512 then <skip this record and continue to next> just after the 'Go to Record(next)' but it never gets to that step. Instead hangs on try to move the record pointer and writing error after error to the log. 
      I've searched the forums fairly thoroughly but there is not a lot of info forthcoming. Surely this has been a problem for someone else that has figured out how to handle it. Any suggestions appreciated.
      Will be glad to provide more info on the environment if needed.
      Thanks in advance,
      Steve
    • By vincenzo
      Hello, I am using l am filemaker 15 pro advanced in windows 10 computer (64 bit, 8gb ram).  I buy it few week ago and i converted my database from the old version fm5. The database work properly but it is very slow to open, about 60 second or more. I am working as standalone (no remote connection). I noted thta if the PC is offline (no network or internet connection) the database open in less that 6 second. It is very strange because I have not any ip configuration and any sharing option... what can be the problem?
      Thank you in advance
      Vincenzo
    • By ggt667
      What is wrong when Database appears unavailable to the scheduler, yet regular users are logged in?
×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.