Jump to content

This topic is 2055 days old. Please don't post here. Open a new topic instead.

Recommended Posts

Using FM 11 Server Advanced


I am having a problem with IWP. On the attached picture there is a list of students with choices for teachers to input classes for next year. The choices were set up as a value list and radio buttons. All the students are defaulted to Standard (Using the client). When the teachers access the internet file and select a different radio button, it will only update one student at a time. Is there anyway the teacher can go down the list, click on the desired radio button for each student and then submit the selections to the server?


Is there some script that will accept the buttons then submit the data and go to the next student. I realize that I am looking a multiple records on one screen. But is there a way? Better yet is there a way to select a radio button for each student and then submit the data to the server?


Any help would be appreciated



Link to post
Share on other sites

In IWP you have to explicitly commit the record. You could replace the radio button field with four actual buttons, which would run a script that sets the value and commits the record.


Or, to get the behavior that you envision, you'd need to display the records in a portal rather than a list.

Link to post
Share on other sites

This topic is 2055 days old. Please don't post here. Open a new topic instead.

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Similar Content

    • By GeoSteven
      I am running a server side script that attempts to update records in a MySQL table that is set up as an external data source. It runs without issue for hours to weeks at a time then gets hung on error 512 (Record was already modified by another user). The problem is that I can't figure out how to capture and handle this error. I've tried adding "If get(lasterror)=512 then <skip this record and continue to next> just after the 'Go to Record(next)' but it never gets to that step. Instead hangs on try to move the record pointer and writing error after error to the log. 
      I've searched the forums fairly thoroughly but there is not a lot of info forthcoming. Surely this has been a problem for someone else that has figured out how to handle it. Any suggestions appreciated.
      Will be glad to provide more info on the environment if needed.
      Thanks in advance,
    • By ggt667
      What is wrong when Database appears unavailable to the scheduler, yet regular users are logged in?
    • By Dr. Zathras
      I'm running FMS on OS X 10.9.5. It's serving forty databases, one of which is served to the web via custom web publishing. Everything is running smoothly but the campus security auditor is picking up a vulnerability with the old version of OpenSSL running on OS X 10.9.5's Apache. I addressed this on a different, non-FMS Mac by disabling Apple's bundled Apache and using MacPorts to install Apache2.
      How to do this on my FMS 11 Mac? Just getting MacPorts to install Apache2 is the first problem as port install apache2 fails with a conflicting ports message. I assume this is because the existing Apache is blocking installation of the new version but how to stop the existing one? I tried turning off web publishing in the FMS admin console but port install still fails with the familiar conflicting ports message. Even stopping the web server with Mark Banks' FMSControl didn't help.
      I therefore have a couple of questions:
      How do I stop the existing Apache so MacPorts will install Apache2? Once I have Apache2, how do I get FMS11 to use it instead of Apple's bundled Apache1? Thanks
    • By imdarek
      Hi, I am using filemaker 11 to copy customer info from excel into the database and then it would generate special keys in pdf allowing us to send the file to the customer.
      My access to the filemaker is non-admin, and the import function of customer info has been blocked.
      We are keying in the record one at a time, so we are looking at ways to automate this process.
      When I try to create a new record using applescript with just 
      it was not allowed. There are data that require validation like date and auto-indexed record number.
      So, is there a way we could create new record and then using the set function to copy data into the report?
    • By ggt667
      How can I get ESS access to PostgreSQL from FM11SA?
  • Who Viewed the Topic

  • Create New...

Important Information

By using this site, you agree to our Terms of Use.