Jump to content

Communication Error (22) but the user is setup correctly!?


This topic is 2939 days old. Please don't post here. Open a new topic instead.

Recommended Posts

I have the same exact solution files setup on 2 separate server stacks.  Everything is working perfectly one one, but on the other I'm getting this Communication Error (22) and I cannot figure out why.

The message says specifically...

Quote

Communication Error: (22) The requested URL returned error: 404 - This can be due to an invalid username or password, or if the FMPHP privilege is not enabled for that user.

The files are exactly the same, though.  The FileMaker files themselves and the PHP files.  The usernames and passwords are all exactly the same in both places.  It's just that they are running on different server stacks.  Both, though, are a combination of FileMaker (in-house) with a web server hosted by the same hosting provider.

I have a very basic script setup to test the connection to FileMaker by displaying the available data sources, and it works perfectly (as well as everything else I do via PHP API) from one server.  The same exact script on a different site hitting a different FileMaker server (with a copy of the same FM files on it) is giving me the 22 error.

Everything points to the credentials being wrong or the FMPHP privilege not being set for the user, but that is simply not the case.  Again, it's a mirror of something that works elsewhere, and of course I did check those credentials numerous times to be sure.

The router at both FileMaker servers (working and not working) is setup with the same port forwarding rules, but that said, I am not quite as confident in the router configuration of the location where the connection is not working correctly as I am the other place.  I am not finding any information while Googling about this issue being caused from network config, though.  Everything just says to check the credentials, but I have, and that is not the problem.

Any information I can get on how to potentially fix this would be greatly appreciated.

Edited by DrewAngell
Link to comment
Share on other sites

37 minutes ago, dansmith65 said:

Have you done the Technology Tests on each server? Available from the bottom right of the Admin Console Start page: https://yourserver.com:16000

Ah, I forgot about the test page, actually.  Sure enough, something seems completely messed up.  I've attached a screenshot of what I get when I run the test on this server.  Any idea why that would be happening or how to resolve it?  

In the status area it shows green check marks for everything like all is well, but obviously that's not the case.

 

fm-error.jpg

Link to comment
Share on other sites

Sorry, I'm not sure. I haven't seen that before.

If I had to guess I'd say that the web server/php is miss-configured. You might be able to fix it by re-deploying (I believe that option is available in the top-right of the admin console).

Link to comment
Share on other sites

  • 1 month later...
9 hours ago, angelleye said:

Yes, after I got that scrambled test page I removed and re-installed FM Server, went through fresh deployment, and then the test page worked nicely.  So then my other stuff started working, too.

We tried that and I still have the same issue! I'm going to push on

Link to comment
Share on other sites

This topic is 2939 days old. Please don't post here. Open a new topic instead.

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.