Jump to content

pdf not attaching


Tusif Ahmad
 Share

This topic is 2289 days old. Please don't post here. Open a new topic instead.

Recommended Posts

Hi,

I have a strange type of issue. I tried a lot but sorry could not be able to solve.

I have Filemaker Server 14 Running on mac environment. Also I have users running Filemaker Pro 14 and I am running Filemaker Pro Advanced. I am written a script to send email with invoice attached. Script works fine on my computer with FMPA but when user are running, it is not attaching pdf.
I tried saving file with get(DocumentPath), get(TemporaryPath), GetCurrentDirectory custom function etc. I think I tried all ways but sorry could not be able to resolve this issue. Can you please guide me what the wrong I am doing.

-----------------------------------------------------------------------------------------
Show Custom Dialog [“Warning” : “Are you sure? You want to send account from to this client?”

Set Variable [$cliid ; value: tbl_client::_kp_id_company]

Set Variable [$compn ; value:tbl_client::company]

Go to Layout [“Contacts Form” (tbl_clients_contact)]

Set Variable [ $mfpath ; value; Get (DocumentsPath) & “account.pdf”]

Export Field Contents [ tbl_clients_contact::AccountsCreation_File; “$mfpath”]

Enter Find Mode

Set Field [tbl_clients_contact::_kp_id_company ; $cliid]

Set Field [tbl_clients_contact::EmailFlag ; 1]

Perform Find [ ]

If [ Get ( LastMessageChoice ) = 1]

Send Mail [ Send Via Email Client ; No Dialog ; To : tbl_client_contact::Email ; Subject: “Account Application” Message “Dear “ & tbl_clients_contact::Full Name&”,” & “¶¶ we have opened a ….. “$mfpath”

End if

Go to Layout [ “tbl_clients_account_form_status” (tbl_clients_account_form_status) ]

New Record/Request

Set Field [ tbl_clients_account_form_status::_kp_id_company ; $cliid ]

Set Field [ tbl_clients_account_form_status::Company ; $compn ]

Set Field [ tbl_clients_account_form_DateSent ; Get ( CurrentDate ) ]

Go to Layout [ “Company Form” (tbl_clients)]

Show Custom Dialog [ “Info” ; “Account Form has been Sent ?”]
---------------------------------------------------------------------------------------------------

 

Edited by Lee Smith
adjusted the Font and removed excess returns.
Link to comment
Share on other sites

Hey Tusif,

 Please use the default font when copy and pasting from another application.

Also, adjust the line spacing in your code so that it isn’t three lines between. 

TIA

Lee

Link to comment
Share on other sites

Hi Tusif

This is a known bug in OS X 10.11 (El Capitan) with FileMaker 14 where the files do not attach to the email if you choose 'Perform without dialog'.

If you un-select that option, they work fine and the PDF will attach, but the user has to click the 'Send' button in OS X Mail.

It is fine in OS 10.10. I've never found a satisfactory workaround that doesn't force the user to interact with the email. I was told by someone in FileMaker UK that it is not something FileMaker can fix, it needs to be fixed by Apple.

Link to comment
Share on other sites

This topic is 2289 days old. Please don't post here. Open a new topic instead.

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.