Jump to content
sal88

FileMaker closes when Popover is closed

Recommended Posts

Hello all

On FM 18.03, the closing of a popover, the button of which is in each row of a portal, causes FileMaker to close.

This appears to only happen when the fields which are in that popover (the portal records) are edited.

Has anyone else experienced this?

Thanks

Share this post


Link to post
Share on other sites

Are you able to reproduce this problem in a new file? If yes, post the file so others may test it too.

Share this post


Link to post
Share on other sites

Hi Comment

Please find attached. I think this is down to some poorly made filtering formulas in the portal:

1. The problem doesn't occur if I delete around 7000 of the portal records
2. It also doesn't occur if I remove the carriage returns from:
PatternCount ( ¶ & Clients::multikey_Cloud_Machines & ¶  ; ¶ &  Machines::ID & ¶ )) in the portal filter
3. However if I remove all the other filters and leave just the above one (with carriage returns) it is also OK

Thanks!

portal_popover_filter_problem.fmp12

Share this post


Link to post
Share on other sites

I cannot reproduce the problem:

image.png.ba5677293feb445572e099987ff5014f.png

 

However, in my experience portal filtering becomes unusably slow when the number of records to filter exceeds a few thousands. Perhaps you're experiencing a memory overflow problem.

  • Like 1

Share this post


Link to post
Share on other sites

Did you click away from the popover as soon as you had populated the field? And are you on 18.03? I just tried it on version 17 and the issue didn't occur.

Thanks

Share this post


Link to post
Share on other sites
5 minutes ago, sal88 said:

Did you click away from the popover as soon as you had populated the field? 

Yes.

5 minutes ago, sal88 said:

And are you on 18.03?

18.0.3.317. Under macOS 10.13.6.

Share this post


Link to post
Share on other sites

This seems to be an ongoing problem ... is it the same portal by chance?

https://fmforums.com/topic/98701-crashing-with-filter-formula/

Windows has, over its years, suffered from crashing portals.  I don't remember the specifics but one issue had to do with corrupt fonts.  Have you tried creating a new portal completely?  How about on a new layout?  Have you ever ran Recover on a copy of that file and see if it still breaks?

added: I won't bother testing since I'm using precisely same FM/OS as Michael.

I agree completely though, that filtering a portal is not a good idea with many records.  

Edited by LaRetta

Share this post


Link to post
Share on other sites

Great memory LaRetta! It is a different portal, but what a coincidence that the issue occurred after an upgrade.

I've tried a brand new portal and tables etc but no luck.

For now I have replaced:
PatternCount ( ¶ & Clients::multikey_Cloud_Machines & ¶  ; ¶ &  Machines::ID & ¶ )
with:
not IsEmpty ( FilterValues ( Home_Clients::multikey_Cloud_Machines ; Home_Machines::ID ))

This has fixed it, though you can still see a delay when the popover is being closed. If it comes up again I will implement a multikey field relationship, the multikey field being updated on record entry.

Thank you both for your help!

Share this post


Link to post
Share on other sites

It has crashed a few times (far less frequently however).

I have gone for the global multikey field option, party populated by ExecuteSQL. Filter criteria is now only user defined.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Content

    • By St3v1e
      Hi,
      As a complete novice to FMP, I'm attempting my very first database. We rely on storing our contracts on Google & Dropbox. I've been trying to either embed the pdf's into a "tab", or (my preferred option) to have an "Add URL" button to link to the online pdf.
      I tried adding a field and copying and pasting the URL, but it's not clickable, and I'd need to add another field for each pdf/contract.
      Is there a better more efficient way to do this?
      Thanks
      Steve
    • By johnmarcel
      I have setup a layer with web viewer. I can maneuver within the website just fine but, I would like it if when the website loads it would send 4 carriage returns to get to a specific field within the website.
      If anyone has any ideas on how I can accomplish this it would be greatly appreciated.
       
      Thank You
      John
    • By john renfrew
      Have copied a shell script which works in other settings onto a new machine
      Changes paths - it zips a backup folder and does a ditto command to copy as a zip file to an external drive
      I worked out that I needed to change the sudoers file to allow no password access to the script. Running the shell script in terminal was requiring a password, now it doesn't 
      Added the fmserver user to that too.
       
      If I run the sh script from the admin console as fmserver it fails straight away, if I run it as the local user with its password it appears to run but in fact times out with a fail message, both of which are about invalid account name or password
       
      The script is working fine when run through terminal, doe not require password, just not when triggered from console.
      Does anyone have any light to shine on this???
    • By Otis
      Actually, I guess this could apply to macOS Mojave as well, but is there any way to get the Send Email script to work when creating a Runtime solution in macOS Catalina?
      I'm using FileMaker Pro Advanced 18 to create my runtime solution. I created a button on my main menu to send an email. When I click the button in High Sierra (and all previous macOS versions) it works. But in macOS Mojave and Catalina, nothing happens.
      I know that Apple placed security limits on applications, but there's no way to add my runtime to the list of allowable applications to execute a script. What is supposed to happen is that macOS is supposed to have a pop up that allows you to click to allow this application to run scripts and access mail.app. So this works in FileMaker Pro Advanced 18. However, when I covert my solution to a Runtime, it's no longer "FileMaker Pro Advanced" and instead is considered a Runtime app.
      In macOS Catalina, manually adding my runtime solution to this area didn't work: System Preferences > Security & Privacy > Privacy (tab) > Accessibility > (Allow these apps below to control your computer)
      Is there any way to allow a runtime to have a simple button to click Send Email in Catalina?
      I'm stumped.
    • By Faldo
      Good morning
      I was wondering if anyone had template for a basic home accounts sytem or the schema for the databases.
      Thanks again.
       
  • Who Viewed the Topic

    3 members have viewed this topic:
    brana15  Tony Morosco  ggt667 
×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.