Jump to content
Sign in to follow this  
AVD128

Graphic performance V9

Recommended Posts

What a disappointment !

We have been working on a rather complex program for several months now. The program consists of a dozen of related files, a few tables per file , several layouts per file with TABs due to the extend of information needed to be displayed. Furthermore is each word, on every layout throughout the entire program , linked to a translation table which allows the program and text to be viewed in several languages depending on a main selections. (English,Chinese, Russian…you name it)

The program looks fine in version 8.5 but truly awful in 9.0.!!!

It seems like version 9.0 has introduced a drastic decrease of graphic performance.

Switching files or even switching layouts is …visibly sloooooow….shows flickering of objects….you practically see the backgrounds, lines, buttons, fields etc.etc…being graphically build-up.

This is really unacceptable and for the first time (in 16 years as FM-user and programmer) I’m really ******! This is not the “Best upgrade ever” I’ve been waiting for and paying maintenance fees for an upgrade that destroys all hard work.

Does anyone of you have the same experience or even a better….a solution?

:bang:

Share this post


Link to post
Share on other sites

Can you post screen shots to illustrate your problems?

Share this post


Link to post
Share on other sites

Because you're describing flickering a video would be the most helpful, if possible that is.

Have you updated the video drivers on the machine?

Have you contacted FileMaker's technical support? I've been hearing a lot of complaints on the forums about screen flicking, however when I called support they said they had next to no reports of it with 9.

I'd suggest giving them a call if you haven't already, they may not be able to resolve the issue directly, but they can pass the information up to the engineers. The engineers can't fix an issue they don't know about :

Share this post


Link to post
Share on other sites

I am also going to lean towards it being the video card/driver. I find that since we upgraded to 9 everything is noticably faster. Changing layouts and files is "snappy" now. The computer here that had the flashing problem says that hers got much better since I installed 9 on it.

Forget what video card she has but it's not anything special. The card in my laptop is a Ge Force 6800 and I get absolutely no flashing.

Michael

Share this post


Link to post
Share on other sites

Thank you all for your reactions:

Clarifying the problem in a screenshot is not doable. Its a dynamic problem and only visible during switching of files and layouts.

I checked for updates for the graphic chip but the latest version is already installed. I must say that its not the best graphics driver. The company leases HP computers containing the Intel 865G/GV chipset (Intel extreme graphics2 64 MB ) for 300 employees.

Asking for an upgrade of computers to have Filemaker 9.0 work better is not an option.

AND....on this computer configuration version 8.5 works perfect.

To prove the thesis that its not the graphics card but FM 9.0 I took the biggest workstation i could get my hands on with a high-end Nvidia Quadro FX1500 graphics card. Tested all my files again...and guess what...the problem remains.

so for now....back to 8.5 untill i get the problem solved.

I will report the issue with Filemaker.

Share this post


Link to post
Share on other sites

This is a FM9 problem. We have run into this at our company as well. It has nothing to do with the graphics card. When we switch layout via script in the same db there is not any flickering but when we switch db via script to another layout it seems fm is redrawing the screen. very strange. We will meet with the engineers at the conference in orlando and see if they have a solution or are aware of this. All in all the new features in 9 far outweigh the screen flickering problem and as in the past.. im sure fm will get around to this problem

Share this post


Link to post
Share on other sites

I am using v9 pretty heavily now and I think I may have a possible solution problem you are describing.

If a field on the current layout does not have a valid relationship to the TO for the current layout redraw slows down significantly as FMP tries to resolve the relationship.

Check your layout very carefully and make sure that any related data displayed on the layout has a valid relationship to the TO that you have the layout set to.

Share this post


Link to post
Share on other sites

I checked all relationships as you suggested but no....there aren't any missing.

I still dont get it what causes these problems in V9 and not in V8.5

As a test I created 2 very simple files. Each file with one layout, darkred background with on top a smaller grey plane with 30 fields (6 copies of 5 fields just to fill the screen). Both files are identical but the fields on a slightly different location on screen. If I switch from file 1 to file 2 you just SEE that it takes time for the graphics to be ready.

In version V8.5 switching files from 1 to 2 is done in a split second and not noticable.

The more files you've opened and start switching files the slower and ugglier it gets. (my program has 12 open files on the background)

Maybe windows of multiple open files need another aproach in V9 (minimized, closed...pffff i dont know)_

To increase performance I've decided NOT to use the Filemaker TABS anymore. Scrolling thru heaps of information using TABS shows unstable and slow views. Once I split my TABS into seperate Layouts (pretending it to be TABS) the view and switching is rock solid.

At first I was happy with the FM Tabs because it saved me a lot of programming but speed and looks are more important for the end-user.

Share this post


Link to post
Share on other sites

:) good to hear that I'm not the only one with the problem.

Ofcourse we are very curious with the outcome when you get the change to talk to the Engineerings.

As for....the benefits of V9 outweighing the problems....mmmm i do not fully agree.

I can't wait to use the conditional formatting....and all other new features but not at the expense of slow, unstable views which will eventually annoy the user.

See keep looking for a solution...and in the meantime...viva 8.5

Share this post


Link to post
Share on other sites

Would you mind posting these example files?

I am curious to see if I can see what you are describing.

Share this post


Link to post
Share on other sites

This may be way off but I had an irritating screen problem a while back and it was actually the Microsoft mouse drives from the CD you get when you buy the Intellimouse Optical, turned it off in the msconfig panel and the screen jitter went away.

Share this post


Link to post
Share on other sites

With files hosted on server 9, I have noticed the screen draw delay, but it is only noticeable on a first visit to a layout. Once the layout is cached on the client, graphics performance seems to be on par with 8.5.

Share this post


Link to post
Share on other sites

Use the 'Full Reply' option. There will be a link for 'Manage Files'

Share this post


Link to post
Share on other sites

You can post a file when making a reply or originating a Topic. It is an option towards the bottom of the page in the NEW REPLY.

Look for,

File Attachments:) 0

Valid file types: zip, txt, pdf, bmp, gif,

jpg, png, sit, mov

and then click on:

[color:orange]Manage files

Once you do this, you will get a sub menu;

First You [color:blue]Choose the file

Then You [color:blue]ADD the file

Then you [color:blue]Finish

HTH

Lee

Share this post


Link to post
Share on other sites

This may be way off but I had an irritating screen problem a while back and it was actually the Microsoft mouse drives from the CD you get when you buy the Intellimouse Optical, turned it off in the msconfig panel and the screen jitter went away.

Subject to some further testing, my screen flashing also appears to have disappeared when I did this.

Share this post


Link to post
Share on other sites

a visualisation (vid) of the problem made with a screencorder cannot be posted here.

But attached are 2 of the most simplest of files which already show a difference in graphic speed in V8.5 en 9.0 when switching layouts and files

Graphictest.zip

Share this post


Link to post
Share on other sites

Remind me again what I'm lookin for, and how to use your files to see it.

Share this post


Link to post
Share on other sites

By opening the 2 files I am not sure what I must to do reproduce the effect you describe. Could you tell us step by step what you do from one file to the next to be able to see this problem so that we can attempt to recreate it as well?

Share this post


Link to post
Share on other sites

FM9 is slower then 8.5 You can see this effect by switching between opened files. An other problem with sorted portals. Sometimes you can see the Sort Window working. Never seen in 8.5

Share this post


Link to post
Share on other sites

When I switch files from testfile1 to testfile 2 it is noticable that the graphic build up is slower in V9 than in V8.

I took it a step further by creating 10 testfiles nr 1 opens them all with the "open" command in an init script. When I switch files now via >windows> I see in Version 9 a flickering off all the other 9 files if you look closely. I think it has something to do with the fact that the other files in the background are cascaded. I tried minimizing them...but that makes it visibly even slower like popup windows (file 1 from max to min and file min to max). Due to the fact that all 10 files have different colors field positions button positions and so on...switching is even uglier because you see all these colors fields and buttons passing in a split second.....its just ugly! adn i dont have this problem in V8.5

To speed up performance I'm rebuilding my layouts...no more FM tabs but seperate layouts...and playing with the adjust window command to get the best result.

By the way....if one switches files would you recommend using the "open (file) "script step...or "perform script (external file) "command?

Both do the trick ...but different

Share this post


Link to post
Share on other sites

Belive you me, I am NOT the FM expert you guys are. But I did want to try the test for myself. I discovered there is the flicker in v.9 you state, but not on 8.5. What I found curious is that if I make both file windows (not maximized) there is no flicker when swithing between them. Take a look at the screen cap. I am not sure if this will resolve your problem, by having both your windows visible, there may not be flicker.

Does this help any?

testfm9.jpg

Edited by Guest

Share this post


Link to post
Share on other sites

I haven't notice what you are pointing out.

I suspect that this has more to do with Graphic Cards, and OS, than with FileMaker.

Perhaps if you did some test using other machines, with different OS, and/or Platform, we could be more helpful.

Why not upload your files, and others can also test them for you. You should also post your hardware informations (i.e. graphic card), and your test results, including what happens and when.

Lee

Share this post


Link to post
Share on other sites

I have a feeling this is an issue specifically in windows. The only people that seem to be able to recreate this issue are those who are using the windows version of FM.

Does anyone running windows not have this problem?

If it does not happen for all windows users, it could be some sort of driver issue.

What video card are each of you using and are your drivers up to date?

Share this post


Link to post
Share on other sites

How can it be a display driver? Does FM make direct driver calls to the hardware? I use all types of applications on my PC, from CAD, 3D, Office, Photoshop, video editing, desktop publishing, etc. And nothing flickers like this. I know my video card was pretty high end a few years back, Nvidia Quadro FX500 and the drivers are up to date. ;)

Share this post


Link to post
Share on other sites

Has nothing to do with Graphic Cards perhaps with FM 9 Windows. After maintenance shrinking files in 8.5 FM 9 works better but the effect is still there.

Share this post


Link to post
Share on other sites

Then post the files so that we can test them.

Lee

Share this post


Link to post
Share on other sites

You can test it with every solution you find. Test it with 8.5 and then with 9.0 After maintenance only switching between layouts in the same file is better but switching between different files the negativ effect is still the same. I dont know if the effect can be covered with a script including freeze window ? And i also havent testet the behavior of a runtime solution

Share this post


Link to post
Share on other sites

No I can't. I don't have this problem.

If these files are causing you a problem, then the only way I (we) can test it to see if it is CPU, Video, Graphic Card, platform, OS, or developer related, is to see what the files do on other machines.

Lee

Share this post


Link to post
Share on other sites

Your system is mac and not windows xp but i think mac should also have the same effects. Looks like FM 9 is working through all relations between the files. I have tested now a runtime 8.5 vers 9 the same result. This is a FM problem. I have tested meanwhile on 5 different PCs. Typical FM half developed because of Devcon in August.

Share this post


Link to post
Share on other sites

I agree,

It seems that only the windows users are experiencing these problems. Something must have changed in Version 9 that handles the calls of the Operating system for graphic build up. Instead of only refreshing the requested window and placing it on top, it looks like all open files are being handled separatly and refreshed from last on top to first on top. This effect can even been seen while switching between just 2 files or layouts of one and the same file (although the latter less visible)

I'm using windows XP...tested it on several computers from Intel grahic accelerator to an high end NVidea Quadro FX1500 but the difference remains between V8.5 and V9

so...my conclusion...it has nothing to do with updating graphic card drivers, the graphic card, memory or CPU power. V8.5 looks perfect...and V9 doesnt.

I just hope that the message comes across with Filemaker and the problem can be solved.

Any other suggestions?

Share this post


Link to post
Share on other sites

Does anyone have an update yet on this issue?

Maybe some of you had the change to discuss it during DEVCON

Share this post


Link to post
Share on other sites

Not yet that I know of. Depending on the driver for the video card that you're using, this works very well or very poorly. Likely an issue with FM interacting with the HAL but we won't see it *resolved* likely, 'till the first update.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Similar Content

    • By Justin Close
      I was doing a bit of work for a client who is running FM9 clients, connecting to a file hosted on an FM11 server.  I don't have FM9, so was doing development on FM11.  I thought I had checked out that everything was compatible, but I somehow generated a calculation that doesn't evaluate on 9, but does on 11.  The components of the calculations and custom functions used all appear to be innocuous...  I  am hoping someone here knows what I tripped up on.
      Here's the field calculation, and the 2 custom function definitions that it uses.  The entire point of this calculation is to take a mish-mash text field that they have and make it sort nicely.  For this bit I added, I'm just concerning myself with sorting some suffix numbers that occur between parentheses, e.g. 12345(A-1).
       
      Field calculation definition: Let ( [ _fileNum = Files::File Number ; //Position of 1st open/close parens, and then extract the text between them: _sParen = Position ( _fileNum ; "(" ; 1 ; 1 ) + 1; _eParen = Position ( _fileNum ; ")" ; 1 ; 1 ) ; _suffix = Middle ( _fileNum ; _sParen ; _eParen - _sParen) ; //Count the leading digits before any non-digit character, e.g. an alpha, or dash or space, etc. _count = CountPrefixDigits ( _suffix ; 0 ) ; //Remove extraneous characters (dash, space): _suffix = Substitute ( _suffix; ["-";""]; [" " ; ""] ) ; //Pad out the string to min 5 characters (helps 75-A sort next to 75): _suffix = _suffix & Left ( "!!!!!" ; 5 - Length (_suffix) ); //Reverse the character sequence (so the Code() call works out better): _suffix = ReverseString ( _suffix ) ]; _count & Code ( _suffix ) //prepend the digit count, but don't encode that count, just the rest of it ) -------------------- 'CountPrefixDigits ( aString ; aCounter )' custom function: If ( IsEmpty ( GetAsNumber ( Left ( aString ; 1 ) ) ) ; aCounter ; CountPrefixDigits ( Right ( aString ; Length ( aString) - 1 ) ; aCounter + 1 ) ) -------------------- 'ReverseString (aString)' custom function: If ( Length ( aString ) > 0 ; ReverseString ( Right ( aString ; Length ( aString ) - 1 ) ) & Left ( aString ; 1 ) ; Left ( aString ; 1 ) )  
      Thanks,
      Justin
       
    • By Tumma K
      Hello, All!

      I am an aspiring developer for Filemaker. The company I work with is stuck in the past working off of Filemaker Pro 4.1

      I was given the task of bringing us up to Filemaker Pro/Server 13. So far my conversion prototypes are successful but we recently had a layout issue that can only be fixed in versions 3-6 (as the file is an .fp3) I work off of a macbook while our network is all Windows 7. In order for me to repair the layouts without tampering our active database, I decided the best option is to repair a copy of our solutions off the network. Unfortunately, when I go to download the trial version of Filemaker Pro 6 off of the respected website, the file is corrupt! I've tried multiple times, with different extraction apps and in different directories.

      My question is;

      Does anyone know a place where I could obtain version 6 (or better yet, 4.0) for an OSX computer? I've looked everywhere!
       
      Thank you for your time,
      Tumma K.
    • By MacSig
      Hello everyone.
      How can I set the calculated value of field C to the number of records having field A equal to the value inserted to field A and field B equal to the value inserted to field B?
       
      For instance with the following situation
       
      record 1  =>  A = "house", B = "pay" 
      record 2  =>  A = "house", B = "win" 
      record 3  =>  A = "car", B = "pay" 
      record 4  =>  A = "house", B = "pay" 
       
      when I create a new record having  A = "house", B = "pay"  C should automatically be 2 (since record 1 and 4 have the same A, B.
       
      Thanks
    • By MrEddByrnes
      I'm hoping my question can have a happy ending. In the mid-90's, I purchased Filemaker 3. When Filemaker 5.5 Pro was released, I bought the update CD, which requires the user to either have FM 3 installed or to have the installation CD for FM 3. I've used it all these years, most recently with Windows XP Pro, and it has worked just fine. The databases I began with were long ago converted to FM Pro 5.5 databases.
       
      I'm still using FM Pro 5.5 on a laptop with WinXP Pro, but in 2013, I purchased a PC with Windows 8. I haven't been able to install FM 3 on it, therefore can't install FM Pro 5.5. I am retired and rarely use Filemaker, but I have a few Filemaker databases I'd like to add to my Win 8 machine. I don't feel it's worth upgrading FM for the sake of using a couple of databases.
       
      Has anyone else run into this situation and/or have a (possible) solution? Is there perhaps any other software that can read FM 5.5 databases? Thanks in advance for your help.
       
    • By bmill
      I am using a custom filemaker solution for medical office billing written with fp5 running on a mac with snow leopard. In addition, I have a patient management db (which I wrote) that is linked through pt. ID number to the billing program allowing transfer of some demographic information (name, DOB, etc).
       
      Other than being limited by hardware restrictions, the billing program serves our needs for now and upgrading to fp12 will take some time (and money).  In the meantime, I am upgrading my pt. management program to fp13 and would like to move new patient demographic information from the billing program ( fp5 running on snow leopard through Parallels) and the new pt management program ( fp13 running on OS X 10.9) on the same mac.   
       
      Ideally, demographic information would be entered once into fp5 and then a scipt would make the data available for fp13.
       
      Any ideas on how to make this work?
  • Who Viewed the Topic

    5 members have viewed this topic:
    ChrisOC  historychef  salana46  Reliant_Reed  theusualsuspect 
×

Important Information

By using this site, you agree to our Terms of Use.