Jump to content

Wondering how fast filemaker can be via odbc(MS SQL) when compared to MS Access


mak
 Share

This topic is 2595 days old. Please don't post here. Open a new topic instead.

Recommended Posts

I'v been using Filemaker for more than 5 years.

Most of the time, I was using Filemaker server with filemaker pro as clients.

 

Now, I'm facing the big problem of performance of Filemaker when using ODBC. 

 

If I make MS Access to link to external SQL Server via ODBC, it works okay

(e.g Just easy search something like A_table.a_column="1" and related_B_table_column<100)

 

However, it seems taking forever for filemaker to do the same thing above. 

 

Why does it take so long? Is filemaker supposed to be using with only SQL queries when using ODBC?

Can't I just do regular 'find' after bringing external tables to relationship(database management), and make relationship?

 

Is there any technique to make faster when dealing with ODBC source?

Link to comment
Share on other sites

It's not entirely clear what you are doing that is slow.

 

How do you work with the ODBC external data; ESS, or the "import from ODBC source" and "Execute SQL" script steps?

What's the ODBC source?

What driver are you using?

 

I would strongly suggest that you read chapter 9 of the new FTS book as it describes at length some of things that can make working with ODBC source slow.

Link to comment
Share on other sites

@Wim

 

I work with "import from ODBC source"  and trying to do 'find' in 'find mode'

e.g. There's table A and related table B then both are accessed via ODBC.

I have a layout for table A and it has table B's related field Z.

 

If I go to 'find mode' and type "20100101...20131231", it takes forever to show the result.

 

Am I supposed to use only SQL query in this case?

Link to comment
Share on other sites

You're mixing a few things up:

 

After an "import from ODBC source", that data then lives natively in a FM table, there is no more connection to the ODBC source.  If you do a find on that table, it's a native FM find and it does not reach out to the ODBC source at all.

So if that find is slow, it's something in your FM setup or FM data

(as in: is that an indexed field, is it perhaps an unstored calculation field,...) - how many records are we talking about here, both in the table and in your expected found set?

 

You have may choices to build a found set.

The obvious one is what you are doing and there is nothing wrong with it: a native FM search.

You can use ExecuteSQL() if you want, it just requires a few more hops to then produce the actual found set of records (vs a list of IDs for instance that the function will return).

Link to comment
Share on other sites

This topic is 2595 days old. Please don't post here. Open a new topic instead.

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

  • Similar Content

    • By Buckie
      Tried adding an ODBC source using both MySQL 8.0.22 and MariaDB 3.1.10 drivers in Unicode mode and I can connect just fine, however it's impossible to add a table onto the relationships graph. It sees the table's name but when I try to add it, I get 
      This action cannot be performed because the required table is missing. error. It works fine with ANSI version of the MySQL driver, sans the ability to work with Unicode of course. I've tried multiple combinations, including making the database and the table strictly "latin", it still refuses to add the table. The test database itself is very simple, just a single table and a single field, no spaces and no unicode characters in names. Test/test/test, basically, tested with an empty FM database. The server is running MariaDB 10.4.16. Any pointers to solve that?
    • By 34South
      I previously used ODBC Manager (32 bit)  to great success importing data directly from Filemaker Server to JMP. I recently upgraded to Catalina (MacOS 10.15.5) and knew that one of the casualties would be this ODBC utility. I downloaded the 64 bit ODBC manager from Actual Technologies and successfully installed it but get the following message when trying to open an FM database from within the ODBC interface in JMP:
      dlopen(/Library/ODBC/FileMaker ODBC.bundle/Contents/MacOS/fmodbc.so, 6): image not found
      I have navigated to Actual Technologies' web site believing I should download an ODBC driver but this comes at a hefty price tag, especially when converted to my local currency. Given the increasing costs of maintenance contracts and SSL certificates I had hoped to avoid further expenditure. Do I really need this and is there an alternative?
    • By andyCodling
      Apologies if I've put this in the wrong place.
      My Filemaker solution uses a FM database and an ODBC connection to a MySql database that is used to serve data to a website.
      I have complete read/write access to the data in the MySql database from inside FM and thus control of data published on the site.
      I would like the MySql database to be able to access tables in the FM database in the same manner.
      I have set up an FM ODBC connection to our FM server and that is visible in my local ODBC Manager, have tested the connection and that is good, but I can't see any way in the MySql apps I have installed on my system to create a table in the MySql database using live FM data, in the same way that I can make a table in FM using live data from the MySql database.
      Is it possible to do this?
      My main MySQL app is SequelPro.  And occasionally MySQL workbench and associated tools.
      Thank you.
       
      Andy Codling
       
       
       
    • By TimP
      I have been attempting to connect to a SQL database on my network using Monkeybread Software and each time that I attempt to do it I have encountered the same error, which I have attached here. I have set up an ODBC connection as well as made sure that I had the names correct, however I have gotten the same error message each time. Thank you for your help.

    • By Will_Logic
      Hi, I have been using Base Elements command BE_FileMakerSQL in FileMaker script to SQL select data, and return with '<c>' as field(column) delimiter, and '<r>' as the row delimiter. The below line worked before, I dumped a whole FM database with these delimiters showing in text files. But somehow, now if I run below line, it seems to have changed to ?only allow? 1 character for the delimiter, which of course doesn't make sense anyway with varied characters in the data:
      BE_FileMakerSQL ( $sql_select;  "<c>" ; "<r>" ; $fm_file ) The string this returns now looks like for example: 352265<gwgwh<474848<<wegwgw<65755<gwgw ....
      i.e. it has only taken the first character of the delimiter, I changed delimiter string to test with eg "A≠" instead of "<c>", same problem, it then only inserts "A" as delimiter. Just wonder if anyone can guess what might have happened here?
      Thanks kindly any suggestions!
×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.