Jump to content

This topic is 2016 days old. Please don't post here. Open a new topic instead.

Recommended Posts

Hi,

i am trying to implement Tim Dietrich "EasySync" utility to enable users to work on the system while in areas with poor connection and then sync when back to the office. I know that there is a part of this forum where people discuss only the "EasySync" but i think that my issue is somehow more related to the client - server connection and Psos than to Tims scripts as such.

 

The scripts are using and seam dependent on PSOS feature.

 

First time i installed the demo files and configured the features as per given tutorial it worked fine and processed whatever it was supposed to process.

 

After a few successful intentions the script suddenly stoped working giving an endless loop on any Perform on server instance of the script. I was disabling one by one "Perform on server..." script and testing in Script Debugger and it always stops on the next script that is supposed to perform on the server which pretty much tells me that this particular feature stoped working for some reason (Psos).

 

Why is this happening?

- Is it possible that PSOS feature gets blocked by the server after some time (the server is AWS Wndows 2012 server) or for some reason.

- Could it be just my computer (I am using a Mac for this and i also fullishly upgraded to Yosemite which brought me a lot of issues, maybe this one also has something to do with Yosemite)

Link to post
Share on other sites

You're saying that it seems to execute the PSoS but then stalls on the next script step?  Is there an error generated by the PSoS script step?  Anything in the FMS event log?

 

To test if it is your machine, try it on another machne; that should rule it out.

As to port blocking: I doubt it, PSoS uses the same port 5003 like the client does for other things, so if the port was blocked, the whole connection would drop.

Link to post
Share on other sites

It stops on the Psos script and stucks there, doesnt go neither backwards nor forwards, and gives no error, just looks like it is trying to perform the script forever. The little colored spinning circle shows and it is spinning which on my Mac should indicate that the processor is having issues performing the script step. I have to Force Quit FileMaker to get out of this. This is why i thought it might be something with my system.

I will try to run it from iPad and from a PC to see if it would work from there, but i would really love to get it working on the same system where i am developing so i could test everything more frequently.

Link to post
Share on other sites
  • 1 month later...

I have just seen this problem with easySync and it is directly related to PSoS. The sync worked well on the desktop but when it was moved to the iPad I would get error 812 ( exceeded host maximum capacity). Because it was only occurring on the iPad it suggested to me that I was running out of Go/WebDirect web connections. The developers server licence only has one connection licence so that seemed reasonable. However, moving the hosted DB to a server with more connections did not fix it. The error is related to Perform Script on Server connections. Increasing the number of PSOS connections allowed in the server console cured the problem.

 

This raises the question, why does it work on the desktop? What is the difference between the iPad and the Desktop when handling PSoS?

Link to post
Share on other sites

As far as I know, the only difference between his PSoS is implemented in Go and Pro is that with Go it will require and use a concern connection. However, that being said, if EasySync is configured properly then the connection will only be opened when needed - and then immediately closed when it is not needed. The individual scripts open and close and a connection throughout the sync cycle...

 

On the desktop, no concurrent connection is needed / consumed.

 

As far as the 812 error goes, it sounds to me as if something else is holding a connection open. I would take a look at the solution to see if there are other things (relationships to tables in the hosted database, for example) that might be causing this.

 

-- Tim

Link to post
Share on other sites
  • 2 weeks later...

Thanks for the replies. Still working on this, find it very dificult to implement with PSoS as it does brake and it is very dificult to tell why (whish there was a script debuger for PSoS...). It looks like it runs the script once (just to give you an idea that it could work) and than blocks the server for the second attempt for some reason, than throws a coffe cup and finally ends up (after long, long time) with an error (not always the same).

This i experienced on the Demo files, that where working initially and than stoped working with no obvious reason just after i hapilly told the boss that we could go for it :). I tried to place this on the PSoS part of this forum but they pushed me back here to EasySync section. 

I am now looking into the ways to use parts of the script without PSoS to make it usable for my system (where 15-20 sales people need to sync frequently from a remote connection when on internet) it looks like this approach will get me there somehow.

Still am courious about the PSoS and why would it stop working?

Link to post
Share on other sites

Hard to say without knowing the different errors that you getting returned.  It may very well be a deployment issue where the client-to-server communication is compromised, or the server is not up to the task, or....

Link to post
Share on other sites

Milan -

 

You might want to setup a test that removes EasySync from the scenario. Perhaps a simple database that makes multiple remote calls to a hosted database using PSoS, and see what happens. That might make it easier to troubleshoot.

 

Also, it is possible to run EasySync without PSoS. You can use the standard Perform Script script step, although you'll take a performance hit as a result.

 

Another option, if you are feeling adventurous, is to replace the PSoS calls with XML calls. That would take some work, but it is an option. I'm looking at adding the XML option to a future version of EasySync. It would use the "Fireball" technique that I've blogged about here: http://timdietrich.me/blog/search/?q=fireball 

 

-- Tim

Link to post
Share on other sites

Thank you,

I will try running some simple script using PSoS and look into the logs to see what it reads.

 

I do feel adventurous and will look forward to see how it works with XML, but i decided to go for the traditional Perform Script option for the moment, it shouldn't take that long if they do it regularily (i hope).

Link to post
Share on other sites

This topic is 2016 days old. Please don't post here. Open a new topic instead.

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Similar Content

    • By Philip Sommers
      I currently administer a Filemaker 16 Server and only use Oracle Java for the admin console (web publishing is turned off). We want to get rid of Java rather than start paying for it. Rather than upgrade to FMS18, is it possible to use OpenJDK instead of Java for the FMS16 admin console? If so, is there anyone that can provide some guidance on how to do that?
    • By jjjjp
      After upgrading to FM Server 16, I am seeing that the automatic daily script executed from the server side is no longer doing so without error. The script sends email reminders to workshop presenters scheduled within 4 days. The error code, which I record in a log, is 119. However, that code isn't listed among the error codes listed in the online help:
      https://fmhelp.filemaker.com/help/16/fmp/en/#page/FMP_Help%2Ferror-codes.html%23
      Knowing the meaning of the error may provide useful information that will help me reconfigure the email account settings for the command Send Via SMTP Server.
      Thanks.
       
    • By Fabian
      When running PSoS, I thought the attachments would be stored in the temporary folder and removed when the PSoS-session is over. I find that each attachment creates a folder like "UID@email.com" in the Documents folder, and it stays there after the session. I tried to make the script remove it, but ran into some problems. Any suggestions?
    • By "... you mean these fans?"
      Mr. Ignoramus
      We have a solution in Canada where we moved the db from a hosting company to a LAN ( customers building ) They are using a Mac OS machine running FileMaker 16 server.
      We access the FM 16 server via apple's remote access, having trouble locating where we would put the index.html and php files for our web form that we used when we were hosting on an outside hosting company.  The hosting company put the html/php file in the folder that designated our account number. 
      My question is this ... where would we put the two web files; index.html (form) and the .php (create record in FM) file on the FM 16 server.  I can not seem to locate the instruction via the documentation FM is providing.  Have done several internet search ...
      I am gathering information to pass to the individual helping us with the FM server at location.
      Anybody able to provide a link or guidance I would be grateful.
      Thank you.
       
    • By jduncan
      Hello,
      We recently upgraded from FMS 14 to FMS16 and one of our databases won't open via WebDirect due to the way it's named:  the database title has an ampersand ("&") in it.  This worked just fine for FMS14, but not for FMS16.  The easiest solution seems to be to change the database title.  I'm a little hesitant to jump into this because of a large number of externally held containers.  How would one safely go about changing the database name (I'd like to change the "&" to "and") without losing the linked containers? 
      In case anyone's wondering, I didn't name the database; I inherited it.
  • Who Viewed the Topic

    1 member has viewed this topic:
    Riley Casey 

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.