dmcs

Java.Lang.NoClassDefFoundError

3 posts in this topic

Hi. I've been using 360Works Email plug-in for years on both Mac and Windows with multiple clients, and just today I got an error upon trying to connect using login information that has worked for me for years - java.lang.NoClassDefFoundError: javax/crypto/spec/SecretKeySpec. I get this consistently using their demo, the sample Email client, and my own Filemaker files that previously worked. I'm using the latest version of Java on Yosemite 10.10.5 and the latest version of the 360Works Email plug-in. I'm sure it's only a matter of time before my clients upgrade to whatever incompatibility this is, everybody starts getting this error, and everything comes to a screeching halt. 360Works people - what gives? Is anyone running successfully on a later version of the operating system, perhaps, that I need to upgrade to, probably requiring me to buy a new Mac in the process that costs as much as my house just so I can run a $99 plug-in successfully? Please advise. Thank you. 

Share this post


Link to post
Share on other sites

Hi dmcs,

I have run the Email plugin on Yosemite, El Capitan, and Sierra in FM11-FM15 and have not seen this error. Do you get this error in Windows?

I would like to take a look at your plugin logs. Please send an email to support@360works.com and reference this thread. Reproduce the error and attach the plugin logs to the email. See this page for log locations. Please be sure to attach the logs and send the email before any restarts of FileMaker as restarting FileMaker overwrites the logs.

Share this post


Link to post
Share on other sites

I haven't tried running it in Windows but upgraded to Sierra and didn't get it anymore. 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

  • Similar Content

    • By D Rai
      Hi everyone,
      We keep getting "java.lang.OutOfMemoryError: Java heap space" while 360plugin tries to download attachment for the email with in filemaker. Till now the only solution is to restart the filemaker server completely and the memory gets reset. We use to be able to run the server for week but now restarting every night is not enough. Does any one has fix for it? Do we need to update the java to latest version? I also tried to locate the pre-built custom memory size files in the system as on this link recommends http://docs.360works.com/index.php/Heapspace_Out_of_Memory_Error but unable to locate the file path on the server 'C:\ProgramData\360Works\' where to set the custom memory size for java to set them?
       
      We are running the plugin on
      Windows server 2008 R2
      Filemaker server 12
      Plugin version: 360Worsks Email  ( V1.981 )
      Java version: 6 update 23 ( 64 bit )
      error log DEBUG : Error inserting file for script "Add attachment" : "java.lang.OutOfMemoryError: Java heap space"
       
      Hope to get the reply soon 
      Cheers,
      Rai
       
    • By mkfoley
      When Hotmail auto-replies to a bad e-mail (bad addressee, mailbox problem, etc) it returns a "Delivery Status Notification" email.  However, there doesn't seem to be any message body returned by 360Works Email 2.03 plug-in.  I've tried:
      EmailReadMessageValue("text")
      EmailReadMessageValue("html")
      EmailReadMessageValue("htmlRaw")
      EmailReadMessageValue("body")
       
      Bodies are returned for all other e-mails.
       
      MIKE