Jump to content
Sign in to follow this  
TaiChi56

Text aligning vertical

Recommended Posts

I have a field that holds names, normally four names separated by commas. But right now they are aligned like this:

John Doe,

Jane Doe,

Billy Doe,

Jo Doe

I need to have them listed on one line such as this:  John Doe, Jane Doe, Billy Doe, Jo Doe

I tried importing from a CSV and an EXCEL sheet and it still comes out vertical. 

Any help would be appreciated, thank you. 

Share this post


Link to post
Share on other sites

I'm not sure I understand your description. Is the above the contents of one field, in one record? If so, I would assume that the names are separated by a carriage return (or returns), in addition to the comma. This should be easy enough to test by looking at the result of =

Substitute ( Yourfield ; ¶ ; "" )

 

Share this post


Link to post
Share on other sites

Yes, it is one field in one record. It is a movie database and the field is the actor field. So in my edit box it shows the names one after the other in a vertical format. I want it on one line. I put your code in the actor field in Calculated value under manage database but nothing happened. Was that the correct way to do it? Thank you.  

Share this post


Link to post
Share on other sites
Just now, TaiChi56 said:

I put your code in the actor field in Calculated value under manage database but nothing happened. Was that the correct way to do it?

No. You should try it in a new calculation field. Or you could use the Data Viewer, since you have the Advanced version.

If you cannot make it work, could you post a file that shows this? All we need is one record with one field containing the problematic data..

Share this post


Link to post
Share on other sites

Thank you. I attached a file so you can see what is going on. I am also having problems with the Director field. You can see where the name dropped down a space. If there is more than one director it then does the same thing as the actor field. Thank you for your help. 

FMForumUpload.fmp12

Share this post


Link to post
Share on other sites

As I suspected, you have carriage returns in both fields. In the actor field, every name is prepended with a return:

actors.png.6f1cba856b979200ad36d24f30e7992e.png

In the director field, there is a carriage return both before and after the name:

director.png.5316f49e1aae36e1f327dd3b247e018e.png

If these values are imported, and you want the returns to be removed during the import, set both fields to auto-enter a calculated value =

Substitute ( Self ; ¶ ; "" )

and enable auto-enters in the import dialog.

Share this post


Link to post
Share on other sites

Awesome, that worked great. Thank you very much for your patience and help. Have a great holiday!

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.