Jump to content
naio

System script for backup does not work with Catalina

Recommended Posts

I have FMS17 running a system shell script that does the following:

  1. Tar the latest backup folder and leave it into a specific 'tar' folder
  2. Mount an external volume share
  3. rsync external share and tar folder

The script was running twice a day without any problem until last week when I upgraded the server OS from High Sierra to Catalina.

FMS event log just shows the following:

Schedule "schedule-name" aborted; aborted by user.

Possibly it's a problem with permissions but how to fix it?

Share this post


Link to post
Share on other sites

FMS 18v3 is the first and so far only version of FMS that is compatible with Catalina so you should expect issues when trying to run FMS17 on it.  I would suggest you roll back to Mojave and stay within support parameters.

Other than that: does your shell script do its own logging so that you know how far it gets and what errors it encounters?

Share this post


Link to post
Share on other sites

Thanks for your reply.

I decided to run the script from launchd. I'm not an expert on bash but a tool called LaunchControl has helped me to debug.

So right now I run this at start up:

/bin/mkdir -p /Volumes/share 
/sbin/mount -o nosuid,-d=777 -t smbfs //user:pwd@host.local/share /Volumes/share

This works normally: the share is mounted. From Terminal –only with root privileges– I can see the share properties:

drwxrwxrwx  1 root  wheel  16384  2 jan 21:19 share

I can also see subfolders and its files properties and it all seems fully open, but it's not, because if at the end of the script I add 

/bin/ls -l /Volumes/share

I get an 'Operation not permitted' error.

It makes no sense to me: the same running script that allows for a share mount, denies an ls.

I'm totally lost and I'm afraid that this is about MacOS, not FMS.

 

Share this post


Link to post
Share on other sites

Finally, after many turns, I've found what's going on:

/bin/bash needs to have Full Disk Access privileges. In order to do so I went to Apple Menu > System Preferences > Security & Privacy, selected Privacy tab, unlocked the settings and added /bin/bash to the list.

Now I can read and write the mounted share, but even after doing this the script doesn't work when called from FMS17 but that's a different story: first I should upgrade to FMS 18.0.3 or downgrade Catalina to Mojave, as @Wim Decorte suggested

  • Thanks 1

Share this post


Link to post
Share on other sites

Hi! For all others who would encounter the same issue.

Running FMServer on 18.0.3.319 version and Catalina 10.15.3, I was unable to add additional folder on external disk. FMServer was returning an invalid folder path message. 

I do almost the same thing than @naio :

Quote

Apple Menu > System Preferences > Security & Privacy, selected Privacy tab, and unlocked the settings and added/checked fmserver_helperd.

The issue was solved then.

Hope it helps,

Tomy

 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Content

    • By 360Works
      NEW 360Works FileMaker Plug-in Update!
       
       
      Update available for the entire 360Works plug-in platform providing improvements for both macOS Catalina and Windows
      360Works plug-ins and products improve the capabilities of FileMaker by adding functionality to the FileMaker platform for sync, email management, web services, payment processing, image and file storage, FTP transfers, Apple/Google/Exchange calendar integration, Microsoft Office document manipulation, and much more.

      The team at 360Works strives to provide the best possible service and support to their customers and to always keep their products compatible and flexible.
      We have released new versions of the plug-ins within our product suite with improvements for use on both Mac and Windows operating systems:
      New signed versions of our plug-ins will prevent macOS Catalina from trying to block it. Plug-ins are now notarized to comply with macOS changes in this update. For Windows users, we implemented better handling of child processes. If there is a hard crash, we detect and clean up java processes left running the next time the plug-in starts up. We improved our plug-in logging which will prevent hangups on background logging threads. For registering our plug-ins, we fixed issues with the registration dialog where the registration would not persist.  
        Updated Versions of 360Works Plug-ins:
      Updated Plug-in Plug-in Description 360Deploy 2.8 Automated, simple deployment of new database versions CloudMail 3.3 Send and track email marketing campaigns Plastic 3.2 Payment processing plug-in Scribe 3.2 Read and write PDF, Word, and Excel files ScriptMaster 5.3 Add many new functions & create custom plug-ins Email 3.3 Send and receive text and HTML emails in FileMaker FTPeek 2.3 FTP upload and download from your FileMaker database WebAssistant 2.2 Access internet resources, URLs, and fill out web forms JDBC 2.2 SQL access with JDBC Compatibility Charts 2.2 Easy-to-use charting for FileMaker RemoteScripter 2.2 Trigger scripts on FileMaker Pro from the web or IWP SuperContainer 2.9514 A better container field for FileMaker Go and FileMaker Pro Installing the Update

      Using the plug-in links above you can download the current updated version of the plug-in. Installing plug-in updates are easiest when using the Install Plugin File script step in all environments. For legacy systems, auto-update is supported as well. Find out more at 360works.com/autoupdate.
      Availability

      This is a free plug-in update if you own a valid license for the most recent major version, or are within your maintenance subscription for the license (maintenance applies to Scribe and CloudMail).

      Active 360Works Portfolio Bundle holders with a current maintenance subscription can use all of the updates at no additional charge. The PDF Plug-in and Scribbler Plug-in, available only in the 360Works Portfolio Bundle, have the same platform update as well!

      Please note: if you do not own the current major version or are outside of your maintenance window you will need to purchase the current major version of the license in order to use this update.
      Custom Plug-in Users
      If you have a 360Works custom plug-in, please contact us to get an updated version of our custom plug-in. In most cases, there will be no additional charge for this. (Charges may occur if additional development work is required. Rates will be billed at our hourly consulting rate of $185/hr. Please contact us for custom plug-in information.)
      360Works Support
      The 360Works Support Team is dedicated to your successful use of 360Works plug-ins and add-ons. With your purchase from 360Works, you receive 2 free hours of technical support Monday - Friday from 10:00 a.m. - 6:00 p.m. (ET). However, most questions can be answered at our documentation page. If you need to get in touch with us, requests for support team assistance can be sent to support@360works.com.
      Stay updated with 360Works
       
       
    • By gczychi
      Browsing through my event logs, I am finding weird scripting errors, like:
      ... Information 645 ...local Schedule "Import Main (every minute 8-20)" scripting error (401) at "Import : Import Main : 36 : Perform Find". How can a simple «Perform Find» script step (which works just fine in the server scheduled script, btw.) generate a scripting error? Occasions where the FoundSet = 0 should be considered «normal».
      I also have found other errors, that shouldn't be errors, like «Go to Record/Request/Page [ Next ; Exit after last ]», when there is no next Record.
      What is the best way to prevent this? It’s clogging the log files.
      Thanks a lot for any insight!
      Gary
       
    • By Stickybeak
      Has catalina broken scribe?
       

    • By Koonce
      I have an export script and it tries to save to server i need it to save to the local desktop cannot get scrip to work... I know Im doing wrong... need help thanks in advance.
       
    • By troi
      Updated file management plug-in for FileMaker Pro 18 is compatible with macOS 10.15.
      Alphen aan den Rijn, the Netherlands, September 10, 2019–Troi today announced the immediate availability of Troi File Plug-in 11.0.2 for FileMaker 18. This is a maintenance update in which we tested and improved the compatibility with the upcoming macOS 10.15 (Catalina).
          Improvements in Troi File Plug-in version 11.0.2
      Troi File Plug-in 11.0.2 has the following improvements:
      Tested and improved the compatibility with the upcoming macOS 10.15 (Catalina). (macOS Catalina) Fixed a bug in the Show Select Folder Dialog script step and the TrFile_SelectFolderDialog function where selecting the top folder of a disk would result in the diskname with two colons at the end (instead of one), for example “macHD::”. (Windows) Fixed a bug in the TrFile_GetContents function, where an error code $$-4212 (kErrReadBytesDiff) could be returned when getting the contents of an empty file. Made small improvements to the DataIn.fmp12 example file. Updated the text on the layout of the DragAndDrop.fmp12 example, to better show the “-ScrollDropZone” switch. More detailed information on all changes and improvements can be found on the File Plug-in page.
      You can download the new version there.
      Upgrading to version 11.0.2 is free for all users of version 11.0 and 11.0.1. You don’t need a new registration code.
      Upgrades from older versions are available from US $ 59. You can order upgrades from our shop.
×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.