Jump to content

Indexing Woas


jhomer
 Share

This topic is 5762 days old. Please don't post here. Open a new topic instead.

Recommended Posts

Greetings all

I seem to be encountering a reoccuring problem with indexing. I would like to know if anyone is experianceing similar problems.

In general our problem consists of a several oddities all relating to indexed fields. I have an inventory solution in which we capture a large bit of information regarding our material. I see reoccuring problems when personnel search for material based on a Tag #, Location code, modification date and user. all fields are set to index all. (this does not mean a searxch is done on ALL fields at once. it can be a combiniation of these fields or a single one) This has not been a problem in all previous versions of FM we have used.

With 8 we have two problems.. material is not being found when a search is conducted on those fields. This material IS entered correctly into the system. Also i have had a problem with material showing up in reports that has been moved to the archives file yet an index has been left in the actual inventory in which BLANK records are showing up in finds. This blank material has been seen to be an exact one to one with material moved to archives.

My current patch is to go into the define fields, set indexing to none. OK out of the define fields, then reenter and re-index these fields. After which all finds can be completed and are correct.

Please let me know if you have experianced any similar problems.

Thanks for your time.

Link to comment
Share on other sites

My guesses:

1. Corruption. Hope it's not that!

2. I've seen weird stuff when you get invisible ASCII characters in fields. Are you perhaps cutting & pasting data from a website or emails or importing from a legacy system? You might need to batch process the inputs to clean the junk out.

3. Field Type & Language Settings -- it's possible to store text in a number field, and vice versa, and some things work but indexing won't. Check the field type, and check to see the field indexing is set properly (not Japanese, etc.)

4. Finding for symbols? One that always gets me is the @ character. If you search for an email "[email protected]" it won't be found. Are you perhaps searching for things with symbols?

Link to comment
Share on other sites

In addition to the compressing and recovery of the affected files is there any other course of action to take to ensure the data is cleaned. This is our first encounter with data corruption and we would like to know the best actions to take.

Again thanks for any input you may have to offer.

Link to comment
Share on other sites

If you are sure it's corruption...

There is a widespread belief that once a file has been corrupted, the only safe thing to do is to recover the file, export all its data, and then import that data into a known good backup copy of the file (i.e. one that is known to be good before the corruption first occurred). This was probably true with filemaker 5 (6) format files. I think the jury is out on whether this is still true in filemaker 7 (8) format files.

However, even if you do follow this advice, it's not always easy to know exactly when your file first became corrupted. Sometimes its easy (e.g. if everything was working fine, then one day you had a server crash and the file was then corrupted). But sometimes you just don't know for sure.

Some advice:

1. FileMaker 8 Advanced does a better job at recovery than FM7 (I had at least one corrupted file that would actually crash FM7 when it tried to recover it. FM8A would recover it w/o crashing).

2. The file maintenance commands (compress/optimize) can sometimes help. I've had at least one file where doing Compress/Optimize BEFORE the Recovery step was the secret to recovering it.

3. After recovery, you should probably "Exercise" your file to see if it's really recovered. I'd suggest you create some dummy reports which do things such as summarizing every record in the database (to see if you have any record(s) that are unreadable). You may also want to create a script that modifies every record in the database to see if you can both read and write to every record. This will muck up your modification date, so perhaps do this on a test copy of the recovered file. Also, since corruption can affect layouts & scripts, you should test everything you can.

Link to comment
Share on other sites

I have also found this same behavior. Recovering does seem to solve the problem sometimes, but I have had it re-accure to the same file. Obviously, revovery alone might not always cure the underlining issue. I will have to try the compress suggestions. I would love for FM to auto do the recovery when a file can't be verified intacked and just save a backup.

Link to comment
Share on other sites

Unfortunately, FileMaker has no utility to re-index, which appears to be a big issue in FM7 & 8

Although "recover" does rebuild indexes, it can also remove unexpected portions of your files, even in FM8

for more detailed info, see my post here:

http://masdevelopment.com:3455/1/57?view=print

Link to comment
Share on other sites

This topic is 5762 days old. Please don't post here. Open a new topic instead.

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

  • Similar Content

    • By Tumma K
      Hello, All!

      I am an aspiring developer for Filemaker. The company I work with is stuck in the past working off of Filemaker Pro 4.1

      I was given the task of bringing us up to Filemaker Pro/Server 13. So far my conversion prototypes are successful but we recently had a layout issue that can only be fixed in versions 3-6 (as the file is an .fp3) I work off of a macbook while our network is all Windows 7. In order for me to repair the layouts without tampering our active database, I decided the best option is to repair a copy of our solutions off the network. Unfortunately, when I go to download the trial version of Filemaker Pro 6 off of the respected website, the file is corrupt! I've tried multiple times, with different extraction apps and in different directories.

      My question is;

      Does anyone know a place where I could obtain version 6 (or better yet, 4.0) for an OSX computer? I've looked everywhere!
       
      Thank you for your time,
      Tumma K.
    • By MrEddByrnes
      I'm hoping my question can have a happy ending. In the mid-90's, I purchased Filemaker 3. When Filemaker 5.5 Pro was released, I bought the update CD, which requires the user to either have FM 3 installed or to have the installation CD for FM 3. I've used it all these years, most recently with Windows XP Pro, and it has worked just fine. The databases I began with were long ago converted to FM Pro 5.5 databases.
       
      I'm still using FM Pro 5.5 on a laptop with WinXP Pro, but in 2013, I purchased a PC with Windows 8. I haven't been able to install FM 3 on it, therefore can't install FM Pro 5.5. I am retired and rarely use Filemaker, but I have a few Filemaker databases I'd like to add to my Win 8 machine. I don't feel it's worth upgrading FM for the sake of using a couple of databases.
       
      Has anyone else run into this situation and/or have a (possible) solution? Is there perhaps any other software that can read FM 5.5 databases? Thanks in advance for your help.
       
    • By bmill
      I am using a custom filemaker solution for medical office billing written with fp5 running on a mac with snow leopard. In addition, I have a patient management db (which I wrote) that is linked through pt. ID number to the billing program allowing transfer of some demographic information (name, DOB, etc).
       
      Other than being limited by hardware restrictions, the billing program serves our needs for now and upgrading to fp12 will take some time (and money).  In the meantime, I am upgrading my pt. management program to fp13 and would like to move new patient demographic information from the billing program ( fp5 running on snow leopard through Parallels) and the new pt management program ( fp13 running on OS X 10.9) on the same mac.   
       
      Ideally, demographic information would be entered once into fp5 and then a scipt would make the data available for fp13.
       
      Any ideas on how to make this work?
    • By randyinla
      Hi, can anyone tell me why my on-line database might have stopped allowing me to delete records?  All of my access privileges and passwords are correct.
       
      thanks!
    • By randyinla
      Hi, I still use filemaker 5.5 and am very happy with it and don't want to upgrade.  Does anyone still host filemaker 5.5?  Thanks!
  • Who Viewed the Topic

    7 members have viewed this topic:
    Hijack  marnixkasper  Vishnu Yanala  AlvarHanso  mr_vodka  zhgchen  -Queue- 
×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.