Jump to content

Processing records is extremely time consuming


opsniper
 Share

This topic is 2437 days old. Please don't post here. Open a new topic instead.

Recommended Posts

  • Newbies

Love the solution so far. Once I figured everything out, it seems to work rather well. However, using the EasySync "Sync with Server" script, it seems to take ~2 seconds per record. I have ~30k records, so doing the math, it will take ~16 hours to sync the entire database. This seems a bit extreme, am I doing something wrong? There are no container fields in the database, so this should be a fairly straightforward process.

 

I also want to note that I could not get any of the scripts to work when they were run on the server side, and had to change the mobile settings to run on the client side.

 

Edit: I want to note that I just deleted a few records from the "mobile" copy in order to sync the differences as a trial, but it seems to be parsing EVERY record.

 

Thank you!

Link to comment
Share on other sites

Opsniper --

 

I'm glad to hear that you are enjoying EasySync, and I hope that I can help you work through some of the issues that you are encountering.

 

If you can let me know a little more about what you are trying to do with EasySync, I might be able to help...

 

You mentioned that you are trying to sync 30k records. That's a lot of data, and I'm wondering if you are doing an initial sync of the mobile device against the hosted database of 30k records, or vice versa. Can you tell us more about what you are trying to do, and what those records look like?

 

Also, ~2 seconds per record seems very slow. What type of connection are using? What iOS device are you using? And what can you tell us about the server?

 

You mentioned that you "could not get any of the scripts to work when they were run on the server side." Do you mean that using PSOS isn't working for some reason?

 

-- Tim

Link to comment
Share on other sites

  • Newbies

Tim,

 

All I did for a test was implement the changes to the database as necessary, made a copy of the hosted for the mobile setup, and completed the changes. I then deleted a few records from the mobile copy so I could then test the sync. After I force ended the process because I couldn't stop it, it did in fact sync, but as the speed earlier mentioned. So the immediate thing that bothers me, is that it was processing all of the records even though there was only a 3 record difference.

 

The database is setup with 20 tables, some with ~38 fields, some with ~4, all comprised of Text, Calculation, Timestamp, Summary, and Number fields. The majority being Text and Number.

The idea behind this is that people will be taking the mobile copy out, to change things, and come back needing to sync new data with the host

 

I am running on Windows 8.1, with both the host and mobile files in the same directory (this was for testing purposes), it will be run in production on Ipads.

 

Yes on the PSOS, if I enable PSOS for any of the scripts, they fail.

 

Let me know if you need anymore information!

 

Thanks

Link to comment
Share on other sites

I suspect that the reason you're seeing all of the records sync is that the Mobile database is configured with the records and the "EasySync_Payloads::ES_Last_Pull_UTC_Time" global field is empty. As a result, when you sync, it appears to EasySync that all of the records have been created or modified since the last sync, so it includes all of them in the payload. If you set the EasySync_Payloads::ES_Last_Pull_UTC_Time field to a UTC timestamp greater than the date that you created the records, then the sync should only include new / updated records from that point on. Let me know if you need more clarification on this.

 

You wrote, "I am running on Windows 8.1, with both the host and mobile files in the same directory (this was for testing purposes), it will be run in production on iPads." Is the hosted version of the database running on FileMaker Server? Or is it running locally via FMPro?

 

-- Tim

Link to comment
Share on other sites

  • 5 months later...

Hi 

I am having a similar issue where I did a preload on the mobile database by importing all the records from the hosted database to the mobile database (about 5000 records) and made sure the record uuids on all the hosted as well as mobile database were the same so that it would not sync again. I also changed the es_lastpushtime and es_lastpulltime on the mobile easysyncpayloads table to a time greater than the import time. However after I tried to do a sync again on the mobile - it's taking a very long time and is stuck on the pushing payload to server status. 

I think it is overriding the the last pull/push time - Im not sure but think so. Could you please let me know exactly how to preload data to the mobile file. I seem to have done all that is mentioned on this link ... http://fmeasysync.com/docs-easysync-integration/)

 

but its not working. Also on the mobile easysyncpayloads table I added a record and then set that records last pull/push time to a greater time. I hope that is the correct way of doing it, please let me know if not.

Link to comment
Share on other sites

This topic is 2437 days old. Please don't post here. Open a new topic instead.

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.