Jump to content
SarahS

File Access Protection & Encryption

Recommended Posts

I have a solution that is hosted by FMS14 and remotely accessed by my client.  My development files have file access protection enabled, and I have authorized the opener file to open the UI file, but they do not have encryption-at-rest (EAR) enabled.  Prior to uploading the files to server, I add EAR protection.  I am confused because after the encrypted files are uploaded and I go to open them with the opener file (that I thought was authorized), I get the error message that the opener file is not authorized and I am required to input my full access credentials.  I am willing to do this, but it means that every time I update the files, I have to re-send my client the opener file that has been authorized for the updated files, and they have to download and replace their opener file for all users and I would like to eliminate this hassle for them.

Is there a way to allow the opener file to remain authorized when uploading updated files?  Do I need to add authorization for the opener file while the UI and data files have EAR enabled? 

Thank you for your guidance!

Share this post


Link to post
Share on other sites

This is not expected behavior, especially in the absence of either a copy or a clone of the file.

A snapshot link (FMPSL) may produce better results.

 

Steven

Share this post


Link to post
Share on other sites

Thank you for your response Steven. 

Would a simple copy & paste of the file affect the file access protection (FAP)?  I am using copies of the UI and data files (made with copy & paste), but not of the opener file.  I didn't think copy & paste would affect FAP since when I try to add authorization for the opener file again, it says the opener file is already authorized.

Below is what I tried with the snapshot link suggestion:

 - I logged in to the file using my full access account & created a snapshot link.

 - I closed the program and tried opening the program again with the snapshot link and got the error message below:

"Cannot restore the snapshot link file "open UI_File.fmpsl"  Make sure that the status toolbar is accessible in at least one window of the referenced database."

I do have the status toolbar enabled in my full access account, but not in the other accounts. 

I plan to do a file upgrade soon and can test how the snapshot link behaves with newly uploaded files.

Edited by SarahS

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


×

Important Information

By using this site, you agree to our Terms of Use.