Jump to content
Sign in to follow this  
john9210

fmp17 Can't custom format dates

Recommended Posts

This is a problem I frequently have. I can't custom format a date in the Inspector. I can't make a selection because the drop down menu becomes a long vertical blue stripe and selections are not available. I wonder if this is a FMP problem or a Windows 10 problem. Does any one else have the same problem?

Share this post


Link to post
Share on other sites

Yes, I am currently having this problem as well.  It's not just FM 17 -- I also experienced this with FM15 which I used previous.  I have to restart my FM client for the problem to resolve itself, and I can't find any pattern as to how/when the issue arises.

Share this post


Link to post
Share on other sites

I have this issue in FM12 - FM18 on the appearance tab in the inspector for the object state dropdown, but never anywhere else, solution for me was just click the dropdown to show the huge blue list (sometimes is a shrunken blue list) then click somewhere on the inspector outside of the dropdown, you should see the dropdown text is outlined meaning its still the active field, then just use the arrow keys on your keyboard to select the option you wish. Clicking into another inspector field will commit the change.

This has been the only solution i found since FM12, Filemaker really needs to stop letting these silly bugs go on for so long.

Share this post


Link to post
Share on other sites

I've never experienced this on either macOS or Windows 10 so it may not be a wide-spread kind of thing.  Anyhow; if you feel strongly about the bugs you discover, make sure to report them here: https://community.filemaker.com/en/s/topic/0TO0H000008OQOGWA4

If it requires a change of the feature set, report it here: https://community.filemaker.com/s/ideas and invite people to vote it up.

If you don't then FMI may not hear about your bug or your feature request. And they do pay attention to what comes in on both of those channels.

Share this post


Link to post
Share on other sites

It's a Windows bug and there have been reports about it for years. It's super annoying.

Sometimes you can get to the selection you want by using the arrow keys. Only other option is to restart the app.

Share this post


Link to post
Share on other sites

Fair enough.  It's just never bitten me or any of our projects so I wanted to make sure that the channels to report the issue were clear,

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

  • Similar Content

    • By ThomaStudios
      I have been using FM17Adv for some time.  I am on a MacPro 12-core tower and I had been running macOS Sierra.  All the internal scripts I had in one database worked perfectly.
      I recently updated to High Sierra and now I am getting script errors I don't understand.  And this is from the same exact file I used previously.  I have one script where I want it to open a folder in Dropbox so I can access files there.  But I am getting this error:  Can’t make "Dropbox" into type integer.  Then I get a -1700 error dialog immediately after that.  Can anyone explain how I can fix this.  I have not been able to find anything online.
      The script is a native AppleScript, and I suspect that has something to do with this.  Here is the script:
      tell application "Finder"     activate     open folder " Pieces 2011" of folder "Teaching Material" of folder "Dropbox" of "  ThomaStudios 4TB"     select Finder window 1 set position of Finder window 1 to {2877, 167} end tell
      Thanks.
      J D Thomas ThomaStudios
       
    • By Caio Euzébio
      Hi Guys,
      There are any logic or resource that i can use to make like a "text to columns".
      Make text from field one flow to another fields but only with in the middle of coma regarding your sequence, like a excel?
      Full text with Comas Text1 Separated Text2 Separated Text3 Separated How,Are,You? How Are  You? Could please help me, i need a lot of this resource.
       
       
    • By jim.weeda
      For about 12 years, we've had a FileMaker database import external data from a .mdb  (Access) database that has data that is downloaded from some equipment.  The process has survived several computer upgrades (Windows XP and Windows 7) and FileMaker version upgrades (created in 7 and currently running in 16).  It broke when we moved into the Windows 10 environment.  The script is set up to retrieve the data from the .mdb file and it says it can't access the file.  So when I dive into the script and try to specify the ODBC connection it now asks for a username and password.  We've never had a user name or password tied to either the .mdb file, the ODBC connection, or the FileMaker file.  But no matter what we try, we can't get past this step.  Is this a bug?  What am I missing here?
       
      Thanks in advance.
    • By carlsson
      I don't really know what I'm missing here.
      I have two windows next to each other. I want to activate a Script Trigger on Record Load (I have tried On Layout Enter as well) , and it does that fine as long as I'm only having one window open. But not when I'm switching between the windows. Ie, I want the script to run when I enter the Window.
      Isn't this supposed to work?
    • By john9210
      Excel and Filemaker calculates the difference between two dates differently. I always thought that when you subtract two date from one another, the result was the number of full days between the dates.

      For example:  Calculate the difference between 1/15/19 – 1/9/19.

      There are 5 full days between these dates (10th, 11th, 12th, 13th, and 14th). However, FM and Excel calculations do not result in 5, and they don’t even agree with each other!

      In Excel, Difference = 7

      In FM, Difference = 6

      It seems that when you subtract two dates in Excel the result includes the starting and ending dates and therefore it is not the number full days between the dates. In FM the result seems to include either the starting or ending date (not both), and therefore it also is not the number of full days between the dates.

      What gives?

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.