Jump to content
Sign in to follow this  
Joost Miltenburg

Record Access working local, not while hosted

Recommended Posts

Hi All,

I added security to limit the DataAPI user from accessing certain records, with the limited option. I tested this while running these files on my HD no server. Worked like a charm. After moving the files to FMServer the DataAPI account can access all record in the table all of a sudden.

Any thoughts as to why this is happening?

Kind regards,

Joost

Share this post


Link to post
Share on other sites

What is the calc for rla? 

Share this post


Link to post
Share on other sites

not(IsEmpty(Trim( ind_sent_to_website )))

For both the view and edit options.

Very basis, IMHO.

Screenshot 2019-11-04 at 13.48.56.png

Edited by Joost Miltenburg
added comment

Share this post


Link to post
Share on other sites

A couple of things to check:

- the calc context of the RLA calc

- in production does the Data API account have the correct priv set attached?

- check the data in "ind_sent_to_website"

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

  • Similar Content

    • By Todd W Carter
      When I launch the exe for upgrading to FM 18.0.3, I get a window showing msiexec options. Installation will not start. I am running win 10 Pro, version 1909. Any help will be appreciated.

      Found a way around the issue... Had to drill down to the msp file in the package, clicked on that and the install ran without issue...
    • By Hurlz
      Hi, in the attached database, we collect a range of readings per date. I need to calculate the median for each element (eg temperature, pH etc) across a range of dates. There is one record per date.
      The user will change the range of dates depending on what time period they want to view. The data doesn't need to be summarised by anything.
      I am most of the way there, thanks to this great post: https://www.briandunning.com/cf/298. I have run the script in that link on a field doing a summary list. However, the list doesn't seem to sort as specified in the script, and the median value returned is not always accurate.
      The lab results layout has been temporarily set up so I can see the summary field for each element below the median calculation field, with the actual data in the body. This way I could see what the sort was etc. I've just put in 5 records to test this, and to test what happens when there are odd and even records. sign in is admin/admin.
      Grateful for any help!
      H
       
       
    • By MacFileman
      Hey...
      Thanks in advance for your thoughts and the time reading this. 
      I am currently running server 17, no issues, however, my SSL certificate just expired. Before I go through all the new motions and get a new certificate, you think I should switch to 18 now? Since the world is ending, my server is slower and its a good time to back it up and upgrade to 18. Are there anything noteworthy about switching to 18 at this point and will installing a certificate be any easier in 18? I thought installing a certificate on 17 was a pain in the you know what.
      Any thought appreciated.
      I am also running my server on a Mac. Been very happy, no issues to speak of.
      Thanks,
      Mike
       
       
    • By crayfish
      Hi, I'm trying to do a cURL PUT request using Insert from URL to Discord's API.
      I've successfully completed the PUT request using Postman, but I can't get it to work in Filemaker. 
      I've successfully completed GET and POST requests with Filemaker, so I know my Discord authorization is working.
      Here's the url I'm using (with IDs removed):
      "https://discordapp.com/api/channels/<channel_id>/messages/<message_id>/reactions/<:name:id>/@me" Here are my curl options (with authorization removed):
      --request PUT --header "Authorization: <token>" --header "User-Agent: <user>" --header "Content-Type: application/json"  
      I'm getting this error response:
      <!DOCTYPE html> <html lang=en> <meta charset=utf-8> <meta name=viewport content="initial-scale=1, minimum-scale=1, width=device-width"> <title>Error 411 (Length Required)!!1</title> <a href=//www.google.com/><span id=logo aria-label=Google></span></a> <p><b>411.</b> <ins>That’s an error.</ins> <p>POST requests require a <code>Content-length</code> header. <ins>That’s all we know.</ins> The last line of the response makes me wonder if Filemaker is submitting it as POST and not PUT?
      Any suggestions are appreciated!
      Thanks!
    • By Ben Ball
      HI,
      I have files loaded into filemaker server 18 and suddenly they all keep randomly opening and closing. Very strange.
      Anyone know of such an issue?
      TIA
  • Who Viewed the Topic

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.