Jump to content

File privileges changed


This topic is 6464 days old. Please don't post here. Open a new topic instead.

Recommended Posts

I have a strange, potentially big problem that just popped up. This morning I tried to work on a database I am developing for my school district. I worked on the db two days ago, no problem. Today the files opened, but I am locked out of editing privileges, ie. I can not change permissions or passwords, define fields or scripts, but I can access the Layout mode. I am using the same full access master password I have always used, but the db acts like I am using a limited password I set up for admin.

I have checked all passwords. All are limited access. Then I checked an older copy and the same thing occurred. Then I checked an unrelated db and the same thing is happened.

What is going on?:

I then took the original db and converted it into FM 7. It WORKED!!! The master password works I and I again have full access to the file. Uhhh? In FM 7 I can see the security I have set in FM 6 and the master password is still identified as Full Access.

Oooops!!

Well I just figured it out. Typing out the above gave me an idea of something else to try and that led to the solution. In case this might help someone else and at the risk of embarassing myself, here is the answer.

I went to a different computer and tried again. Same problem, BUT I actually read(!!) the opening message ( the one after entering the password.) First problem with the message. It goes by too fast on my computer. Second problem, the first part of the message is the standard message about opening the file as a multiuser file. I thought the message has just the usual message at startup. On a slower computer I saw that the last part of the message was that the file was locked! The file didn't look locked. When I "Got Info" the file was not marked as locked, but the ownership & permissions stated I could only read the file. Then I remembered...the file is on a USB thumb drive...one with a locking switch! A switch I had never used. A least intentionally. Sure enough the USB drive was locked.

Arrrgh!

Never mind.

(I slink quietly out of the room.)

Link to comment
Share on other sites

This topic is 6464 days old. Please don't post here. Open a new topic instead.

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.