Jump to content

Basic Script Help for Beginner


This topic is 2556 days old. Please don't post here. Open a new topic instead.

Recommended Posts

  • Newbies

Hi, 

 

My client has photos stored in a container field in a table. There are a few thousand, so obviously I need to script it. There are some examples for scripting an export from container fields out there, but I'm getting stuck with an 800 error "filename could not be created on this disk. Use a different name, make more room on the disk, unlock it or use a different disk." I'm trying to write to my /tmp/ folder, so permissions shouldn't be an issue and I don't see any other obvious problems. I've attached a screen shot of my script. Any ideas?

 

Once I get past this, I guess I'll see if the looping actually gets me through all the records in the table. 

 

Thanks!

Mark

post-111514-0-30921300-1405005098_thumb.

Link to comment
Share on other sites

I'm trying to write to my /tmp/ folder, so permissions shouldn't be an issue and I don't see any other obvious problems.

 

This error usually indicates an invalid path. If you're trying to write to the (Filemaker) temporary folder, use the Get(TemporaryPath) function to get its path.

 

See also:

http://fmforums.com/forum/topic/45545-looping-script-to-extract-container-jpegs/?view=findpost&p=212714

Link to comment
Share on other sites

  • Newbies

Hi Comment,

 

Thanks. I'm using Get ( TemporaryPath ) now, but I'm still running into the issue. I even used the data viewer to see the filepath to the temp folder and set full 777 permissions to that folder, just in case. 

 

The data viewer shows my filepath as "filemac:/Macintosh HD/private/var/folders/2y/cs6gwg3s07j7j9k8n7px7f9h0000gn/T/S10.3/C00001.jpg". The expression is: "filemac:" & Get ( TemporaryPath ) & Contacts::_k_ContactID & ".jpg"

 

The other post was useful and helped me add a Show All Records and Go To Layout at the beginning. Attached is my updated script steps.

 

Thoughts?

 

post-111514-0-99529200-1405008533_thumb.

Link to comment
Share on other sites

  • 4 weeks later...

This topic is 2556 days old. Please don't post here. Open a new topic instead.

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

  • Similar Content

    • By John Link
      I have a field named "Databases" with the following values: "CORD", "SDHS", "Y Ballet". This field is displayed as a checkbox set. I recently learned that "CORD" should have been "DSA", so I naively changed "CORD" to "DSA" in the value list but then none of the records that were checked for "CORD" were checked for "DSA", which reminded me that the values in the value list are the values of the field Databases and not labels for checkboxes. I revised the value list to again include "CORD" and its checkbox is again checked for all the records for which it was originally checked.

      I wrote a script, shown in one of the attachments, to insert "DSA" into the Databases field for each of the records that contains "CORD" in that field. When I run the script I get an error message saying "Databases" is defined to contain only specific values, and that I must enter a valid value. How can DSA not be a valid value when it is included in the value list for the field? How can I accomplish what I want to do?

      Does programming scripts in FileMaker ever get easier? I don't write many scripts, but when I do I find it surprisingly difficult to accomplish what I think would be the simplest of tasks.

      Thanks in advance for your help,
      John Link


    • By Tony Diaz
      How do I set a field with a value list item from a script, from a set of tick box values? .. or remove a value list item, but leave whatever else is there alone?
      Looks like GetValue with the name of the value list and the position # of the value, but I'm sure that also means that if I change that value list, I need to change any scripts that reference them by position # too..
      Something like detecting if a string is already there, and if not add it, surrounded by C/Rs, unless it's the first item entry?
      For the first time a field is set, I presume I could just Set Field (field ; "Value List Item"), and if there's only one entry/line in it, just clear it.  But if there's already a value there, I just want to select an additional one.
    • By emncwundy
      I have two iPads connected to FM server. For some reason one ipad (5th Gen running 13.5) will not complete the navigation scripts and shows error messages (no records match this find criteria), however the 7th Gen running on 13.1.1 works fine..... Issue has only begun after purchasing the second, newer iPad. I cannot for the life of me work out what is wrong, or how to troubleshoot and would love some guidance please!! Here is a screengrab of one of the scripts and related layout:
      fm go script issue.tiff Orders iPad layout.tiff
    • By PatrickDes
      Hello everyone,
      I have a Preference table with status options. The user can create a new status and through a script can assign a color (see attachment). The calculation is the following: 
      Allow user abort [off]
      Set error capture [on]
      Set variable [$start ;  value: Get ( ActiveSelectionStart )]
      Set variable [$end ;  value: Get ( ActiveSelectionStart ) + Get ( ActiveSelectionSize ) -1 ]
      Insert Calculated Result [ TextColor ( Middle ( Get ( ActiveFieldContents ) ;  Get ( ActiveSelectionStart ) ; Get ( ActiveSelectionSize) ) ; Get ( ScriptParameter ) ) ]
      Set Selection [ StartPosition : $start ; End Position : Send$ ]
      The ScriptParameter has the color values in RGB: RGB ( 237; 41; 190).
      The Status field is pulled into a Value List for the Product table. Is it possible, once the status is used in the Product table , to convert the text color into a conditional formatting? Is my approach wrong? I am trying to give the user some flexibility.
      Thank you for guiding me.


    • By Agnes Riley
      I'm getting "The file "" could not be opened. Either the host is unavailable, or the file is not available on that host."
      This happens when a script runs. Not a new server, no new files. The file is actually open in the background. The file reference is just "file:".
      I restarted the server. Didn't fix it.
      FMS18.03
      It's apparently intermittent. I copied all the script steps to a new script, then it worked 3 times, but couldn't find the file for the 4th time.
      Any ideas?
×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.