Jump to content

Constant "allowing incoming network connections" dialog


mikedr
 Share

This topic is 2884 days old. Please don't post here. Open a new topic instead.

Recommended Posts

I haven't seen this discussed here (please correct me if I'm wrong). Since the latest update to FMP, every time myself or my assistant starts FMP, it asks if we want to accept incoming network connections, even though the Mac firewall is properly set to let FMP do this (on both Mavericks and Yosemite). That is, the normal workflow is it asks *once*, but it asks *always*.

It appears that this is a known issue, but I'm wondering if anyone here has come up with a good workaround. I've tried re-signing the digital signature for FMP to no avail, for instance.

http://forums.filemaker.com/posts/681ddd5845

Again, a shot in the dark . . . .

Link to comment
Share on other sites

This disappeared on its own for me when I updated to OSX 10.9.5.  I'm using it with FMPA 13.0v4 and FMS 13.0v5.  I won't move to Yosemite until the FM bugs are worked through.  If you've upgraded your Mavericks to 10.9.5, I would love to compare settings to see if it could be isolated on why mine works and yours doesn't.  

Link to comment
Share on other sites

Interesting!   Yes, I first upgraded to 13.0v4, and ran into this issue on Mavericks.  Since have upgraded to Yosemite, and the issue persists.  Frankly, by this time i was expecting a fix from the FM people, since per the link in my original post it seems to be prevalent. 

Link to comment
Share on other sites

When reviewing all information on the subject, it seems some users with 10.9.5 with 13.0v4 also have the issue.  This smacks of some setting within my system which is set differently than those with same versions which fail.  If we can pinpoint that different setting, it might resolve the issue at least temporarily.  I am willing to go through settings with someone else with 10.9.5.

 

I noticed one setting different than the screen shots in the bug reports:  Security & Privacy > Firewall > Firewall Options and I have 'enable stealth mode' checked.  I doubt it would be that obvious nor do I have a clue whether this setting might be involved, but some setting (or combination of them) is prohibiting that message in my system.

Link to comment
Share on other sites

I did try the stealth mode, just to see, but no dice.  Other things I've tried have been to delete FMP from the firewall list, with the idea that it got corrupted, and the next time FMP started it would be the last time that I would be asked, but no dice there either.

 

FWIW, my paralegal has the exact same issue.  She has a totally different type of Mac.  The common denominator for us is that we both first installed FMP with 13.0v3, and then upgraded to v4.  I'm wondering if that has something to do with it.

 

The various posters at the other forum seem to suggest FM has been able to reproduce this bug.  I think the problem is not anything that can be corrected without a further update probably.  That is, when upgrading to v4, something got "munged" with the digital application signature for the app.  Even if I undid whatever setting caused that munging, it wouldn't change the fact that the digital signature has already been munged.

Link to comment
Share on other sites

Well I was on 13.0v3 and upgraded to 13.0v4 as well.  As I said, I've read all the other threads in detail. Well, if someone is not willing to walk through all settings methodically then I guess you are stuck. 

Link to comment
Share on other sites

  • 2 weeks later...

I'm not disputing that the issue exists - it certainly does, only that I was not experiencing the problem so some configuration must be different.  However, I had to reinstall FireFox because of adware junk and when I did, Mac said I had to install OSX.  After that reinstallation, I now get that dialog as well.   :idot:

 

I suppose I could go to a Time Machine backup but it has now been a week and I'm not crazy about that idea.  But the point is ... since nothing changed in my FileMaker configurations, it must be on the OSX side (within some configuration or setting) which causes this issue.  

 

Now I can't even compare with anyone to pin it down.  Still, I believe this is important information and I might add it to that Report A Bug forum thread.

 

Thanks, Rick, for adding another version/update to the list which it affects!

Link to comment
Share on other sites

This topic is 2884 days old. Please don't post here. Open a new topic instead.

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.