Jump to content

Text formatting and the calculation engine


Fenton
 Share

This topic is 6522 days old. Please don't post here. Open a new topic instead.

Recommended Posts

Most interesting. I got an enquiry from a client in Japan (who are really happy about 7), about resetting a font to the layout default, after an import. I discovered that our old work-around, setting the field to itself did nothing.

So I tried the new Text Formatting function, TextFont(). It worked. Then I tried my old "MergeStyles" file, which had a letter text field, with custom merge fields Substituted by calculation.

In pre-FM7, I was preserving styles through a calculation with an AppleScript routine. Amazingly it now works fine as is, styles are preserved by the calculation engine. We can build real letters folks, native, cross-platform!

Version: v7.x

Platform: Mac OS X Panther

Link to comment
Share on other sites

To continue the discussion. I found that importing the Japanese text was not a problem, once I set the index of the field to Japanese (duh). Then the Field Format of a Japanese font stuck.

I had a bit of trouble with the "Furigana" option, which is way cool. It puts a translation of the Japanese (English in my case, Roman) into another field.

The trouble was in getting it to happen. The only way I could figure to trigger it was the old stand-by of cutting then pasting the text in the Japanese field, to trigger the Furigana option and populate the 2nd target field. Not only that, but it would not work on the client's Windows XP machine. So I did it on my eMac.

So the question is, does anyone know how this can be triggered, other than by manually entry? (which is I suppose what it's primarily designed for). Auto-enter didn't seem to do it, though I was having trouble getting that option anyway, as it was an Excel file being imported.

Another observation, not really related. I believe someone else was saying that editing styled text was not good in XP. That the cursor was impossible to place correctly after the text. Well, it's the same in Mac OS X. The cursor seems to think the text is still the same size as it was before being formatted. This makes it impossible really to edit. Sometimes the cursor goes right down the middle of a letter, or is one whole letter off.

Not a big deal if you're running a merge and there will be no editing afterwards, but definitely an insect. I wonder no one caught this. Or probably they did but it's very difficult to fix cross-platform, styled text being one of those things each platform wants to do its own way.

Link to comment
Share on other sites

This topic is 6522 days old. Please don't post here. Open a new topic instead.

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.