Jump to content

Bit rot in FMP7


This topic is 7398 days old. Please don't post here. Open a new topic instead.

Recommended Posts

I have a complicated database to track my photos, and I have been putting off upgrading it until I could get my hands on FMP7. Having just spent the last week working on a new version of the database, I am seriously considering putting my new copy of FMP7 on the shelf and continuing using FMP6.

I love the new features of FMP7--although the scripting environment is so mouse heavy that I am getting stress pains in my right hand. And my solution seems to be coming together quickly. However, I am experiencing "bit rot" in my files and it has me so worried that I think I shouldn't continue using FMP7.

The first relations I built worked just as advertised. Then I started combining tables from external files, and the portals started acting funny. First they wouldn't update when I added new records in the associated table. I found that I could fix this by clicking on the window zoom button to update the screen--or in a script by adding the steps "Set Zoom Level 75%" and "Set Zoom Level 100%". This worked for a while, but (as described in an earlier post), relations then started showing completely wrong data. The underlying data is there, and the relation appears to be functioning correctly (I believe I can get all the data through scripts), but the data display in the relation is just wrong, making the file unusable.

This does not appear to be a function of the size/complexity of the solution, as the problem continues even after I remove the external file references and most of the tables, fields, and data. Nor does "recovering" the file help. It appears that somehow, something basic in the internal data structures of the file broke while I was editing it, and the only solution is to start over and redefine all tables, fields, relationships, scripts and reimport the data. UGH!

I never had problems like this with FMP6, and I am afraid to continue using FMP7.

Thoughts?

FileMaker Version: Dev 7

Platform: Mac OS X Jaguar

Link to comment
Share on other sites

It seems to me more likely that you have an unexpected combination of the table occurrence of the layout, that of the portal, and that of the field in the portal. I'm not completely up to speed on 7; but this part of it is new, the table occurrence for a layout, and can be confusing.

Link to comment
Share on other sites

Fenton,

Thanks for the comment, but no I don't have what you described. If you go to my thread before called "HELP! Portal redraw problems" (to which I haven't received any replies), there is a small database as an attachment. That database has 1 table, 3 fields, and 1 relationship, and it shows the redraw problems (at least on the two computers that I have). Go to one of the portals, if you click in the scroll arrow, you will see one update problem, and if you click in the "page down" area below the thumb of the scroll bar you will see another problem.

I don't know if these problems are restricted to FMP7 under Mac OS 10.3 or are more general.

I'd love your comments after you check it out.

Thx

Link to comment
Share on other sites

This topic is 7398 days old. Please don't post here. Open a new topic instead.

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.