Jump to content
Sign in to follow this  
smorr

Bug?? Define Dialog konks out on delete field

Recommended Posts

I have run into a problem over the last couple of days.

I am building a solution and I needed to delete a field I found obsolete. I opened up Define Database. select the field and hit delete... then the defined database dialog just konks out. So I went back to Define database and see the field still there but now when I try to delete it, FMP 7 says that the data definitions are being edited by someone else (ie me!)

Now here is the weird part... After this happens, my scripts will not execute. I start a script and it just hangs on the first step -- I have to cancel the script to exit it. (FMP doesnt crash and the DB appears OK in all other ways)

Although the database hadn't ever been corrupted or recovered (ie hinting to some underlying unfixed problems), I went back to a earlier backup of the database and started there thinking there maybe some sort of corruption not showing. In the older version, I tested out the delete -- worked fine... Spent a couple of hours, copying an pasting calculations yada yada. Then tried the Delete field again and Boom -- it happened again (konked out define database dialog and scripts not working) --Even though I had not quit or had FMP crash between the point it was working and the point that it was not working.

This occurs in FMP7 FMD7 (OS X) and FMP 7 Windows.

can anyone shed some light on this situation -- Is this a bug in FMP or a corruption in my database that is lurking until I have a certain number of fields or B)??

Scott Morrison

Share this post


Link to post
Share on other sites

Important piece of info! -it was a new FM7 DB -- based on a fm6 solution but my pet project for learning the ins and outs of 7

Share this post


Link to post
Share on other sites

Confirmed BUG

This seems to have to do with a nested Case statement that in a setfield that refers to the field being set.

I have a script with a set field step that basically sets a status flag on a record:

Set Field [CurrentAllocation:B)_Status;

Case (ParamByName("Status") = "Toggle"; // if it says to toggle,

case(CurrentAllocation::_Status = "Closed"; "Current"; "Closed"); // toggle btwn close & current

ParamByName("Status") //otherwise, set to parameter

)

nb ParamByName is a custom function

When The script step reads as above, I cannot delete a field in the define Database Dialog. (I have consistently observe this.) Upon deleting, the define Database dialog dies and then Filemaker will not run any more scripts (in ANY database) until it is restarted.

If I use an if statement with the equivalent logic -- I can delete fields with no problem.

If I use a case statement where the test does not involve the field being set, there is no problem. It is only when the second case statement tests the field that is being set does it prevent me from deleting fields.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

  • Similar Content

    • By Tony Morosco
      I'm a botanist, and the tables I am working with are for tracking botanical garden collections. The data represents plants in the garden, and the plants are tagged and show up in the database.  The tables I am working with were created in FMP 7, and I'd like to open them up in FMP 11 (or later.)  The system hasn't been used in years, but still has valuable information.
      One of the tables is giving me problems using the FMP convert and recover commands.
      These tables are all inter-related.  The main table is the Accessions table, which contains records for all of one kind of plant, from the same source, received on the same date.  It is basically a museum standard.
      The other tables are related to each other through this one main table.  The Species table is related to the locations table through the Accessions table. 
      (i.e.  table A relates to table C through the table B, the intermediary)  
      From the Locations table, we can't see the the species information unless the accessions table is present.
      When issuing the open command on the main table to convert the database to FMP 11, I get the message:
      "Accessions.fmp7" is damaged and cannot be opened.  Use the Recover command to recover this file. When using the Recover command from v. 11, I get another message:
      WARNING: problems were detected while recovering the database.  Please review the Recover.log file to see where problems were found and their severity.  The recovered file should NOT be used going forward; copy only the most recent work from it into a backup copy of the original file. Recovery results:   File blocks: scanned and rebuilt 563 blocks, dropped 214 invalid data blocks.   Schema: scanned fields and tables, 1 items modified   Structure: scanned; 1 items modified   Field indexes: rebuilt  
      Opening the recovered database, there are only three records present.  There should be hundreds.  So obviously I am looking on how to wrangle this database open.
      I've attached the log file here, as well as the database structure map.  
      The other files have converted just fine.  But since the main table won't open, we are kind of stuck.
      I can share the files with you through Dropbox or whatever, if needed.
      Please let me know any thoughts you have, either basic or advanced.  And ask for any clarifications or additional questions.   :-)  
      Thanks!
      -Tony
      Recover.log

    • By Tumma K
      Hello, All!

      I am an aspiring developer for Filemaker. The company I work with is stuck in the past working off of Filemaker Pro 4.1

      I was given the task of bringing us up to Filemaker Pro/Server 13. So far my conversion prototypes are successful but we recently had a layout issue that can only be fixed in versions 3-6 (as the file is an .fp3) I work off of a macbook while our network is all Windows 7. In order for me to repair the layouts without tampering our active database, I decided the best option is to repair a copy of our solutions off the network. Unfortunately, when I go to download the trial version of Filemaker Pro 6 off of the respected website, the file is corrupt! I've tried multiple times, with different extraction apps and in different directories.

      My question is;

      Does anyone know a place where I could obtain version 6 (or better yet, 4.0) for an OSX computer? I've looked everywhere!
       
      Thank you for your time,
      Tumma K.
    • By MrEddByrnes
      I'm hoping my question can have a happy ending. In the mid-90's, I purchased Filemaker 3. When Filemaker 5.5 Pro was released, I bought the update CD, which requires the user to either have FM 3 installed or to have the installation CD for FM 3. I've used it all these years, most recently with Windows XP Pro, and it has worked just fine. The databases I began with were long ago converted to FM Pro 5.5 databases.
       
      I'm still using FM Pro 5.5 on a laptop with WinXP Pro, but in 2013, I purchased a PC with Windows 8. I haven't been able to install FM 3 on it, therefore can't install FM Pro 5.5. I am retired and rarely use Filemaker, but I have a few Filemaker databases I'd like to add to my Win 8 machine. I don't feel it's worth upgrading FM for the sake of using a couple of databases.
       
      Has anyone else run into this situation and/or have a (possible) solution? Is there perhaps any other software that can read FM 5.5 databases? Thanks in advance for your help.
       
    • By bmill
      I am using a custom filemaker solution for medical office billing written with fp5 running on a mac with snow leopard. In addition, I have a patient management db (which I wrote) that is linked through pt. ID number to the billing program allowing transfer of some demographic information (name, DOB, etc).
       
      Other than being limited by hardware restrictions, the billing program serves our needs for now and upgrading to fp12 will take some time (and money).  In the meantime, I am upgrading my pt. management program to fp13 and would like to move new patient demographic information from the billing program ( fp5 running on snow leopard through Parallels) and the new pt management program ( fp13 running on OS X 10.9) on the same mac.   
       
      Ideally, demographic information would be entered once into fp5 and then a scipt would make the data available for fp13.
       
      Any ideas on how to make this work?
    • By randyinla
      Hi, can anyone tell me why my on-line database might have stopped allowing me to delete records?  All of my access privileges and passwords are correct.
       
      thanks!
  • Who Viewed the Topic

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.