Jump to content
Sign in to follow this  
Al Hannenberg

FM 4.1 to FM 7 Performance Tuning & Conversion

Recommended Posts

I've worked with an excellent third party''s FM database for a number of years, currently operating under a 9.2 environment with Mac G3's and FM4.1V2. We purchased the product with a number of user licenses. Unfortunately, the owner/developer of the database software has moved on to other ventures and has not upgraded their product to operate in an environment beyond FM5.

Preparing for a migration to a G4 or G5 (ideally) machines, with OSX.2.or OSX.3 environment, I set up a X.2.8 and FM7 testbed. Converting files was successful and I could launch my database in FM7. The following problems were encountered and I would appreciate any suggested specific or general remedies. I sense the need for engaging a 3rd party in concert with the existing database developer. The types of problems fall into two general categories: FM4.1 to FM7 conversion issues and FM7 post conversion database performance issues. As I am not a programmer, but rather an owner of a firm that acquired long ago the usage rights to the database, my formost concern is being able to adapt to an OSX environment, providing longevity to our mission critical database. Note that I have maintained over the years a cordial relationship with the 3rd party database software developer.

Conversion Issues

- The account is my former password. Can I as a user/owner change my account, or will this privilage defer to the administrator/owner of the 3rd party database. I have administrative rights at this point to the workstations only.

- I successfully amended the password used for the entire set of 16 relational databases. What was strange was that while I was performing the password changes, I received messages indicating "Your access privilages do not allow you to perform this action." Apparently, this message was not accurately representing my ability to execute changes. Would these messages indicate any flaws in the initial release of FM7? What is strange is that we always have had user rights in the combined OS 7, 8 & 9 and FM4.1 environment to change our password.

- To consolidate the 16 database logins, I used the option box to chain the logins. Now I can readily open all databases, unintentionally providing such access without need for any login whatsovever. However, at launch, I receive 16 notices indicating that "Your access privilage does not allow you to perform this action." I can still navigate between the databases. Finding warning messages to be inaccurate, I am uncomfortable with the security integrity of my databases.

Performance Issues

- Running a simple query in either of two notes fields within my prevailing OS9.1 and FM4.1 environment, I can render results in a fraction of a second, sifting through 11K+ records. Running similar queries in the same notes fields of my FM7 converted files renders horrific query delays, stretching into minutes. Would this simply be as a result of 4.1 to 7 conversion limitations, which would be expected? Are these typically problems that can readily be corrected?

Again, I appreciate any of your comments or suggestions.

Al Hannenberg

Share this post


Link to post
Share on other sites

Regarding your speed issues: In FM7 a solution should (at least) work as fast as in FM4. But there have been some discussions about FM7 speed issues in this Forum during the last months. I don't remember all the causes, that were mentioned, but I would start with checking the file references in your converted FM7 files. For details have a look at the technical briefs from FMI ( http://filemaker.com/upgrade/techbriefs.html ). There's also a tool by New Millenium called

Share this post


Link to post
Share on other sites

Detlev, thanks for your posting and the reference to the technical brief; I'll review it before submitting further inquiries.

Al Hannenberg

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

  • Similar Content

    • By Tony Morosco
      I'm a botanist, and the tables I am working with are for tracking botanical garden collections. The data represents plants in the garden, and the plants are tagged and show up in the database.  The tables I am working with were created in FMP 7, and I'd like to open them up in FMP 11 (or later.)  The system hasn't been used in years, but still has valuable information.
      One of the tables is giving me problems using the FMP convert and recover commands.
      These tables are all inter-related.  The main table is the Accessions table, which contains records for all of one kind of plant, from the same source, received on the same date.  It is basically a museum standard.
      The other tables are related to each other through this one main table.  The Species table is related to the locations table through the Accessions table. 
      (i.e.  table A relates to table C through the table B, the intermediary)  
      From the Locations table, we can't see the the species information unless the accessions table is present.
      When issuing the open command on the main table to convert the database to FMP 11, I get the message:
      "Accessions.fmp7" is damaged and cannot be opened.  Use the Recover command to recover this file. When using the Recover command from v. 11, I get another message:
      WARNING: problems were detected while recovering the database.  Please review the Recover.log file to see where problems were found and their severity.  The recovered file should NOT be used going forward; copy only the most recent work from it into a backup copy of the original file. Recovery results:   File blocks: scanned and rebuilt 563 blocks, dropped 214 invalid data blocks.   Schema: scanned fields and tables, 1 items modified   Structure: scanned; 1 items modified   Field indexes: rebuilt  
      Opening the recovered database, there are only three records present.  There should be hundreds.  So obviously I am looking on how to wrangle this database open.
      I've attached the log file here, as well as the database structure map.  
      The other files have converted just fine.  But since the main table won't open, we are kind of stuck.
      I can share the files with you through Dropbox or whatever, if needed.
      Please let me know any thoughts you have, either basic or advanced.  And ask for any clarifications or additional questions.   :-)  
      Thanks!
      -Tony
      Recover.log

    • By Tumma K
      Hello, All!

      I am an aspiring developer for Filemaker. The company I work with is stuck in the past working off of Filemaker Pro 4.1

      I was given the task of bringing us up to Filemaker Pro/Server 13. So far my conversion prototypes are successful but we recently had a layout issue that can only be fixed in versions 3-6 (as the file is an .fp3) I work off of a macbook while our network is all Windows 7. In order for me to repair the layouts without tampering our active database, I decided the best option is to repair a copy of our solutions off the network. Unfortunately, when I go to download the trial version of Filemaker Pro 6 off of the respected website, the file is corrupt! I've tried multiple times, with different extraction apps and in different directories.

      My question is;

      Does anyone know a place where I could obtain version 6 (or better yet, 4.0) for an OSX computer? I've looked everywhere!
       
      Thank you for your time,
      Tumma K.
    • By MrEddByrnes
      I'm hoping my question can have a happy ending. In the mid-90's, I purchased Filemaker 3. When Filemaker 5.5 Pro was released, I bought the update CD, which requires the user to either have FM 3 installed or to have the installation CD for FM 3. I've used it all these years, most recently with Windows XP Pro, and it has worked just fine. The databases I began with were long ago converted to FM Pro 5.5 databases.
       
      I'm still using FM Pro 5.5 on a laptop with WinXP Pro, but in 2013, I purchased a PC with Windows 8. I haven't been able to install FM 3 on it, therefore can't install FM Pro 5.5. I am retired and rarely use Filemaker, but I have a few Filemaker databases I'd like to add to my Win 8 machine. I don't feel it's worth upgrading FM for the sake of using a couple of databases.
       
      Has anyone else run into this situation and/or have a (possible) solution? Is there perhaps any other software that can read FM 5.5 databases? Thanks in advance for your help.
       
    • By bmill
      I am using a custom filemaker solution for medical office billing written with fp5 running on a mac with snow leopard. In addition, I have a patient management db (which I wrote) that is linked through pt. ID number to the billing program allowing transfer of some demographic information (name, DOB, etc).
       
      Other than being limited by hardware restrictions, the billing program serves our needs for now and upgrading to fp12 will take some time (and money).  In the meantime, I am upgrading my pt. management program to fp13 and would like to move new patient demographic information from the billing program ( fp5 running on snow leopard through Parallels) and the new pt management program ( fp13 running on OS X 10.9) on the same mac.   
       
      Ideally, demographic information would be entered once into fp5 and then a scipt would make the data available for fp13.
       
      Any ideas on how to make this work?
    • By randyinla
      Hi, can anyone tell me why my on-line database might have stopped allowing me to delete records?  All of my access privileges and passwords are correct.
       
      thanks!
  • Who Viewed the Topic

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.