Jump to content

More indexing trouble


adrain
 Share

This topic is 5684 days old. Please don't post here. Open a new topic instead.

Recommended Posts

Simple problem baffling me. Have a file with 20 layouts. I have a field called "View all layout names" and it is a calculated field which uses the LAYOUTNAMES(fieldname) function. It is blank and is not showing the layoutnames. I have tried every combination of indexing (on, minimal, all), I just can't get it to carry out an index and display the layout names. This was originally a FM6 file. When I create a small test file from scratch in FM8 the layout names do appear. Yet when I do the same in my other file....blank field. Is there any way of forcing an index to be made of the layout names ? I have tried deleting the field and re-defining it, to no avail. Am I missing something obvious ? Thanks for any help offered. Allan

Link to comment
Share on other sites

The calc should be unstored (if you want it to update when new layouts are added).

The result should be set to Text.

If it still doesn't work, try this syntax:

LayoutNames ( Get (FileName) )

Another thing worth trying: clone your file (Save a Copy As.. > "clone (no records)") and see if it works in the clone.

Link to comment
Share on other sites

Calc is unstored and result set to text.

Using your suggested syntax LayoutNames ( Get (FileName) )

produces an invalid Get function parameter.

No joy with cloning the file either...same result, blank field.

Thanks for your suggestions, any more worth trying ? Allan

Link to comment
Share on other sites

Does this one work over there?

Notes:

1. Your calc was NOT set to be unstored.

2. When you clone a file, the name is changed, so you need to change it in the calc too (unless you're using the Get (Filename) syntax).

3. The first character of the file name was a space - this could be the problem with your original file as well.

Cloned.fp7.zip

Link to comment
Share on other sites

Works perfectly now, I misunderstood your suggestion to use the GET(FILENAME) function. I took you to mean I was to use the actual filename in inverted commas as in GET("S1andS2PI"), which is why it did not work.

Many thanks Comment for your assistance, it is much appreciated.

Allan

Link to comment
Share on other sites

This topic is 5684 days old. Please don't post here. Open a new topic instead.

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

  • Similar Content

    • By Tumma K
      Hello, All!

      I am an aspiring developer for Filemaker. The company I work with is stuck in the past working off of Filemaker Pro 4.1

      I was given the task of bringing us up to Filemaker Pro/Server 13. So far my conversion prototypes are successful but we recently had a layout issue that can only be fixed in versions 3-6 (as the file is an .fp3) I work off of a macbook while our network is all Windows 7. In order for me to repair the layouts without tampering our active database, I decided the best option is to repair a copy of our solutions off the network. Unfortunately, when I go to download the trial version of Filemaker Pro 6 off of the respected website, the file is corrupt! I've tried multiple times, with different extraction apps and in different directories.

      My question is;

      Does anyone know a place where I could obtain version 6 (or better yet, 4.0) for an OSX computer? I've looked everywhere!
       
      Thank you for your time,
      Tumma K.
    • By MrEddByrnes
      I'm hoping my question can have a happy ending. In the mid-90's, I purchased Filemaker 3. When Filemaker 5.5 Pro was released, I bought the update CD, which requires the user to either have FM 3 installed or to have the installation CD for FM 3. I've used it all these years, most recently with Windows XP Pro, and it has worked just fine. The databases I began with were long ago converted to FM Pro 5.5 databases.
       
      I'm still using FM Pro 5.5 on a laptop with WinXP Pro, but in 2013, I purchased a PC with Windows 8. I haven't been able to install FM 3 on it, therefore can't install FM Pro 5.5. I am retired and rarely use Filemaker, but I have a few Filemaker databases I'd like to add to my Win 8 machine. I don't feel it's worth upgrading FM for the sake of using a couple of databases.
       
      Has anyone else run into this situation and/or have a (possible) solution? Is there perhaps any other software that can read FM 5.5 databases? Thanks in advance for your help.
       
    • By bmill
      I am using a custom filemaker solution for medical office billing written with fp5 running on a mac with snow leopard. In addition, I have a patient management db (which I wrote) that is linked through pt. ID number to the billing program allowing transfer of some demographic information (name, DOB, etc).
       
      Other than being limited by hardware restrictions, the billing program serves our needs for now and upgrading to fp12 will take some time (and money).  In the meantime, I am upgrading my pt. management program to fp13 and would like to move new patient demographic information from the billing program ( fp5 running on snow leopard through Parallels) and the new pt management program ( fp13 running on OS X 10.9) on the same mac.   
       
      Ideally, demographic information would be entered once into fp5 and then a scipt would make the data available for fp13.
       
      Any ideas on how to make this work?
    • By randyinla
      Hi, can anyone tell me why my on-line database might have stopped allowing me to delete records?  All of my access privileges and passwords are correct.
       
      thanks!
    • By randyinla
      Hi, I still use filemaker 5.5 and am very happy with it and don't want to upgrade.  Does anyone still host filemaker 5.5?  Thanks!
×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.