Jump to content

This topic is 2750 days old. Please don't post here. Open a new topic instead.

Recommended Posts

Hi all,

 

Got myself in trouble yesterday. Hope there is a solution. I know I have obsolete material but it works for my needs.

 

Hardware/software :

 

xp pro sp3 up to date as of 2013/05/05

fms9.0.3

jre6u7

firefox 20.0.1

 

Situation :

 

For the past few months I had no access (on my fms box) to fmadmin as I had inadvertedly updated my jre to an update that made my fmadmin to crash whenever I tried to select a specific hosted database.

 

So yesterday, I tried removing that jre to replace it with jre6u7 which I know is the last one to work with fms9. As it didn't want to get deleted, after googling, I decided to use microsoft's fixit and I removed it but I also removed all that was java thinking that by installing jre6u7 i would be set to go. Big mistake!!!

 

Even though jre6u7 is correctly installed, when I launch fms 9 start page, it tells me I should have java 5 +.

 

I looked at my Firefox plug ins and grayed out is my jre6u39. If I try to find a jre6u7 plug in with Firefox's plugin wizard, nothing shows up.

 

What do you experts recommend I do other than upgrading to fms12?

 

If you need any more info, please let me know.

 

Thanks in advance for any help,

 

Cheers

Link to post
Share on other sites

Here are some screen captures that might be helpfull.

Also, I thought of making internet explorer as the main browser and activated the IE java plugin but with the same result, i.e. the fmsadmin splash screen appears but after about a minute dies off.

In your opinion :

a - would a remove and then reinstall of fmserver 9 solve the issue?

b - would an xp clean install solve the issue?

Thanks again for any help,

Cheers

P.-S. : I need this to work somehow as I am still using Filemaker mobile 8 on two Palm Centros.

 

post-54890-0-41021400-1367868105_thumb.p

post-54890-0-09242100-1367868117_thumb.p

post-54890-0-89171300-1367868129_thumb.p

post-54890-0-66241700-1367868138_thumb.p

post-54890-0-64291300-1367868148_thumb.p

post-54890-0-40776700-1367868160_thumb.p

Link to post
Share on other sites

Hi again :-)

 

I need to take action on this matter. I was hoping that someone with more knowledge that I have on this matter (which is not much I must say) would kindly direct me in one direction or another in order for me to avoid making silly mistakes. Like I mentionned on my last post on this subject, I'm about to either reinstall fms9 or reinstall xp. These are drastic steps that might be avoidable but I do not have a clue. Also, even if I do that, I might end up with a negative result as it might be impossible to reinstall fms9 because of this Java matter. On my end, the lack of security of java's older versions do not pose me much issue as this is an intranet server.

 

So again any help will be appreciated even if it were to tell me to go to another forum that addresses obsolete products like mine. I would not be offended nor do I mention this to be offensive in any way.

 

Cheers

Link to post
Share on other sites

I cannot help with Java... however there is a command line version of the admin console that you can use to perform many FMS admin tasks. This does not require Java.

 

At the very least I'd be using this to backup the hosted files, close them, the stop the FMS service before re-installing FMS or the operating system.

Link to post
Share on other sites

I doubt you'll find much help, 9 is a really old version and the whole java thing is a mess to begin with.  I would probably go with a full reinstall just to wipe the slate clean.  But as you mentioned that is not a guarantee that things will actually work.

Link to post
Share on other sites

Thanks Vaughan

 

Before I got in this mess, that is what I did (from the moment my admin console "died" a few months back). Now, when I try run commands such as fmsadmin open, I get the following message :

 

Windows can't find "fmsadmin". Please verify that you have entered the name correctly and try again.

 

I did not have that message before I removed the improper Java versions. It looks as if Java is mandatory for any server management and Java appears to be very messed up on that server box even though I have reinstalled jre6u7 and it appears to have installed correctly.



Thanks Wim,

 

If anyone knows if a fresh install of fmserver on a fresh install of xp will do the trick, I'm all ears.

 

Cheers

Link to post
Share on other sites

 

Windows can't find "fmsadmin". Please verify that you have entered the name correctly and try again.

 

 

That message isn't caused by java, that's just Windows not knowing where the path to the "fmsadmin.exe" file is.

It's in the FMS database server folder.   If you have not added the path to the executable to your Windows PATH variable then you need to navigate to the folder where fmsadmin.exe is before you can execute it.

 

If it worked before from anywhere and now it does not then something changed that PATH Windows variable...

Link to post
Share on other sites

Thanks again Wim

I did go to that folder but when I launch it manually, a DOS window shows up for about half a second (attached) and then nothing else happens.

 

I am correct, reading from your previous answer that JAVA has nothing to do with fmsadmin.exe if lauched manually, that if I do a complete reinstall I could operate fms9 only with manual commands?  If so, I'd be ok then, right?

 

 

Link to post
Share on other sites
  • 2 weeks later...

Hi all,

 

Just to let you know, all worked out perfectly. I reinstalled XP pro sp3, FMS9 with the included Java 6 update 3 and voilà, all is fine! I guess it had been so many years that I had it installed that I forgot that Java 6 was included with the FMS9 installation.

 

Very happy about the outcome.

 

Thanks to all for your help.

 

Have  great day!

Link to post
Share on other sites

This topic is 2750 days old. Please don't post here. Open a new topic instead.

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Similar Content

    • By mat101010
      After moving the .fmx64 plugin file to the Extensions folder, FileMaker Pro (v18.0.3 and Windows 10) shows a message saying "Unable to launch plug-in child process JVM". This is happening for both the Email plugin and the FTPeek plugin. 
    • By Stickybeak
      I am evaluating 360works email plugin and when getting messages from an office365 server I get the following error "java.lang.ArrayIndexOutOfBoundsException: -99"...If I click OK it reduces to "98" but then increases: I assume its retrieving messages and this is the count.
      Any ideas?

    • By bigitinc
      Are any of the announced distribution/release changes at https://java.com/en/download/release_notice.jsp going to impact our ability to use our plugins made with ScriptMaster?
    • By Lisa Mac
      When calling the function EmailSetBodyFile(url, 1) I receive the error - Java.security.cert.CertificateException No subject alternative DNS name matching conta.cc found. I was using the function to send a url that points to a constant contact page. I have done this many times in the past and can still successfully perform this function on other constant contact pages but not this particular one for some reason. https://conta.cc/2ug3M0P
      Any help??
       
      Thanks!
    • By -dp-
      I'm running FMS 16 on macOS 10.12.6. FMS is up and running, and I can access the hosted databases. But I can't get into the admin console. When I enter the credentials, it just sits there. It doesn't throw an error. It just doesn't react at all. Same thing when I intentionally enter an incorrect passcode. No error. Same behavior whether I use Firefox or Safari. Same behavior whether I try to come in remotely, or if I work directly from the server as localhost. So, something is wrong with web services rather than FMS, right?
×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.