Jump to content

Accessing Web Direct Solution via Filemaker Pro

This topic is 2598 days old. Please don't post here. Open a new topic instead.

Recommended Posts

Would be most grateful if somebody could help please.


I have developed a WebDirect solution which all works fine.  I type in into my browser, it lists my database file named 'Portam' and I'm then able to log-in.


I'm also able to access the file via Filemaker Pro Advanced using the Open Remote File facility and selecting the host fmnet:/filemakerserver.cunliffes.local/, this then lists my file 'Portam' and like with above i'm then able to log-in.  I firstly have to make a VPN connection however to my office for my file 'Portam' to be listed when selecting the host, else my file doesn't appear. 


What's confusing me is that I recently asked for help via the forum with a few issues with my solution, and in providing the filemaker I.P Address only, and setting up an account for this person I seen via the filemaker server console that he had managed to log-in.  I know that a VPN connection isn't required, and he doesn't have a VPN set-up to allow him to connect into our office, so what is he doing differently?


It would be great if somebody could help as my client has just purchased Filemaker Pro to access the solution, instead of via the browser, and they don't have a VPN connection set up to connect into my office so at present they can't access it this way, only via a browser. 


Sorry if the above is a little confusing, have tried to explain it the best I can





Link to comment
Share on other sites

To access remotely outside the VPN you need a public IP address that is port forwarded onPort 5003 to the internal address of the server.  Then you use the Internet as a Wide Area Network. This is similar to the Local Area Network inside your office.



Link to comment
Share on other sites

This topic is 2598 days old. Please don't post here. Open a new topic instead.

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Similar Content

    • By Donald Clark
      I have a FileMaker server 13.v10 database solution that changed somehow during development and now does not display several WebDirect objects properly.
      For starters, the text shows up as white on a white background, which it did not do before.  We have been and are using the Cool Grey theme.
      Other problems with display:
      1.  3 value lists will not display:  One a regular list from a set of values, another list from a related layout, and a third a filtered list from another layout.  Another value list works normally
      2.  A picture in a container field (locally stored, not external yet) does not show.
      3.  A filtered, sorted portal does not show the records, nor are they accessible in the portal. The filtering and sorting are straightforward.
      We have tried several things to correct the issue:
      1.  Made a new layout, grouped everything together and paste it on the new layout.
      2.  Made a new layout and made the fields and portal from scratch.
      3.  Simplified and changed the relationships to the portal
      4.  Substituted simplified relationships for the value lists (just for testing.
      5.  Tried the db on FM Server 16 and made most of the changes above, nothing was different.
      6.  Used Dropdowns, Popups, and radio buttons, no change in behavior
      7.  We had FMDiff examine the db for corruption, but they found no problems, so file corruption is not an issue.  We also compacted the db in order to reindex all indexed fields, but that did not help.
      Everything works fine using FM client.  Only WebDirect has problems.
      A photo showing the problems on WebDirect is attached, as is a photo showing the fields properly displayed in FileMaker Client.  Please forgive the look and feel; the photos show the layout as we made changes and are troubleshooting.
      Has anyone seen this before?  Do you have any ideas how to fix it?
      Thanks for your help.

    • By Martin_S
      Ok, so we have just completed the set up of our test FM13 server and the application is being accessed via webdirect.
      I have tested it on Chrome (as our managed image only runs IE8 at present), and I get a login dialog whuich i have to enter my network credentials into. Currently the application is secured by three different Active Directory groups based on the access level of the user, and the users would really like to know if it's possoble for them to not have to sign in?
      The third party provider who set this up believed it was possible, but as WebDirect is new, there doesn't seem to be much info available. I've searched the user guides and they all mention SSO with ODBC, but I am pretty sure this doesn't apply here.
      Can anyone tell me if what we need is possible, and if so how?
    • By wimclaessen
      In Webdirect, when i press a button that initiates a script, i usually see a message for a flash of a second saying something like "Wait for the script to be executed".
      Occasionally FM decides not to display the message and just executes the script.
      Is there any way to tell Filemaker not to show these messages ?
      Thanks for the advice.
    • By LaRetta
      There are several methods for creating standard icons in a file:  regular container, paste the image directly on the layout, use text Webdings ... but recently I have used placing the image in Inspector > Appearance > Background Fill with image.  In this way, the icon can change color on highlight etc. Then this style is saved to a custom theme.
      The advantage is that I can import these 'icons' between files (by importing themes) and I can save them to the theme so it changes throughout a solution automatically.  This is particularly advantageous when I have several companies sharing a single solution because I can change icons to match their theme colors.
      The problem:   When opened in web direct, all I get is a solid-colored square.  I know normally we make separate layouts for web direct but in this current situation, the existing layouts will work perfectly except for a few of these buttons.  And regardless, I would have the same issue on a web direct layout.
      I've tried many different types of icons and images but I am no Images Master and I do not understand the differences in rendering on why images placed in Appearance::background (images) will not work on Web Direct.  Before I give up on this idea for this project, because it is truly my preferred approach, do others have suggestions on image quality or type which might allow this to work?
    • By Morenomdz
      Hello there, I've set few text boxes per layout that work as "tutorials", with one button called "help" that changes one global field [tutorial] from Yes to No (and vice versa), commits the record.
      When the global field "tutorial" is set to yes, all the "text boxes" should hide, when it is set to no they should apear. It works perfectly in the fm client but when I got to the web even if I change the field to Yes or No in the client and save the record, the web still shows all the text boxes.
      It looks like the the "hide when" is simple not working. Using 
      table::tutorial = "yes"
      Did a test having the a tex field for the tutorial showing on the layout, it looks like the webdirect is not seeing the field content at all. It shows as empty on web and Yes or No on the client.
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.