Jump to content

Start Stop Timer in webviewer in Go12 on ipad


This topic is 2581 days old. Please don't post here. Open a new topic instead.

Recommended Posts

Hi,

 

reading through the different approaches to timers for elapsed time capturing, I cannot seem to find the right lead or approach:

 

For a quiz scenario  on an Ipad, I would like to press start that triggers a timer to start counting up the seconds.

While they are visibly running, the user will perform a quiz and answer questions, switching layouts.

When he is finished he will press stop and the used time (the one displayed on screen) is saved. 

 

Any leads how this could be done? My head is spinning on the thought of a javascript count up of seconds...

 

Thank you!

Link to comment
Share on other sites

After pondering on it I think the approach is a little to complicated. 
In my opinion, it would be easiest to timestamp a field and then start a timer in a web viewer.

 

If the user clicks stop on a button on the interface, I would wipe the web viewer and evaluate the result in 

a field. 

 

Now- trying to find a simple javascript that will return Minutes:Seconds of my timer that will start upon 

a certain amount of minutes seconds counting up (lap) has proven difficult to find for me.

Who would know how where to find this?

 

Your help is appreciated, thank you.

Link to comment
Share on other sites

Yes comment, thanks. I had been looking at it and tried to adapt the egg timer that does almost everything. Unfortunately I don't seem to be able to make it count up,

the egg timer counts down....

Link to comment
Share on other sites

This topic is 2581 days old. Please don't post here. Open a new topic instead.

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

  • Similar Content

    • By cat traveller
      Hi everyone, 
      we are using web direct on Safari on an Ipad iOS 14, FilemakerServer 19.
      When we try to put data into a data field, the user needs to click once to select the field, and once again to see the keyboard. This is super annoying.
      I tried several approaches to select field, select object but it does not work. 
      I know that there is FIlemaker Go but we have to give iPads to people in a remote place and they wont have the chance to install it.
      Is there a way around anyone would know? 
      Thank you!
    • By Answers
      Our people out in the field take photos which go directly into the container fields, we would like those photos to automatically transfer to the camera roll/gallery. I know there is an export command and that would allow the techs to export and choose the location, save image etc... But that is a tad too complicated for them.
      Any suggestions on how to automate this process, the script for export field contents doesn't have a choice to save to camera roll.
      Thank you!
      Caroline
    • By typewriter
      I use jQuery and the jQueryUI slider widget to display a slider in FileMaker Pro (v17-17-18-19). Works fine but I also need to have it work on FileMaker Go, so I tried my luck on jQuery Mobile 1.4.5. The slider is working nicely on FileMaker Pro, but on FmGo 17, 18 or 19 it doesn't load, keeps displaying a spinning logo. When I publish the HTML page on a website and open it in Safari Mobile it works fine. Any help appreciated! See the example file: just downlaod it and open it on FMGo. The Webviewer and the HTML are displayed side by side.
      sliderExample.fmp12
    • By ggt667
      I can ping my PDF document server from Terminal, I can connect to the PDF document server from all browsers apart from Safari, my default web browser is FireFox, I also tried to change to Chromium and Opera as the default web browser. WebViewer has the same symptoms as Safari, server not found.
      $ ping -nc 1 document PING document (10.0.0.7): 56 data bytes 64 bytes from 10.0.0.7: icmp_seq=0 ttl=64 time=0.002 ms --- document ping statistics --- 1 packets transmitted, 1 packets received, 0.0% packet loss round-trip min/avg/max/stddev = 0.002/0.002/0.002/0.000 ms FileMaker says ’Couldnot connect to the server.’
       
      The issues is easily solved by creating a new MacOS X user, and log in to that user, however I would rather like to fix the current user not having to migrate all other application settings. Is there some dns cache specific to Web Viewer and Safari?
    • By St3v1e
      Hi,
      As a complete novice to FMP, I'm attempting my very first database. We rely on storing our contracts on Google & Dropbox. I've been trying to either embed the pdf's into a "tab", or (my preferred option) to have an "Add URL" button to link to the online pdf.
      I tried adding a field and copying and pasting the URL, but it's not clickable, and I'd need to add another field for each pdf/contract.
      Is there a better more efficient way to do this?
      Thanks
      Steve
  • Who Viewed the Topic

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.