Jump to content

Weird Behaviour of FM files over network


This topic is 6606 days old. Please don't post here. Open a new topic instead.

Recommended Posts

Apologies if this is in the worng forum but I wasnt sure where else to post it.

I have a problem with an existing FM DB which has just started to manifest itself and I am hoping someone may be able to shed some light on it.

I have a small home LAN on which I keep all my files on a central server. I have 3 pcs [one being the server] all of which I use to access the DB from various rooms in my house. I only ever use one PC at a time to access the DB and have a single user licence.

The issue is this:

Up until a few days ago, I was able to access the DB using any of the 3 pcs and was able to do whatever I wanted in terms of data and layout editing, reports, scripts etc. In otherwords everything was working as one might expect.

However, whilst I can still access the DB and edit files from any of the pcs, I can now only operate the scripts I have, from one of the pcs, and its not even the server! Bear in mind that only one instance of the program is open at any one time on any of the pcs.

I have tried reinstalls of the app. on the 2 pcs that are having problems just in case the program files had corrupted but it has not made any difference. At present I have resorted to access the DB from the one PC that seems to be operating without any problems. I dont think it is a hardware issue as it is unlikely that 2 pcs would both start acting up at exactly the same time. I dont think it is a access privilege issue either as I have tried to access it using different user account with the same result on both the pcs that don't operate the DB properly and on the one that does.

Can anyone suggest a likely cause and solution?

Many thanks


Some additional info to assist as there have been plenty of viewers but no suggestions yet forthcoming.

OS is XP Pro Build 2600 SP2

CPU/MEM: 1 Intel , 995MHz with 768MB

Using Static IP's on a hard-wired LAN using ICS.

Internet connection is a 2Mb Cable

Please help! I am getting desperate here!


Link to comment
Share on other sites


I had a similar problem with a network (though mine was on an Apple platform).

Networked files initally worked great but become unstable over time.

In my case it had to do with OS level file sharing.

It seemed that filemaker sharing tended to corrupt itself when run over OS level sharing.

My problem was solved by installing Filemaker server onto a dedicated server computer.

This computer has OS level filesharing set to OFF.

My client stations have OS level filesharing set to ON.

Here is the thread that explained it all to me:


Maybe this will help.


Link to comment
Share on other sites

Well, I tried your advice and had a look at that thread Jarvis. Having gone and got another couple of versions of FM I am now serving the database across my network from an unshared OS volume using FM Server to 1 install of FM Dev and 1 of FM pro. Everything is sharing fine, updating ok, simultaneous viewing and updating is fine, scheduled backups are working fine but....

...I still get this screwy behaviour sometimes though!

The one PC that is running everything sweetly is a minimum installed pc in my office that is running just XP [OS] plus Office , FM Pro and a load of security apps. The other main PC that I access the DB from is running FM Dev plus a host of other apps.

Is it likely to be a port conflict from one app to another perhaps? I am not sure how FM Server tunnels data from the Host to the Clients, but I should imagine its TCP/IP in which case might it be conflicting with a port address of another application?

Anyway, the bottom line is that sometimes it behaves as it should, and sometimes it doesn't... So whenever it manifests itself, it just means I have to get up off my bum and change desks/PCs to the one that does work! The exercise will no doubt do me good... wink.gif

Thanks for the suggestion anyway. laugh.gif

Link to comment
Share on other sites

This topic is 6606 days old. Please don't post here. Open a new topic instead.

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.