Jump to content

Cannot open database after uploading to Server using WebDirect


Brad Mathews
 Share

This topic is 2292 days old. Please don't post here. Open a new topic instead.

Recommended Posts

I am evaluating File Maker Pro 14 and Server 14.

After uploading a database to Sever 14, when the FM tries to open the version on the server I get this error:

The file "DBTrackingODBC.fmp12" could not be opened. (Extended privilege diabled)

The first database I tried worked, but this one it not. The only real differences are that I added an Admin password to this one and the tables are ODBC (to an Azure SQL server database if that matters.)

If I try to open the database via WebDirect on the browser, it asks me to login. But it will not accept my database's admin password. So I tried the server admin password and my ODBC database password to no avail.

I have anonymous access enabled in this database so if I click cancel, my database comes up but all of the fields say <Data Source Missing>

How do I get access to the database from FM? and what password am I supposed to be using in WebDirect?

I am on Windows 10 and the server is running locally.

Thanks,  Brad

 

 

Link to comment
Share on other sites

@Fitch

Yup, that was at least part of it. Need the 32bit DSN for File Maker and the 64Bit DSN for the server which makes total sense.

I rebuilt my test DB from scratch and uploaded it and I did not get the error, but the login was not working, until you came to the rescue. The database is running from the server in FM14 just fine.

But now, I cannot open the database in WebDirect. The database is not in the /fmi/webd list. I cannot go to it manually ("Database not available" messsage) but it is in the list of databases in the Admin console. Does it have to wait to compile or something?

- Brad 

 

 

Link to comment
Share on other sites

Did you verify in the security settings that the web direct extended privilege is enabled in the privilege set you're using?

Link to comment
Share on other sites

Thanks, yeah, I figured out that you have to set the WebDirect access to the file before sharing it. And I learned that these are called extended privileges even though that term is not used anywhere in the app itself.

We're all good now, just going through tutorials on Lynda.com.

- Brad

 

 

Link to comment
Share on other sites

Glad you figured it out. Not sure what you mean by "that term is not used anywhere in the app." Extended Privileges is a main tab under Manage Security, and is listed within the Edit Privilege Set dialog. There's also the functions Get(AccountExtendedPrivileges) and Get(CurrentExtendedPrivileges), and there's About accounts, privilege sets, and extended privileges.

Link to comment
Share on other sites

I should have said   "that term is not used anywhere in the app that I have encountered yet". My bad.

The place i set the Extended Privileges was in the Configure for FileMaker WebDirect dialog. I just selected All Users for my test and that seemed to fix it.

I'll need to get much further into security settings before my journey is done - I don't know Privilege Sets from Extended Privilege Sets from Shinola yet.

- Brad

Link to comment
Share on other sites

This topic is 2292 days old. Please don't post here. Open a new topic instead.

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.