Jump to content

Read and write logic on both client and server are different than configuration


This topic is 2737 days old. Please don't post here. Open a new topic instead.

Recommended Posts

Hello there,

I'm just investigating on 2 issue I have on sync 2 DB, 1 on the server and 1 on the iPad that are set to use a Spoke Db in the middle tier.

Basically the sync is set to copy ALL the data from some tables on the server to the local db and send some data from the local db to the end server db. For some reason, on a large table, called Articles, with more than 130k records, the sync does not copy all the record for some users. There is no 'filter' based on user on the end db, and I run a pre-populate sync on the spoke db that copied all 130k records. When the sync is run for that specific user, the final result on the iPad is that the sync DELETES 12k records for no apparent reason.

 

In addition, there is a Global table that has always 1 records and is get from the server to the client. But I found some times that there are several records on that table (more than 10) on the server, even if the sync is set to write on the spoke and not viceversa for that table. I have the suspect that are written from the sync. Is it possible?

Thanks in advance,

Gianluca  

Link to comment
Share on other sites

Hi Gianluca - we're not going to be able to troubleshoot without the sync log. Please submit a problem report (use the 'report a problem' link on the MirrorSync launch page to do this), and copy and paste this entire message into the problem description.

If you know at least one of the primary keys that was deleted, please include it in the description. That will make it much faster to find the right place in the log file.

Link to comment
Share on other sites

Ciao Jesse,

Unfortunately the process worked on my part, but after redoing it (I mean deleting the record 'server' on the mirrorsync table, then creating it again new and writing the actual date and time in the sync4 field) on the final ipad client it didn't worked because it still deleting 12k records and I don't know why.

What should I do?

Thanks,

Gianluca.

 

Link to comment
Share on other sites

This topic is 2737 days old. Please don't post here. Open a new topic instead.

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.