Jump to content

Client fails to launch


kwong
 Share

This topic is 5764 days old. Please don't post here. Open a new topic instead.

Recommended Posts

  • Newbies

So, this is a seemingly simple problem w/a seemingly simple solution, but...

After having not used FMP 7 on my PC for about a week (running XP service pack 2), I tried to open the application yesterday afternoon to create a new database. FMP 7 begins to initialize, but after about 5 seconds the splash screen goes away and it fails to launch and dies on me. The application never actually opens. By the way, I'm running FMP 7 v1a.

I don't get an error message to led me to a certain spot, so I've tried to alleviate the problem by rebooting, de-installing the software, rebooting, re-installing the software, running multiple virus scans, running rootkitrevealer, and comparing the services running with other PC's. All of the attempts produce the same result: FMP 7 still fails to launch. However, none of my other software applications seem to have any problems. It must be OS related, but I have no idea where to look now. Registry??

Any thoughts or help would be much appreciated. I noticed someone else in the forum had this problem w/FMP 6 on a MAC. Did you get any help?

-kwong

Edited by Guest
Link to comment
Share on other sites

The first thing you should do is get the FM7v3 update. That might fix your problem right there.

I've seen FileMaker "not load" as you describe because it is already running. It appears to be closed because the FM application window is gone but if you go to the Windows Task Manager (Processes tab) you will see FileMaker still running. The cause for FileMaker failing to fully close in my case was on older version of the SMTPit plugin. I simply contacted CNS and they sent the latest version and the problem went away.

Link to comment
Share on other sites

Good call, Ted! This has caught me also!! And FM can be running but there be no window - check Menu > Window and see if there is a file open but it's window not displaying.

Using XP and vs. 7.0v1, a few other possibilities: it will occasionally NOT produce its warning message "same licensed copy being used elsewhere" and simply close again. I've had this happen 2 or 3 times (I wasn't trying to cheat, just got computers mixed up). BTW, are you networked? Because that's also how an opener might respond if it can't find the host.

Also, laugh if you will, but (as last resort) reinstalling my printer drivers solved this very problem on one client machine which continually refused to load (even after un- and re-intalling FM). :wink2:

Link to comment
Share on other sites

  • Newbies

I have been having similar behavior for a number of our users. clicking an application or filemaker pro.exe shortcut will produce an hourglass for a second or two and then nothing else will happen.

I seemed to have tracked it down to:

After closing all "visible" applications (files) in filemaker, If there is a hidden file open in filemaker when exiting filemaker it will leave a filemaker pro.exe process running but not accessible.

After changing my "exit" button in my application from "close file" to "exit application" this issue "seems" to have gone away.

I understand not wanting to exit all of filemaker when wishing to close a single file, I am posting this as a further indication of this issue.

Link to comment
Share on other sites

This topic is 5764 days old. Please don't post here. Open a new topic instead.

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

  • Similar Content

    • By Tony Morosco
      I'm a botanist, and the tables I am working with are for tracking botanical garden collections. The data represents plants in the garden, and the plants are tagged and show up in the database.  The tables I am working with were created in FMP 7, and I'd like to open them up in FMP 11 (or later.)  The system hasn't been used in years, but still has valuable information.
      One of the tables is giving me problems using the FMP convert and recover commands.
      These tables are all inter-related.  The main table is the Accessions table, which contains records for all of one kind of plant, from the same source, received on the same date.  It is basically a museum standard.
      The other tables are related to each other through this one main table.  The Species table is related to the locations table through the Accessions table. 
      (i.e.  table A relates to table C through the table B, the intermediary)  
      From the Locations table, we can't see the the species information unless the accessions table is present.
      When issuing the open command on the main table to convert the database to FMP 11, I get the message:
      "Accessions.fmp7" is damaged and cannot be opened.  Use the Recover command to recover this file. When using the Recover command from v. 11, I get another message:
      WARNING: problems were detected while recovering the database.  Please review the Recover.log file to see where problems were found and their severity.  The recovered file should NOT be used going forward; copy only the most recent work from it into a backup copy of the original file. Recovery results:   File blocks: scanned and rebuilt 563 blocks, dropped 214 invalid data blocks.   Schema: scanned fields and tables, 1 items modified   Structure: scanned; 1 items modified   Field indexes: rebuilt  
      Opening the recovered database, there are only three records present.  There should be hundreds.  So obviously I am looking on how to wrangle this database open.
      I've attached the log file here, as well as the database structure map.  
      The other files have converted just fine.  But since the main table won't open, we are kind of stuck.
      I can share the files with you through Dropbox or whatever, if needed.
      Please let me know any thoughts you have, either basic or advanced.  And ask for any clarifications or additional questions.   :-)  
      Thanks!
      -Tony
      Recover.log

    • By Tumma K
      Hello, All!

      I am an aspiring developer for Filemaker. The company I work with is stuck in the past working off of Filemaker Pro 4.1

      I was given the task of bringing us up to Filemaker Pro/Server 13. So far my conversion prototypes are successful but we recently had a layout issue that can only be fixed in versions 3-6 (as the file is an .fp3) I work off of a macbook while our network is all Windows 7. In order for me to repair the layouts without tampering our active database, I decided the best option is to repair a copy of our solutions off the network. Unfortunately, when I go to download the trial version of Filemaker Pro 6 off of the respected website, the file is corrupt! I've tried multiple times, with different extraction apps and in different directories.

      My question is;

      Does anyone know a place where I could obtain version 6 (or better yet, 4.0) for an OSX computer? I've looked everywhere!
       
      Thank you for your time,
      Tumma K.
    • By MrEddByrnes
      I'm hoping my question can have a happy ending. In the mid-90's, I purchased Filemaker 3. When Filemaker 5.5 Pro was released, I bought the update CD, which requires the user to either have FM 3 installed or to have the installation CD for FM 3. I've used it all these years, most recently with Windows XP Pro, and it has worked just fine. The databases I began with were long ago converted to FM Pro 5.5 databases.
       
      I'm still using FM Pro 5.5 on a laptop with WinXP Pro, but in 2013, I purchased a PC with Windows 8. I haven't been able to install FM 3 on it, therefore can't install FM Pro 5.5. I am retired and rarely use Filemaker, but I have a few Filemaker databases I'd like to add to my Win 8 machine. I don't feel it's worth upgrading FM for the sake of using a couple of databases.
       
      Has anyone else run into this situation and/or have a (possible) solution? Is there perhaps any other software that can read FM 5.5 databases? Thanks in advance for your help.
       
    • By bmill
      I am using a custom filemaker solution for medical office billing written with fp5 running on a mac with snow leopard. In addition, I have a patient management db (which I wrote) that is linked through pt. ID number to the billing program allowing transfer of some demographic information (name, DOB, etc).
       
      Other than being limited by hardware restrictions, the billing program serves our needs for now and upgrading to fp12 will take some time (and money).  In the meantime, I am upgrading my pt. management program to fp13 and would like to move new patient demographic information from the billing program ( fp5 running on snow leopard through Parallels) and the new pt management program ( fp13 running on OS X 10.9) on the same mac.   
       
      Ideally, demographic information would be entered once into fp5 and then a scipt would make the data available for fp13.
       
      Any ideas on how to make this work?
    • By randyinla
      Hi, can anyone tell me why my on-line database might have stopped allowing me to delete records?  All of my access privileges and passwords are correct.
       
      thanks!
  • Who Viewed the Topic

    4 members have viewed this topic:
    Daniel Wood  OlgerDiekstra  mrmacmusic  B.Fehr 
×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.