Jump to content

Disable highlighting portal row?


This topic is 8472 days old. Please don't post here. Open a new topic instead.

Recommended Posts

I want to simulate an input box or a dialogue box for a user to input data into one field. To achieve this I duplicated my original layout, then proceed to draw the dialogue box over top of it, disabling all the fields underneath. However, I have a portal underneath, and when I click on the dialogue box, it highlights the portal row right through it. Is there any way I can disable it?

Kim

Link to comment
Share on other sites

captkurt, has a soluiton that might work...

it is very clever...

on the layout w/ the portal.

you need to enter preview mode perform a copy

via a script

then paste the contents it into a container.

on a layout with a very large container in the back ground you can create a dialog box in the foreground.

When you are in browse mode and you hit a button that spawns the dialog box it will appear as if the dialog box poped up floating over the portal.

Link to comment
Share on other sites

quote:

Originally posted by Ocean West:

captkurt, has a soluiton that might work...

it is very clever...

Aww, shucks. Your making me blush here!

quote:

on the layout w/ the portal.

you need to enter preview mode perform a copy

via a script

then paste the contents it into a container.

on a layout with a very large container in the back ground you can create a dialog box in the foreground.

When you are in browse mode and you hit a button that spawns the dialog box it will appear as if the dialog box poped up floating over the portal.

More generically you create your "Dialog" layout with your dialog box (I also have a method of creating some amount of dynamicness to the dialog itself, but that is a bit more complicated to explain) and behind it is a full screen container field "gBackground". Make sure that you uncheck the "Allow access to field" option, so that your users will not be able to click into this picture.

From any screen your dialog script should enter preview mode (make sure your layout margins are all specifically set to 0) enter Preview mode and Copy. This will copy a picture of the screen into the clipboard.

Now goto a Developer-only layout which has your gBackground field on it and Paste into the field.

Now goto your dialog layout and enter Browse or Find mode. This all takes a fraction of a second to perform and it looks and acts as if a dialog box popped up in front of the current layout.

------------------

=-=-=-=-=-=-=-=-=-=-=-=-=

Kurt Knippel

Consultant

Database Resources

mailto:[email protected]

http://www.database-resources.com

=-=-=-=-=-=-=-=-=-=-=-=-=

Link to comment
Share on other sites

This topic is 8472 days old. Please don't post here. Open a new topic instead.

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.