Jump to content

FM Go will not access remote over WIFI but cellular is fine


This topic is 367 days old. Please don't post here. Open a new topic instead.

Recommended Posts

  • Newbies

Hi,

 

I have Filemaker 12 server and when using FileMaker GO 13 on an iPhone I am able to connect remotely when on cellular but when I switch to wifi (still entering remotely) it does not "see" the server. (Host is not available)

 

I have tried this on two separate wifi locations with the same problem. I even tried it on the WIFI network that the server is on with no luck.

 

Also replicated the same problem using wifi on an iPad. I don't have cellular o the iPad so I couldn't determine if it would see the server

 

Is it a magical port I am missing that needs to be opened?

 

Any help would be appreciated.  I am stumped.

 

Thanks

Link to post
Share on other sites

I would forget about FMGo for the moment and make sure you can see the server at a "lower" level, ie can you ping the server? If you can, can you browse to the server using an internet browser, or browse a fileshare? If there's no option to browse a share or no webpage available, try telnetting to an open port on the server. I'm no expert on ipads/iphone (am an Android man), but I have to support ipads and iphones in my workplace. Never tried looking for it, but I'd imagen there'd be a telnet app of sorts for iOS.

If you can see the server via ping and telnet (or browse) then the ipad/iphone might be blocking a port though I wouldn't have expected that. Just remember that while you may be able to ping a device, that doesn't necesarily mean you have open communication lines, even if there's nothing blocking (ie firewall) in between. Pings will work when there are routing issues but not http or telnet and stuff.

It might also be a firewall issue on the wifi network, ie traffic between the wireless part of the AP and the physical wire is filtered.

Link to post
Share on other sites

If you can see a fileshare remotely without a VPN connection; that would be really bad security.  An internet browser can only see what is available on port 80 or 443, neither may be open on the FileMaker Server, and pings routinely get dropped on the firewall, telnet (port 23) is such an obvious attack vector that you'd be foolish to have it open.  So neither of those are good tests IMHO.  FM data traffic is its own protocol and uses port 5003.

 

Since FMS is available on cellular but not on WifI, it can only indicate that those WIFI networks block outgoing traffic on port 5003, and that is what needs to get fixed.

Link to post
Share on other sites

I beg to differ.

 

You can easily telnet to any port you like to determine whether those ports are being listened to. Telnet defaults to port 23 but you can tell it to use any port. Ie telnet 443 will attempt to connect to port 443, telnet 80 will connect to port 80, telnet 5003 will attempt to connect to port 5003. The response from telnet immediately tells you whether you are connecting or whether the connection is refused. That most certainly tells you something about the underlying layers.

I've been doing this for years to quickly determine whether a port is open. It's an excellent way to test. Up to Win7 the telnet client was included by default. With Win7 you have to explicitly install it. 

 

Further, the problem wasn't so much connecting via cellular, but via wifi. OP mentions the server is connected to a wireless network and he tried that as well without success. That tells me the wifi is a local network and therefore unlikely to require a firewall. Which means ping is a valid option to test with.

 

An internet browser, much like telnet will connect to any port you tell it to. Default http is on port 80 and default HTTPS is on port 443. But that is very easily changed. http://www.google.com.au:64333will attempt to connect to google's servers on port 64333. That of course will only succeed if google has a service listening on that port and has http capabilities, but thats besides the point.

Link to post
Share on other sites
  • Newbies

Thanks for the input but I am still stumped.

 

Let me take FM Go out of the equation because it may be complicating things.  

 

If I try to connect to FM server 12 on a computer in my LAN it operates fine if I try to connect remotely with the same computer it does not "see" it

 

I have opened ports 80, 16000, 16001, 16004, 16006, 16008, 16010, 5002, 5003, 16012, 16014 on the firewall (ATT Motorola NVG510 Router)

 

Again FM GO sees it fine remotely on a cellular network

 

I'm sure it is something stupid I am doing.

 

Thanks for any insight

Link to post
Share on other sites

When you say "remotely" I assume it's from outside your network, ie somewhere on the internet. You would then be connecting to your filemaker server with a DNS name or IP address that is translated on your firewall to the internal ip address of your filemaker server.

 

For instance, if your filemaker server has an IP address of 192.168.1.10, that address would not be accessible from the internet. To make your server accessible from the internet, you would need to translate your external ip address that your ISP assigns to your internet service to the ip address of your filemaker server. That would allow you to access the filemaker server using the external ip address of your router.

 

However, that exposes your filemaker server to anyone out on the internet which would not be the best idea. It would be better to create a VPN between either the router and your external host (phone/tablet/computer) or the filemaker server and the external host. That would do away with the need to open any port on the firewall as well (other than for VPN purposes).

 

Haven't used FMGO on iphone before and only internally on ipads so can't elaborate why the iphone would be able to connect via cellular and not wifi.

Link to post
Share on other sites

 

Haven't used FMGO on iphone before and only internally on ipads so can't elaborate why the iphone would be able to connect via cellular and not wifi.

 

One reason would be that the file reference is defined as the external IP address and not the internal one.  On cellular you would be in effect be *outside* your network and the external IP reference would work.  From inside the network (on WiFi) the external IP may not be routable.

 

A screenshot of the file reference would help a lot here.

Link to post
Share on other sites

Olger,

 

"However, that exposes your filemaker server to anyone out on the internet which would not be the best idea."

 

SSL can still be used. As well, all FM security measures can be implemented. If someone manages to hit a public IP all they'll see is a page telling them it's a FileMaker Server site. Even if the address is reached via FM or FMGo, account name and password would still be required.

Link to post
Share on other sites
  • 4 years later...
  • Newbies

Did you find a solution for this?, I have the same problem. I cannot connect from my home to a database in my office using my house wifi from my laptop. But there is no problem connecting through cellular from my iPhone. It is even possible to connect from my laptop sharing my iPhone's cellular connection. But no luck through my homes wifi (that lets me connect to the internet without problems)

Link to post
Share on other sites

This topic is 367 days old. Please don't post here. Open a new topic instead.

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Similar Content

    • By juli51
      Hi all,
       
      Is there any way to launch a kiosk mode video from FM Go?
       
      I have a customer who has iPads in his shop for the public to search product information ( it's a very simple catalog). When the iPad is idle he wants a promotional video to start automatically and close when someone touches the screen again.
       
      Thanks in advance...
    • By Goetch
      I am pretty sure this is a known bug in FMGo 13, however, I was wondering if anyone might have a work around.  
       
      I am having an issue with list view in a simple FMGo 13 program.  Basically after about 20 or so records the input field of a new record disappears.  Scrolling the screen will almost always bring it back.
       
      The program is pretty simple, 3 tables, 2 input fields scan and qty.  I made the program to help take our physical inventory.  The user is only interacting with the "scan" table.  The two fields are scan and quantity.  Basically I download the program into an iPhone and pair a socket scanner with it.  I have a script trigger that runs on object save on the scan field.  The barcode and based on a preference either a new record is created or the user enters in the quantity.  Everything works great until about 20 or so records are scanned, then the user can no longer see the input field on the bottom of the screen.  Scrolling up usually fixes this.  The program seems to work flawlessly if the layout is set to form view, however, obviously the user does not see the last few scans in this view.  
       
      Like I said I have read that there are bugs in list view.
       
      Can anyone suggest a work around?  
    • By charlie649
      I have a solution on the iPad using FMGo13 and the user likes to let the iPad sleep without logging out.  When the iPad wakes up I have experienced weird problems from, records not saving, data entry not allowed, not being able to connect to host even though the network and the host show they are available. 
       
      If you restart the iPad the problem is solved and everything works perfectly, only seems to happen after the iPad sleeps
       
      Just wondering if anyone else has experienced this and what the solution was
    • By Cliveds
      Hi
       
      Can anyone help, I've stored Scanned PDF's of purchase invoices on our FM database which is running on FM server 13. 
       
      Stored externally and secure storage option on the container field.
       
      We can view the files fine on FM pro but when we try and view on FM Go goes to a web view and errors and does not show the PDF.
       
      How do you view stored pdf's in filemaker go?
      Currently running the below script which works for Filemaker Pro Clients just not on Filemaker Go on iOS
       
      Set Variable [$AttachmentPath; Case (Abs (Get(SystemPlatform)) = 1, "filemac:", "filewin:") & Get (TemporaryPath) & TableName::SerialNumber & ".pdf"]
      Export Field Contents [TableName::ContainerFieldName; "$AttachmentPath"; Automatically open]
       
       
       
      Any ideas
       
      Thanks
       
      Clive
    • By Scrimshaw
      I am about to get my iPhone 6 plus and have a number of files setup for my current 3.5inch iPhone screen. Does anyone have the dimensions I need to customise the outline template when modifying those files for the iPhone 6 plus please.
  • Who Viewed the Topic


×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.