Jump to content

When accessed via LAN, Server doesn't find databases


Recommended Posts

I'm having something odd happening.  I'm running FMS18 on a server on my LAN. When I run admin console on that machine, everything is as it should be.  SSL certificate is installed, valid license, expected databases are open.

When I access via another computer on the LAN, using IP address:16000/admin-console, I am able to login and it shows the server is running BUT no databases are there, license shows as expired and there is no installed SSL certificate. In the past, I've had issues where firewall software prevented accessing the console over my LAN - but I've never had a situation where I could log into the console from another machine, but server reported all this incorrect information.

I can remote desktop into the server machine from the other computer, and run the console locally (port 16001) - all is good.  But putting the same IP address into a browser on that other computer, I get this weird result.  This started happening quite recently, and no doubt there have been windows updates since then.  I'm just not sure where to look.  

Thanks for any suggestions.

Link to post
Share on other sites

If you have an SSL cert installed you should always address the server by the name on the cert and never use the IP address.

That wouldn't explain the issue you are describing but it prevents many other issues.  What do you get when you use the DNS name?

  • Like 1
Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Similar Content

    • By mikedr
      We’re not ready to upgrade our server to 19, but would like to upgrade some clients to 19. I understand that we won’t be able to leverage any of the new functionality of 19, but will there be any issues with accessing a database hosted on FMS18 with FMP19?
    • By Gnurps
      On a clean install of FMS18, fresh install of Mojave, web publishing will not run. I initially addressed the problem by wiping the Mac-mini hard drive and reinstalling OS X Mojave 10.14.6. (Mac mini is 2018 model with 16gb RAM and >400gb free HD space.) Then installed FMS 18.0.4. Installed the certificate and the Java JDK 8 update 242. Files accessed by FM Pro work fine, with green lock and normal behavior. WebDirect called from browser on the server using http://127.0.0.1/fmi/webd refuses to connect (with Chrome 81 and Safari 12.1).  WebDirect over the local network refuses to work, too. FMS Admin console shows no problem. WPE.log shows no errors. Activity Monitor shows all FMS processes running, including fmscwpc. 
      stderr.log has this code that seems to indicate a problem: 
      INFO: Initializing AtmosphereFramework May 18, 2020 10:07:38 AM org.apache.jasper.servlet.TldScanner scanJars INFO: At least one JAR was scanned for TLDs yet contained no TLDs. Enable debug logging for this logger for a complete list of JARs that were scanned but no TLDs were found in them. Skipping unneeded JARs during scanning can improve startup time and JSP compilation time. May 18, 2020 10:07:38 AM org.atmosphere.cpr.AtmosphereFramework addAtmosphereHandler The address org.atmosphere.cpr.AtmosphereFramework makes a lot of entries into that log. 
      Anyone able to decipher this or offer advice? 
      The problem seems similar to this post:
       
      Last fall, xochi posted that v.18.0.3 included a fix to intermittent failures of Apache: "sometimes after a reboot on macOS, the apache / httpd server fails to start up.  As a result, FMPro works fine, but WebDirect will be dead, and there's no notifications" The release notes on 18.0.3 do note a fix for it as an intermittent problem. 
      But it happens to this machine all the time. After completely fresh install!
      Gary Sprung
      Gnurps Consulting
    • By dubl
      HI all - I have two folders inside of the Databases folder which contain numerous files - these are DepotMaestro and TCM. I am trying to setup backup schedules for each of the subfolders.
      The path I am using is for the subfolder is:
      filemac:/NewMiniHD/Library/FileMaker Server/Data/Databases/DepotMaestro/
      filemac:/NewMiniHD/Library/FileMaker Server/Data/Databases/TCM/
      Both show the Not A Valid Path error.
      What am I doing wrong?
      Mojave, 18.0.3.319
    • By john renfrew
      Have copied a shell script which works in other settings onto a new machine
      Changes paths - it zips a backup folder and does a ditto command to copy as a zip file to an external drive
      I worked out that I needed to change the sudoers file to allow no password access to the script. Running the shell script in terminal was requiring a password, now it doesn't 
      Added the fmserver user to that too.
       
      If I run the sh script from the admin console as fmserver it fails straight away, if I run it as the local user with its password it appears to run but in fact times out with a fail message, both of which are about invalid account name or password
       
      The script is working fine when run through terminal, doe not require password, just not when triggered from console.
      Does anyone have any light to shine on this???
    • By Agnes Riley
      I'm getting "The file "" could not be opened. Either the host is unavailable, or the file is not available on that host."
      This happens when a script runs. Not a new server, no new files. The file is actually open in the background. The file reference is just "file:".
      I restarted the server. Didn't fix it.
      FMS18.03
      It's apparently intermittent. I copied all the script steps to a new script, then it worked 3 times, but couldn't find the file for the 4th time.
      Any ideas?
  • Who Viewed the Topic

    3 members have viewed this topic:
    whardy  Steve Martino  comment 

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.