Jump to content
Sign in to follow this  

Go to Related Record bug?

Recommended Posts

Is this a known bug with the "Go to Related Record" script step in FM 7?

Every time I use the script step "Go to Related Record" it shows <unknown> for the layout.:

Go to Related Record [ From table: "{Inventory}"; Using layout: <unknown> ] [ Show only related records; New window ]

Even though I can set the layout in the "Show record using layout" menu of the script step. I click OK to dismiss the dialog box. It shows <unknown> for the layout, so I click OK and save the script and run it. The script runs fine it goes to the the correct layout. I come back to the script and it still shows <unknown> for the layout.

I save all my scripts as a PDF doc and do a search for "unknown". I find hundreds of <unknown> and they are all in a "Go to Related Record" script step.

So do others see this same error? Is it just me? Is it a corrupted file or a bad install of FM 7?

Mac OSX 10.3

FM 7.0v3

Share this post

Link to post
Share on other sites

I thought this was fixed in v3. Did you add the GTRR steps in v3 or previous ones? If previous ones, respecify the layout and see if that helps.

Share this post

Link to post
Share on other sites

Did you add the GTRR steps in v3 or previous ones? If previous ones, respecify the layout and see if that helps.

Some of the GTRRs were made in earlier versions of FM 7. This file is not a conversion from FM 6 and below.

I tried to re-specify the layout in a few GTRRs and nothing seemed to stick. While doing this I decided to change the layouts to <Current Layout> and it stuck. So I tried "Layout Name by Calculation" and "Layout Number by Calculation" and they stuck too, but none of the other layouts would stick which were made by me.

Next test, I recovered the file to see if this would fix it, nothing. Same symptoms. Then I created a brand new file. This worked. No more Using Layout: <unknown>.

So now I am stuck with a file that is a big project. I have been working on for a few months now and it is full of unknown error on each GTRR.

I am thinking if I can unistall FM and reinstall it, this might fix the problem.

Can anyone reproduce this error? It is a pre 7.0v3 file.

Is there anyway to repair the file?

Share this post

Link to post
Share on other sites

Bummer. Well, even though it shows <unknown>, it does save it and the step works. So if you can live with it for the time being, since it doesn't cause any problems, maybe FM will have a fix for it eventually.

Share this post

Link to post
Share on other sites

Well I reinstalled Filemaker and no go.

Does anyone know of a product that can copy an entire FM file's contents (field definitions, layouts, scripts, value list, file ref, etc) into a another file, preferably a new blank file.

This is a massive file. I have created. I could maybe live with it for no but in the future, looking for bugs in my scripts will be hell. My tried and trusted way of saving my scripts into a PDF and doing searches has been wounded.

I am at a cross roads. I am only half way finished with this project. I have to decide to start all over and copy everything by hand or keep the file and let these GTRR bugs multiple.

This is probably the biggest disadvantage of FIlemaker. Once you start a file you are stuck with it. Filemaker really needs to make a way to transfer file definitions from to another.

Share this post

Link to post
Share on other sites

I have figured out what exactly is causing this Go To Related Record (GTRR) bug. But I need someone to verify it by recreating the bug themselves.


At first I thought it affected all instances of the GTRR script step in any file, but when created new files it did not appear. While I was working with this new file the bug reappeared a few days later. I noticed it showed up on GTRR steps that involved table occurrences pointing to tables that were out side the current file.

So now I think this GTRR bug only appears when the GTRR includes a TO pointing to another file containing the table. This may be a another bug regarding referenced files and FM 7.

I have attached a sample file to see if you guys can see it on your computer. Then I need you to create a new file to see if it effects all newly created files in FM 7.

Any feed back is needed.


Share this post

Link to post
Share on other sites

This is a known bug. I've seen it discussed on another list. Basically, the step works fine, but it doesn't read right. I imagine FileMaker will fix it. Then probably all your visible "errors" will go away without you doing anything. Hopefully.

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

  • Similar Content

    • By Tony Morosco
      I'm a botanist, and the tables I am working with are for tracking botanical garden collections. The data represents plants in the garden, and the plants are tagged and show up in the database.  The tables I am working with were created in FMP 7, and I'd like to open them up in FMP 11 (or later.)  The system hasn't been used in years, but still has valuable information.
      One of the tables is giving me problems using the FMP convert and recover commands.
      These tables are all inter-related.  The main table is the Accessions table, which contains records for all of one kind of plant, from the same source, received on the same date.  It is basically a museum standard.
      The other tables are related to each other through this one main table.  The Species table is related to the locations table through the Accessions table. 
      (i.e.  table A relates to table C through the table B, the intermediary)  
      From the Locations table, we can't see the the species information unless the accessions table is present.
      When issuing the open command on the main table to convert the database to FMP 11, I get the message:
      "Accessions.fmp7" is damaged and cannot be opened.  Use the Recover command to recover this file. When using the Recover command from v. 11, I get another message:
      WARNING: problems were detected while recovering the database.  Please review the Recover.log file to see where problems were found and their severity.  The recovered file should NOT be used going forward; copy only the most recent work from it into a backup copy of the original file. Recovery results:   File blocks: scanned and rebuilt 563 blocks, dropped 214 invalid data blocks.   Schema: scanned fields and tables, 1 items modified   Structure: scanned; 1 items modified   Field indexes: rebuilt  
      Opening the recovered database, there are only three records present.  There should be hundreds.  So obviously I am looking on how to wrangle this database open.
      I've attached the log file here, as well as the database structure map.  
      The other files have converted just fine.  But since the main table won't open, we are kind of stuck.
      I can share the files with you through Dropbox or whatever, if needed.
      Please let me know any thoughts you have, either basic or advanced.  And ask for any clarifications or additional questions.   :-)  

    • By Tumma K
      Hello, All!

      I am an aspiring developer for Filemaker. The company I work with is stuck in the past working off of Filemaker Pro 4.1

      I was given the task of bringing us up to Filemaker Pro/Server 13. So far my conversion prototypes are successful but we recently had a layout issue that can only be fixed in versions 3-6 (as the file is an .fp3) I work off of a macbook while our network is all Windows 7. In order for me to repair the layouts without tampering our active database, I decided the best option is to repair a copy of our solutions off the network. Unfortunately, when I go to download the trial version of Filemaker Pro 6 off of the respected website, the file is corrupt! I've tried multiple times, with different extraction apps and in different directories.

      My question is;

      Does anyone know a place where I could obtain version 6 (or better yet, 4.0) for an OSX computer? I've looked everywhere!
      Thank you for your time,
      Tumma K.
    • By MrEddByrnes
      I'm hoping my question can have a happy ending. In the mid-90's, I purchased Filemaker 3. When Filemaker 5.5 Pro was released, I bought the update CD, which requires the user to either have FM 3 installed or to have the installation CD for FM 3. I've used it all these years, most recently with Windows XP Pro, and it has worked just fine. The databases I began with were long ago converted to FM Pro 5.5 databases.
      I'm still using FM Pro 5.5 on a laptop with WinXP Pro, but in 2013, I purchased a PC with Windows 8. I haven't been able to install FM 3 on it, therefore can't install FM Pro 5.5. I am retired and rarely use Filemaker, but I have a few Filemaker databases I'd like to add to my Win 8 machine. I don't feel it's worth upgrading FM for the sake of using a couple of databases.
      Has anyone else run into this situation and/or have a (possible) solution? Is there perhaps any other software that can read FM 5.5 databases? Thanks in advance for your help.
    • By bmill
      I am using a custom filemaker solution for medical office billing written with fp5 running on a mac with snow leopard. In addition, I have a patient management db (which I wrote) that is linked through pt. ID number to the billing program allowing transfer of some demographic information (name, DOB, etc).
      Other than being limited by hardware restrictions, the billing program serves our needs for now and upgrading to fp12 will take some time (and money).  In the meantime, I am upgrading my pt. management program to fp13 and would like to move new patient demographic information from the billing program ( fp5 running on snow leopard through Parallels) and the new pt management program ( fp13 running on OS X 10.9) on the same mac.   
      Ideally, demographic information would be entered once into fp5 and then a scipt would make the data available for fp13.
      Any ideas on how to make this work?
    • By randyinla
      Hi, can anyone tell me why my on-line database might have stopped allowing me to delete records?  All of my access privileges and passwords are correct.

Important Information

By using this site, you agree to our Terms of Use.