Jump to content
Sign in to follow this  
Steven Cappiello

Sort Script in Startup Script isn't executing

Recommended Posts

Could someone tell me why it might be that

my sort script does not execute when it's in the

startup script ,

but when I call the same exact script (after the startup script finishes),

then it works perfectly ?

Share this post


Link to post
Share on other sites

Scripts apply to the table occurence associated with the layout you are on when the script fires. Does your sort script include a layout switch to a table based upon the records you wish to sort?

Share this post


Link to post
Share on other sites

Hmmmm.... Yes, I am switching layouts in the script.. but I get to the proper layout before the sub- script is called.

So, shouldn't I be okay ?

any ideas ?

Share this post


Link to post
Share on other sites

Are you certain it's not sorting and then resorting for some reason? Did you put a Pause/Resume or Show Custom Dialog step in to see if it's ever activated?

Is there any reason the file might be opening without performing its on-open script? This was an issue in previous versions when the opening layout referenced a relationship in a closed file. It would open without performing the on-open script. I thought this had been resolved in 7 though.

Share this post


Link to post
Share on other sites

Add a Show Custom Dialog step with Get(AccountName). It would seem the account name test is not successful, but putting a dialog step in will verify if it's getting past it.

Share this post


Link to post
Share on other sites

Thanks but, no, it is definitely getting past it.

It's doing everything up to that sort.

And the problem is... it's ALMOST sorting them.

with a few errors in the sorting... then if I manually run the sort script.. it sorts them as they should be.

what could be stopping this same exact sort script from running correctly in the original script.

Could it be a problem with the first part of the script taking too long to happen :

Share this post


Link to post
Share on other sites

could my problems be caused by the fact that i'm sorting by some fields that are "stored" calculated fields and some that are not :??

and if so, which do i want to be using ?

Share this post


Link to post
Share on other sites

I'm not sure. Try turning Error Capture off and then open the file. See what, if any, errors are produced.

I'm curious why you're re-logging in as andersok_rtdb if the account name is already andersok_rtdb though.

Share this post


Link to post
Share on other sites

I'm relogging in because I"m authenticating against active directory, then relogging in to assign more specific privileges

I'm just testing it with andersok_rtdb 's account

I figured it out !!!! the problem had to do with the fact that the thing I was sorting on was a calculation that was based off of a related field.

For some reason, it wouldn't work while the startup script was running.

I got around it by passing the related value in the startup script into a global field in the table I am sorting on.

now it sorts. Anyone know why I had to do this to get it to work ? I don't understand what exactly the problem was.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Similar Content

    • By Tony Morosco
      I'm a botanist, and the tables I am working with are for tracking botanical garden collections. The data represents plants in the garden, and the plants are tagged and show up in the database.  The tables I am working with were created in FMP 7, and I'd like to open them up in FMP 11 (or later.)  The system hasn't been used in years, but still has valuable information.
      One of the tables is giving me problems using the FMP convert and recover commands.
      These tables are all inter-related.  The main table is the Accessions table, which contains records for all of one kind of plant, from the same source, received on the same date.  It is basically a museum standard.
      The other tables are related to each other through this one main table.  The Species table is related to the locations table through the Accessions table. 
      (i.e.  table A relates to table C through the table B, the intermediary)  
      From the Locations table, we can't see the the species information unless the accessions table is present.
      When issuing the open command on the main table to convert the database to FMP 11, I get the message:
      "Accessions.fmp7" is damaged and cannot be opened.  Use the Recover command to recover this file. When using the Recover command from v. 11, I get another message:
      WARNING: problems were detected while recovering the database.  Please review the Recover.log file to see where problems were found and their severity.  The recovered file should NOT be used going forward; copy only the most recent work from it into a backup copy of the original file. Recovery results:   File blocks: scanned and rebuilt 563 blocks, dropped 214 invalid data blocks.   Schema: scanned fields and tables, 1 items modified   Structure: scanned; 1 items modified   Field indexes: rebuilt  
      Opening the recovered database, there are only three records present.  There should be hundreds.  So obviously I am looking on how to wrangle this database open.
      I've attached the log file here, as well as the database structure map.  
      The other files have converted just fine.  But since the main table won't open, we are kind of stuck.
      I can share the files with you through Dropbox or whatever, if needed.
      Please let me know any thoughts you have, either basic or advanced.  And ask for any clarifications or additional questions.   :-)  
      Thanks!
      -Tony
      Recover.log

    • By Tumma K
      Hello, All!

      I am an aspiring developer for Filemaker. The company I work with is stuck in the past working off of Filemaker Pro 4.1

      I was given the task of bringing us up to Filemaker Pro/Server 13. So far my conversion prototypes are successful but we recently had a layout issue that can only be fixed in versions 3-6 (as the file is an .fp3) I work off of a macbook while our network is all Windows 7. In order for me to repair the layouts without tampering our active database, I decided the best option is to repair a copy of our solutions off the network. Unfortunately, when I go to download the trial version of Filemaker Pro 6 off of the respected website, the file is corrupt! I've tried multiple times, with different extraction apps and in different directories.

      My question is;

      Does anyone know a place where I could obtain version 6 (or better yet, 4.0) for an OSX computer? I've looked everywhere!
       
      Thank you for your time,
      Tumma K.
    • By MrEddByrnes
      I'm hoping my question can have a happy ending. In the mid-90's, I purchased Filemaker 3. When Filemaker 5.5 Pro was released, I bought the update CD, which requires the user to either have FM 3 installed or to have the installation CD for FM 3. I've used it all these years, most recently with Windows XP Pro, and it has worked just fine. The databases I began with were long ago converted to FM Pro 5.5 databases.
       
      I'm still using FM Pro 5.5 on a laptop with WinXP Pro, but in 2013, I purchased a PC with Windows 8. I haven't been able to install FM 3 on it, therefore can't install FM Pro 5.5. I am retired and rarely use Filemaker, but I have a few Filemaker databases I'd like to add to my Win 8 machine. I don't feel it's worth upgrading FM for the sake of using a couple of databases.
       
      Has anyone else run into this situation and/or have a (possible) solution? Is there perhaps any other software that can read FM 5.5 databases? Thanks in advance for your help.
       
    • By bmill
      I am using a custom filemaker solution for medical office billing written with fp5 running on a mac with snow leopard. In addition, I have a patient management db (which I wrote) that is linked through pt. ID number to the billing program allowing transfer of some demographic information (name, DOB, etc).
       
      Other than being limited by hardware restrictions, the billing program serves our needs for now and upgrading to fp12 will take some time (and money).  In the meantime, I am upgrading my pt. management program to fp13 and would like to move new patient demographic information from the billing program ( fp5 running on snow leopard through Parallels) and the new pt management program ( fp13 running on OS X 10.9) on the same mac.   
       
      Ideally, demographic information would be entered once into fp5 and then a scipt would make the data available for fp13.
       
      Any ideas on how to make this work?
    • By randyinla
      Hi, can anyone tell me why my on-line database might have stopped allowing me to delete records?  All of my access privileges and passwords are correct.
       
      thanks!
×

Important Information

By using this site, you agree to our Terms of Use.