Jump to content

Open URL (IWP 7.0v3) Fails on many browsers?


This topic is 6952 days old. Please don't post here. Open a new topic instead.

Recommended Posts

This article: http://filemaker.custhelp.com/cgi-bin/filemaker.cfg/php/enduser/std_adp.php?p_faqid=408

says basically that under IWP, the "Open URL" script step will fail if there are any javascript or popup-blockers in use.

Since a large percentage of users are using popup-blockers, this basically means that the Open URL script is next to useless. I think this is ridiculous! FM's suggests that you ask your users to disable their popup blockers is not gonna work in the majority of circumstances.

How hard could it be for FM to just put a standard HTML <A href=...> link in the page's html? Even a javascript location.href= xxx command should work, as long as it's triggered by a button click. I just don't get it.

Unless this is fixed, I think this makes IWP basically a toy, unsuitable for any serious work, which is a shame, since it's otherwise so capable and easy to use...

Anyone figured out a robust work-around (other than using CDML, etc.)? Can you put the entire IWP session within a sub-frame, and have a top frame which has navigation buttons "Return to website", etc?

Link to comment
Share on other sites

This topic is 6952 days old. Please don't post here. Open a new topic instead.

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.