Jump to content
Sign in to follow this  
Brian C

FMP 9 Bug?

Recommended Posts

I have noticed that if I change my network connection on my laptop from wired to wireless while working in FMP Adv 9, FMP freezes when I attempt to use the function: Get ( SystemIPAddress )

After force quitting FMP, this function will continue to freeze FMP until I restart my laptop.

Has anyone else noticed this bug? Is this a Mac OS X only bug? Is this a FMP Adv only bug? Does this only happen to me?

Share this post


Link to post
Share on other sites

That is a strange bug, when you log back in... do you use the same user name and password?

Is this same problem found in 8.5? My experience when force quitting filemaker is that the server tends to actually still see you connected for a short time so typically an error about using duplicate licenses may pop up.

If you are using a site license, I am guessing that FileMaker may just allow you to log in and then it gets confused between multiple users. These are all just wild shots in the dark but something to think about.

Share this post


Link to post
Share on other sites

I am experiencing this bug while developing in Adv 9 on my laptop. No server is involved. The account used to connect has no affect on this bug - it crashes no matter what account I use to open the filemaker file. I just get the spinning wheel of doom that never goes away until I forcequit FileMaker Pro.

Edited by Guest

Share this post


Link to post
Share on other sites

It's probably because the wireless router is assigning the computer a different IP address. FMP remembers the IP address when it first starts.

I'd be surprised if any program could manage this.

You'd probably notice that mounted file servers will drop off too.

Edited by Guest

Share this post


Link to post
Share on other sites

FMI should look into this so that their application will not crash and corrupt data for a locally hosted solution. If anything it should return an error if it does not recognize a valid response from the OS or the query times out. I do not view it as acceptable for an application to crash simply because there is a lost network connection. What if something happens to the user's network? What if a switch/hub goes down? I should not have to be concerned with data integrity if that occurs.

A developer could potentially use get(systemipaddress) to lock a solution to a specific machine. If this is broken then there could be a similar issue with get(SystemNICaddress).

In any case I discovered this because I have to develop my solution locally before it can be hosted on a server. I do not relish having to restore from a backup and loose a day's worth of work.

In my scenerio, Dynamic ip address assignment via DHCP is not an issue here either since in my scenerio the ip is already assigned, and the airport connection is already present and established. It is just not the default connection that the network traffic is being routed through as long as the wired connection is active.

When you use get(systemipaddress) it returns a delimited list of IP addresses for the users machine... Example:

192.168.1.1

192.168.1.100

If the first ip address in the list is my wired connection and I unplug it it, then the wireless connection automatically takes over after a few seconds and the second ip address swaps places with the first. Example:

192.168.1.100

192.168.1.1

If FMP caches the ip address list from launch, it should not crash since it would return the same result.

If FMP does not cache the ip address list, why would it crash by querying it from the OS a second or third time?

I am not trying to attack FMP 9. I love the new version. I am just trying to make others aware of potential problems and to also verify that others can replicate the same issue. If it is an error that only occurs on my Intel MacBook Pro running OSX 10.4, that is also useful to know.

Share this post


Link to post
Share on other sites

n any case I discovered this because I have to develop my solution locally before it can be hosted on a server. I do not relish having to restore from a backup and loose a day's worth of work.

Granted that the app ought not to crash, but why in the world do you go for a day of development and not make a backup? If thisis crtical work, you should backup very frequently, perhaps once every 10 to 15 minutes.

Steven

Share this post


Link to post
Share on other sites

Brian,

I'm confused -- you first post says that fileMaker froze, and then you force-quit it. This is not the same thing as a crash.

I'm sure you are aware that Mac OS X has some trouble with networking (e.g. when a server goes offline, the Finder will often beachball for 2+ minutes until it decides it's gone). Perhaps the same thing is happening?

Have you tried just waiting it out?

Share this post


Link to post
Share on other sites

Yes I let it wait overnight one of the times just to see if it would time out. It makes no difference.

If the application freezes or if the application unexpectedly quits I still consider it a crash.

Share this post


Link to post
Share on other sites

If this is reproducable, you can probably help apple and/or filemaker by doing this:

1. Get filemaker to hang.

2. Open /Applications/Utilities/A ctivity Monitor

3. Click the FilemakerApp and choose "Insepct"

4. Click the "Sample" button.

5. Submit the sample log to apple/filemaker as a bug report.

Sampling takes a snapshot of the processes status for a few seconds -- this should clearly show which method the app has hung in.

Share this post


Link to post
Share on other sites

were you able to duplicate this in a new file?

If so, can you post step by step instruction on how to cause the hang?

In my testing I was able to get the spinning wheel of death for maybe 30 seconds.

Share this post


Link to post
Share on other sites

Hi,

just to say that I had the same thing today. Impressive !

Actually, FileMaker didn't really crash and was finally returning a normal result, but after several (15 or so) seconds of spinning beach ball.

And I'm not sure something had changed in the network environment. Anyway, the database was on my laptop.

Restarting the laptop didn't solve it, by the way.

[MacBook Pro, Leopard, FileMaker Pro Advanced 9[color:red]v3]

Edited by Guest

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Similar Content

    • By Justin Close
      I was doing a bit of work for a client who is running FM9 clients, connecting to a file hosted on an FM11 server.  I don't have FM9, so was doing development on FM11.  I thought I had checked out that everything was compatible, but I somehow generated a calculation that doesn't evaluate on 9, but does on 11.  The components of the calculations and custom functions used all appear to be innocuous...  I  am hoping someone here knows what I tripped up on.
      Here's the field calculation, and the 2 custom function definitions that it uses.  The entire point of this calculation is to take a mish-mash text field that they have and make it sort nicely.  For this bit I added, I'm just concerning myself with sorting some suffix numbers that occur between parentheses, e.g. 12345(A-1).
       
      Field calculation definition: Let ( [ _fileNum = Files::File Number ; //Position of 1st open/close parens, and then extract the text between them: _sParen = Position ( _fileNum ; "(" ; 1 ; 1 ) + 1; _eParen = Position ( _fileNum ; ")" ; 1 ; 1 ) ; _suffix = Middle ( _fileNum ; _sParen ; _eParen - _sParen) ; //Count the leading digits before any non-digit character, e.g. an alpha, or dash or space, etc. _count = CountPrefixDigits ( _suffix ; 0 ) ; //Remove extraneous characters (dash, space): _suffix = Substitute ( _suffix; ["-";""]; [" " ; ""] ) ; //Pad out the string to min 5 characters (helps 75-A sort next to 75): _suffix = _suffix & Left ( "!!!!!" ; 5 - Length (_suffix) ); //Reverse the character sequence (so the Code() call works out better): _suffix = ReverseString ( _suffix ) ]; _count & Code ( _suffix ) //prepend the digit count, but don't encode that count, just the rest of it ) -------------------- 'CountPrefixDigits ( aString ; aCounter )' custom function: If ( IsEmpty ( GetAsNumber ( Left ( aString ; 1 ) ) ) ; aCounter ; CountPrefixDigits ( Right ( aString ; Length ( aString) - 1 ) ; aCounter + 1 ) ) -------------------- 'ReverseString (aString)' custom function: If ( Length ( aString ) > 0 ; ReverseString ( Right ( aString ; Length ( aString ) - 1 ) ) & Left ( aString ; 1 ) ; Left ( aString ; 1 ) )  
      Thanks,
      Justin
       
    • By Tumma K
      Hello, All!

      I am an aspiring developer for Filemaker. The company I work with is stuck in the past working off of Filemaker Pro 4.1

      I was given the task of bringing us up to Filemaker Pro/Server 13. So far my conversion prototypes are successful but we recently had a layout issue that can only be fixed in versions 3-6 (as the file is an .fp3) I work off of a macbook while our network is all Windows 7. In order for me to repair the layouts without tampering our active database, I decided the best option is to repair a copy of our solutions off the network. Unfortunately, when I go to download the trial version of Filemaker Pro 6 off of the respected website, the file is corrupt! I've tried multiple times, with different extraction apps and in different directories.

      My question is;

      Does anyone know a place where I could obtain version 6 (or better yet, 4.0) for an OSX computer? I've looked everywhere!
       
      Thank you for your time,
      Tumma K.
    • By MacSig
      Hello everyone.
      How can I set the calculated value of field C to the number of records having field A equal to the value inserted to field A and field B equal to the value inserted to field B?
       
      For instance with the following situation
       
      record 1  =>  A = "house", B = "pay" 
      record 2  =>  A = "house", B = "win" 
      record 3  =>  A = "car", B = "pay" 
      record 4  =>  A = "house", B = "pay" 
       
      when I create a new record having  A = "house", B = "pay"  C should automatically be 2 (since record 1 and 4 have the same A, B.
       
      Thanks
    • By MrEddByrnes
      I'm hoping my question can have a happy ending. In the mid-90's, I purchased Filemaker 3. When Filemaker 5.5 Pro was released, I bought the update CD, which requires the user to either have FM 3 installed or to have the installation CD for FM 3. I've used it all these years, most recently with Windows XP Pro, and it has worked just fine. The databases I began with were long ago converted to FM Pro 5.5 databases.
       
      I'm still using FM Pro 5.5 on a laptop with WinXP Pro, but in 2013, I purchased a PC with Windows 8. I haven't been able to install FM 3 on it, therefore can't install FM Pro 5.5. I am retired and rarely use Filemaker, but I have a few Filemaker databases I'd like to add to my Win 8 machine. I don't feel it's worth upgrading FM for the sake of using a couple of databases.
       
      Has anyone else run into this situation and/or have a (possible) solution? Is there perhaps any other software that can read FM 5.5 databases? Thanks in advance for your help.
       
    • By bmill
      I am using a custom filemaker solution for medical office billing written with fp5 running on a mac with snow leopard. In addition, I have a patient management db (which I wrote) that is linked through pt. ID number to the billing program allowing transfer of some demographic information (name, DOB, etc).
       
      Other than being limited by hardware restrictions, the billing program serves our needs for now and upgrading to fp12 will take some time (and money).  In the meantime, I am upgrading my pt. management program to fp13 and would like to move new patient demographic information from the billing program ( fp5 running on snow leopard through Parallels) and the new pt management program ( fp13 running on OS X 10.9) on the same mac.   
       
      Ideally, demographic information would be entered once into fp5 and then a scipt would make the data available for fp13.
       
      Any ideas on how to make this work?
  • Who Viewed the Topic

    1 member has viewed this topic:
    -Queue- 
×

Important Information

By using this site, you agree to our Terms of Use.