Jump to content

13.0v5 doesn't fix "incoming network connections" bug, adds a new bug -- but both are correctable!


This topic is 2015 days old. Please don't post here. Open a new topic instead.

Recommended Posts

I excitedly saw that 13.0v5 was just released, and it said that they were fixing the annoying "allow/deny incoming network connections" bug.

 

I dutifully upgraded.  Not only did the bug persist (!), but it introduced a new one -- for the database I access, I have the password saved to keychain, but it started asking me all the time to enter the password, and whether I wanted to save it to keychain.

 

Great.

 

But, I was able to fix both issues (yay!).

 

For the incoming network connections issue.  First,  quit FM.  Second, go to the Firewall settings on your Mac, and edit the options.  Remove FM's entry. Third, go to Terminal, and enter this command:

sudo codesign --force --sign - /Applications/FileMaker Pro 13/FileMaker Pro.app/

It will ask for your password.  Enter it.  It'll resign the app (which couldn't be done with the prior version).  The next time you start up FM should be the *last* time that you have to allow incoming network connections.

 

As to the other issue if you now have to enter your password every time to access your database, even though you specified for it to be saved in Keychain, this is what you need to do.  Again, quit FM, go to Keychain.  Search for "Filemaker".  Delete the password for your database in the list.  Start FM, enter your password, and say save it to Keychain.  Quit FM.  Go back to Keychain, search for "Filemaker" and click the info icon at the bottom.  Under "Access Control" it says "confirm before allowing access" -- but you'll notice that "always allow access by these applications" doesn't list FM.  Click the plus button.  Find the FM app, and select it.  Save changes. 

Start up FM, you should be fine!  

 

Link to post
Share on other sites

Hi Mike,

 

The Issue with a New Update... no taking Info from the Mac Key Chain... is not a bug.  FileMaker V Revs are not identified as being the same app as the previous app...at least initially by the Keychain.   It is confused.   

 

A restart of the Mac will clear the issue, and afterward... it will be able to access the Key Chain again.

 

- RC

Link to post
Share on other sites

Mike, there is no useful information in your post(sorry) for anyone who has followed the instruction to restart after installing the update. From what I can tell you neglected to do this before posting. That said, thank you for posting fixes for a set of problems. The problems do not occur when performing a restart after the upgrade before launching the updated software.

Link to post
Share on other sites

I stand by my post.

I've received 3 emails from people who did reboot and still had this problem, and my solution worked. This group is too quick to judge. I will stay quiet on the future and no longer post.

Link to post
Share on other sites

Mike, your post is good info.

We have a lot of users, that never reads instructions, like e.g. you need to reboot after applying the update.

So, I am sure we will get support calls when such users update and don't follow instructions.

I have written your tips into our knowledge base.

Thanks for sharing, and keep doing so in the future.

 

Richard, good to know, that if update instructions is followed, it should not cause such issues...

Link to post
Share on other sites

I stand by my post.

 

GOOD! You didn't do anything wrong. I’m disappointed in a couple of members who made it seem like you did. I hope they will go back and edit their posts to tone down the harsher stuff. On the good side, others thanked you for the heads up. 

 

 

 

This group is too quick to judge. I will stay quiet on the future and no longer post.

 

Regarding this post, I agree. 

 

IMHO, FileMaker needs to make the need to Restart after installation more obvious, or do like other software and tell you to close the application as you are starting the upgrade, or others instruct you to restart the application to finish the upgrade.

 

Lee
  • Like 1
Link to post
Share on other sites

This topic is 2015 days old. Please don't post here. Open a new topic instead.

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Similar Content

    • By Teilo
      So, the time has come. Runtime support is gone in 19.
      This puts me in a quandary. At my company, I have a handful of small apps that do nothing but import CSVs and print labels with barcodes on Zebra label printers, or packing slips with pictures for each item. These are one-off special purpose databases. There is no active data management. The scripts clear out the DB and import a fresh CSV on each run.
      I have tried making these applications work with Server, to no avail. I doubt anything has changed in 19.
      I can understand Claris wanting to move to an online subscription-based model, but the problem is that the server version is not at feature parity with the desktop client for certain essential things I need, like printing to a label printer, or exporting PDFs with images that come from a folder full of PNG files that change on each run.
      I have some time, obviously, but version 18 will not run forever, especially if Apple's shenanigans continue. Is Claris listening, or should I just assume that this is a lost cause?
    • By Russell Watson
      Hi Jeremiah,
      maybe this is a place we can pass Feedback to you about Carafe.FM?
      MrWatson
      Improvement: UX confusing when search finds nothing
      Hi Jeremiah,
      I'm still goggling at Carafe ... and loving every minute of it! In general fantastic job on the UX of the whole app! Congrats!
      One thing is confusing ... when you search for something and nothing is found there is no feedback ... I then made the mistake of thinking the two little arrows to the right of the search box are for navigating the search term ... but clicking them doesn't work ... and then I realised, that they are for sorting ...
      Solution idea: Visual feedback
      It would be great if there was some kind of visual feedback to let you know that nothing has been found.
      Maybe a (very) quick and dirty fix could simply be a conditional format on the search box -> goes red when error 401 is active. (See image)
      Thanks
      MrWatson
      P.S. Have you considered hosting the Carafe.FM FileMaker files on GitHub?
      You have your other Carafe-code on GitHub, why not the FileMaker files, too?
      OK, so they are binary files, but on GitHub we could leverage the Issue-tracking tools, and make use of pull requests, etc.?

    • By Joost Miltenburg
      Hi!
       
      using FM18v3 I defined an import, update using key with option :add remaining. 
      Odd enough, when running the import for the first time, the key field remains empty. (Unexpected)
      As a result the second time I run the script I get new records, but now the keyfieldfield is filled. (Expected) The third time the import also runs as expected ( no new records ).
      I fixed this by defining this script in FM18 using an if. Eventually, I launched FM17 and re-did the script. Now it works like it should. 
       
      Anyone else can replicate this?
       
      Kind regards,
    • By TaiChi56
      I have always developed with FileMaker for windows. I have bought myself a MacBook Air and love it. So now I am using FileMaker 16 Pro advance for MAC. I know that MAC does not label their directories like windows does. So I am having problems figuring out to get the right coding to access my photos. I have a folder called "Photos" that reside on the C: drive in windows. Then I reference that folder so pictures will populate automatically when I put in a record. Here is what I have on the windows fileMaker:
      ImagePath:
      Let ( [ // Transform the contents of a container field named Images to text ImageRef = GetAsText ( ImagePath); Photos = Position ( ImageRef; "/"; 1; PatternCount ( ImageRef; "/")) ]; Middle ( ImageRef; Photos + 1; Length ( ImageRef ) - Photos ) ) images:
      "imagewin:/C:/Photos/" & Film::title & ".jpg" Then I go into Import folder and point to the folder all the photos are in. The problem I have now is how to point to that folder in "imagewin", is their an alternative called imagemac, then I could put in Macintosh HD/Users/patricks/Documents.  The folder is in the Document folder, called Photos. Thank you for any help.
    • By Jonah74
      Am I righting in thinking I can use a case statement to evaluate two fields and return an answer into a third field ie: Field A has the number 27 in it. Field B has the number 32 in it.  Could the case statement look at the difference and put the difference in Field 3.The difference being 5? 
      I’m also trying to get this to do the math on data entry, so the figure in Field A is 27 but when the user enters the new figure in Field B (i.e 32), it looks at that difference between A and B, copies the difference of 5 to Field 3 and then also copies the figure 32 from Field B into Field A thereby updating Field A to the new value.
      Help, suggestions or thoughts will be greatly appreciated.

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.