Jump to content

Sending email from INSERT FROM URL is going to spam folder


This topic is 1634 days old. Please don't post here. Open a new topic instead.

Recommended Posts

I have started sending emails using the INSERT FROM URL method shown by soliant here:

https://www.soliantconsulting.com/blog/html-email-filemaker/

Emails are being sent out but many recipients seem to be getting my emails sent to their spam folders. I'm curious if this has anything to do with this method of sending emails.

Link to comment
Share on other sites

Usually this is because of the smtp server used or the content of the subject/message.  You have very little control over the spam filters on the receiving end, but some smtp servers (email providers) are better than others.

Link to comment
Share on other sites

Thanks Wim,

I'm using smtp.gmail.com. I've edited my dns records and added an SPF txt record as well as a DMARC record so I seem to be 'passing' the spam tests I've been doing.

Is there another smtp server I can easily send mail from instead of smtp.gmail.com? While still using this insert from url sending method?

Link to comment
Share on other sites

I also recommend a good transactional email service such as SparkPost you can either use their API or you can send mail by injecting it as SMTP just like your doing now, your just going to use a different set of credentials. 

 

Link to comment
Share on other sites

Ocean West, so with SparkPost... I could still send using insert from URL in FM? I just need to setup an account at SparkPost and use there SMTP server/credentials? Email will still appear to come from my email address?

Link to comment
Share on other sites

On 12/6/2019 at 6:23 AM, mvoogt said:

I have started sending emails using the INSERT FROM URL method shown by soliant here:

https://www.soliantconsulting.com/blog/html-email-filemaker/

Emails are being sent out but many recipients seem to be getting my emails sent to their spam folders. I'm curious if this has anything to do with this method of sending emails.

Most likely this has to do with the email server you are using not being setup in the SFP record of your email domain. If you are sending emails as [email protected] and sending using gmail's SMTP server, you need to setup the gmail SMTP servers in your SFP record. Other wise, receiving servers will check the SFP record, see that the sending server is not in it, and mark the email as potential spam.

Gmail usually gets around it by setting a flag "sending on behalf of...". But its possible this might not work when using direct SMTP.

The downside of including SMTP servers such as gmail in your SFP record is that anyone can then send emails on your behalf using gmail SMTP servers (if they know you've set that up).

Link to comment
Share on other sites

This topic is 1634 days old. Please don't post here. Open a new topic instead.

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.