Jump to content

WebDirect Deployment - Connection Refused - Yosemite


DDDan
 Share

This topic is 2838 days old. Please don't post here. Open a new topic instead.

Recommended Posts

I had to update my FM Server Mac to Yosemite and I cannot seem to enable web services. During deployment I get the message: Test web server (http://127.0.0.1:80/fmi-test/test.xml): Connection refused

(Please note that this is different from 'ports are in use' which is the other common error;-)

 

I can install and deploy FM Server 13.05 without a problem, I just can't enable web services. I did a lot of testing, de-installed, manually deleted the Library-FM server folder, etc. Re-installed, etc. (when I re-install I did get the message port 80 and 443 are in use, and did choose disable web sites) Also tried port 591 as suggested by FM, same error. (also tried 8000, to be honest I don't care on which port it is web serving, I can remap that in the router)

The problem seems to lie in Yosemite switching off access to port 80 (and others). I also have Apple Server Tools so I tried the following: I switched on Web services and then I can access the ports on my local network and you get the default website.

(before somebody warns me that I shouldn't use Apple Server, I first tried to get it to work without Server tools installed. And when I was still using 10.8 they co-existed very peacefully, as long as you did not switch on Apple's web services, I need them for some other stuff)

When I try to deploy FM Web direct while having on Apple's web services, I get the correct 404 error because the ports are in use (by Apple's web services) When I switch off web services again then I get error 403 (instead of connection refused) but that means almost the same. (forbidden) 

When I then try to access port 80 from my local network it says 'websites are turned off'. kind of suggesting that the ports are closed on the server now.

Please note it is not a firewall issue, I am deploying FM Server from the same mac as it is running. (localhost) I have no (software)FW enabled on that Mac. I guess I am looking for a unix command to tell Yosemite that it should allow access of ports 80 and 443...

Any suggestions, work around, unix commands are appreciated... I have wasted almost a day now... 

Daniel

Link to comment
Share on other sites

Hi DDDan

It is important that you do it in the correct order...

When you are "touching" Apple Server App, it will tell launch service of the OS, that the OS should use Apple's Apache settings. Even if you turn off websites.

So, when you think you are trying to access any FMS web service, you are accessing Apache with, whatever Apple settings are in place.

The "trick" is to turn off all web services in the Apple Server App. Close it and don't open it again.

Then you need to tell the launch services that it should use FMS13 settings for Apache and then restart Apache, in order to make the change work.

I would then, from FMS UAC, do a re-deployment and turn on web services.

After this, it should work.

 

You can read about commands and other information in my virtual host guide+tool here:

http://www.datamanix.com/news/files/FMS-virtualhost-guide-tool-v2.html

  • Like 1
Link to comment
Share on other sites

Hi Claus

Thanks a lot for your quick reply and help. I just downloaded the mentioned document. I just wanted to say a quick thank you and will let you know how it goes. Might take a couple of days, this issue is on my home server which is there for testing, and coming days I am out working for clients. But I got something to read ;-) 

 

Just for clarity: I first installed and deployed FMS13 before I did anything with Apple's Server Tools (AST). I hadn't even installed them because I know about the issues between FMS and AST. Only after trying everything with FMS13 (de-install, re-install,etc) I could think if I wanted to see if AST would enable website hosting. 

 

Thanks again, will revert back with hopefully good news in a couple of days!

 

Daniel

Link to comment
Share on other sites

Hi Claus,

Today I went through your documentation and tools. But the more I read it, the more I had the feeling that this was far beyond what I need. Thing is, I do not use OSX Server for hosting websites, and I keep the website services switched off. I mainly use it for VPN, proper file sharing, and testing. Having said that I tried to go through your instructions, but stopped somewhere halfway when it was mentioned that I needed to have the documents for the virtual hosts in the right locations. That is unknown territory for me. 

I would just like to know why FM web direct does not want to start, and if there is a 'relative' simple way to make it work, keeping in mind that the only web service I want to host, is FM web direct. (don't mind modifying http documents or terminal commands)

As explained I am doing this on my test server at home, because before I promote this technique with clients I want to be sure that it is manageable. But I have my doubts...  I hope you have a simpler suggestion... ;-)

But anyway thanks for your help...

Link to comment
Share on other sites

Hi Claus, OK I tried the launch service and graceful commands, stop ams, restart, etc. did not help.

Then I de-installed FMS completely, removed everything that the uninstaller does not remove manually, restarted, installed the whole thing from scratch, re-installed, same thing happens. (connection refused on port 80) Guess there is something wrong somewhere else in the OS. Updated Java, etc. but no way to get it to work. (this is all with OSX web Server tools switched off)

Guess best thing is to do a fresh install of Mac OSX... 

 

Thanks for your help. 

Link to comment
Share on other sites

FMS13 require Java 7 (NOT java 8)

If the latter is installed, un-install and use java7

 

You could turn off apache, which should help FMS installer to take over apache.

Use this command in the Terminal:

sudo apachectl stop

 

Then use the FMS installer.

 

Before that, un-install FMS with the installer.

After that, trash the entire FileMaker Server folder in /Library/

Link to comment
Share on other sites

Hi Claus,

Really appreciate your efforts, but I formatted my drive, installed Mavericks (for now) and am installing FMS updates one by one. First deployed, tested if everything works, and it does, and now make a full disk image backup before every next step. (this is how I work for clients, but for my own server I tend to 'live dangerous', but lesson learned ;-) 

Haven't installed server tools yet, first make sure that FMS is working with web direct. Once everything works and I have  backup I'll update to Yosemite, and last step is the server tools, but now I can always go back to my backups. 

And yes, I know Java 7 is the supported version, but if everything fails, you tend to try what the British so nicely call a 'drowning man's solution'. In the past, with <FM11 often updating Java would fix weird connection problems. But I think my OS was really confused, at a certain moment when I started FMS admin it would say that the same serial number is already running on my server... Really weird, because I know you need to stop the server before any update, and otherwise the updater won't let you. Wouldn't know how to start FMS multiple times on one server!

 

But I've learned a thing or two from your input, and I keep all these tips and good to know unix commands on file for the future use. 

 

All the best, Daniel

Link to comment
Share on other sites

Hi again,

discovered some things you might find good to know... I've got it all working in Yosemite, even after I installed the server tools. (leaving web services off) That all works. There is however a new screen in server tools called 'access'. It is like a port based firewall where you can define through which ports access is allowed to the server and by which users.  As soon as you set something in that screen it apparently enables this firewall and from that moment on web direct stops working. Hence the 'connection refused' message.

So for now I went back to a backup of the system without the server tools. 

 

Another thing I discovered is that in Yosemite you can get the message 'Another copy of FileMaker Server is already running with this license' after you've manually stopped the server in the admin tools. The message is a bit misleading, it is not running twice, the server just lost it's license details. Re-entering the license details immediately enables all services. weird thing that didn't happen in Mavericks, but started as soon as I had updated to Yosemite. (this was after formatting the drive, installing a new system and FMS 13.05, nothing else, and upgrading..)

 

The joy of computers!

Daniel

Link to comment
Share on other sites

This topic is 2838 days old. Please don't post here. Open a new topic instead.

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.